• FORUMU MOBİL UYGULAMADAN TAKİP EDİN

    Forumu isteyen üyelerimiz Tapatalk (Harici bir hizmet) üzerinden mobil uygulamadan takip edebilirler.
    iOS için : https://itunes.apple.com/app/id307880732?mt=8
    Android için : https://play.google.com/store/apps/details?id=com.quoord.tapatalkpro.activity
    adreslerinden indirebilirsiniz.

    Bir iki haftaya da foruma özel kendi uygulamamız yayında olacak.
ALTIN ÜYELİK Hakkında Bilgi
-----------------------

Çözüldü Pivot ile Saat Aralığı Saydırma,

gicimi

Altın Üye
Altın Üye
Katılım
3 Şubat 2008
Mesajlar
263
Beğeniler
12
Excel Vers. ve Dili
Office 2016 Eng. 64 Bit
#1
Merhaba;

Ekteki Çalışma için yardımcı olabilir misiniz. Teşekkürler

Pivot yardımı ile saat aralığına göre saydırmak istiyorum. Farklı bir yöntem olarakta formül ile de yardımcı olabilir misiniz.
 

Ekli dosyalar

Katılım
8 Mart 2011
Mesajlar
11,021
Beğeniler
124
Excel Vers. ve Dili
Office 2013 TÜRKÇE
#2
Merhaba.

C1 hücresine ARALIK diye bir başlık ekleyin ve C2 hücresine aşağıdaki formüllerden birini uygulayıp, liste boyunca kopyalayın.
Ardından da A1:C11 hücre aralığını (veri alanı) seçip EKLE=>ÖZET TABLO şeklinde işlem yapın.
Özet tablonun satır, sütun ve değerler kısmına ilgili alan isimlerini sürükleyin.
İstediğiniz sonucu elde edersiniz.
.
=YİNELE("0";(SAAT(B2)<10))&SAAT(B2)&"-"&YİNELE("0";(SAAT(B2)+1<10))&SAAT(B2)+1
=ARA(SAAT(B2);{0;10};{0;""})&SAAT(B2)&"-"&ARA(SAAT(B2)+1;{0;10};{0;""})&SAAT(B2)+1
 
Katılım
8 Mart 2011
Mesajlar
11,021
Beğeniler
124
Excel Vers. ve Dili
Office 2013 TÜRKÇE
#3
Formül ile sonuç almak istiyorsanız da aşağıdaki formüllerden birini G3 hücresine uygulayıp sağa ve aşağı kopyalayın.
-- Birinci formül yardımcı sütunu (önceki cevabımda C sütunu için önerdiğim formülü) kullanmadan sonuç almanızı sağlar,
-- İkinci formül ise önceki cevabımda belirttiğim C sütununa formül uygulamanız halinde sonuç verir.
=TOPLA.ÇARPIM((SAAT($B$2:$B$11)>=0+SOLDAN(G$2;2))*(SAAT($B$2:$B$11)<0+SAĞDAN(G$2;2))*($A$2:$A$11=$F3))
=TOPLA.ÇARPIM(($C$2:$C$11=YERİNEKOY(G$2;" ";""))*($A$2:$A$11=$F3))
 

gicimi

Altın Üye
Altın Üye
Katılım
3 Şubat 2008
Mesajlar
263
Beğeniler
12
Excel Vers. ve Dili
Office 2016 Eng. 64 Bit
#6
@İdris SERDAR alternatif için teşekkür ederim. Kolaylıklar.
 
Üst