Farklı sayfalardan koşula göre veri çekme

kimki

Altın Üye
Altın Üye
Katılım
10 Nisan 2011
Mesajlar
63
Beğeniler
0
Excel Vers. ve Dili
Excel 2016
#1
Herkese selam,
Örnek dosya için 6 farklı data sayfam mevcut, özet sayfasında ise data ismini seçebileceğim hücre var. Buradan seçtiğim dataya ait verilerin tabloma yazdırmasını istiyorum. Makro yada formül her türlü yardımlarınızı kabul ederim. Data sayfalarım artabilir örnek olsun diye 6 tane ekledim.

Umarım anlaşılır olmuştur, örnek dosyasmı ekledim. Yardımlarınız ricasıyla. Kolay gelsin.
 

Ekli dosyalar

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
4,652
Beğeniler
746
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#2
Özet Sayfası A4 Hücresine kopyalayınız.Yeterince sağa ve aşağı doğru çoğaltınız.Hücre biçim ayarlarını yapınız.
Kod:
=EĞER(DOLAYLI("'"&$B$1&"'!"&ADRES(SATIR($A3);SÜTUN(A$1)))="";"";DOLAYLI("'"&$B$1&"'!"&ADRES(SATIR($A3);SÜTUN(A$1))))
 

kimki

Altın Üye
Altın Üye
Katılım
10 Nisan 2011
Mesajlar
63
Beğeniler
0
Excel Vers. ve Dili
Excel 2016
#3
Özet Sayfası A4 Hücresine kopyalayınız.Yeterince sağa ve aşağı doğru çoğaltınız.Hücre biçim ayarlarını yapınız.
Kod:
=EĞER(DOLAYLI("'"&$B$1&"'!"&ADRES(SATIR($A3);SÜTUN(A$1)))="";"";DOLAYLI("'"&$B$1&"'!"&ADRES(SATIR($A3);SÜTUN(A$1))))
Hocam ilginiz için çok tşk. ederim. Bunun üzerine 2 sorum daha olacak ;
1 - Özet sayfasındaki ilk 3 sütunum sabit olacak, Zone-Terr Kod - Terr Ad sabit. D4 hücresinden başlayıp değeri olmayan bölge "-" ile gösterilebilir.
2 - Dataların bazılarının biçimi sayı, bazıları % , bunları her seferinde düzeltmek gerekecek bunun için yapabilecek birşey var mı ?
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
4,652
Beğeniler
746
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#4
İlk 3 sütunun sabit kalmasının mahsurları:
Dosyanızdaki tüm sayfalar aynı yapıda olur ise formülü kopyalayıp , biçimlendirmeyi yaptıkdan sonra tekrar biçimlendirme yapmaya gerek olmaz. Ançak dosyanızda 2 farklı yapı var bu sorun oluşturabilir bazı sayfalarda toplam var ve A1,A2......A8 den A10 olurken diğer sayfada A1,A2 ......An sıralı gitmekde bu da şablonla uyuşmama sorunu olabilir.
Dosyalarınızın yapısını düzenler iseniz.
D4 Kopyalayıp biçimleri birkez düzenlediğinizde tekrar düzenleme gerekmez.
Kod:
=EĞER(DOLAYLI("'"&$B$1&"'!"&ADRES(SATIR($A3);SÜTUN(D$1)))="";"-";DOLAYLI("'"&$B$1&"'!"&ADRES(SATIR($A3);SÜTUN(D$1))))
 

kimki

Altın Üye
Altın Üye
Katılım
10 Nisan 2011
Mesajlar
63
Beğeniler
0
Excel Vers. ve Dili
Excel 2016
#5
Anladım, diğer sayfaları aynı formata çevirdim sıkıntı yok onda.Ancak datalar arası geçiş yaptığımda biçim değişmiyor, % olanı düzelttiğimde sayı olanda aynı kalıyor. örnekteki gibi dosya ekledim.
 

Ekli dosyalar

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
4,652
Beğeniler
746
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#6
Data2 sayfasında ad tanımla alanına (resim1) A3:AL42 yazın ve enterleyin seçili olur.Kopyala yapınız.Özet sayfası A3 de özel yapıştır.Biçimleri yapınız (resim2) sayfaların biçimleri sabitlenmiş olur.
 

Ekli dosyalar

Üst