En Yakın Büyük Değeri Bulma

Katılım
12 Temmuz 2017
Mesajlar
25
Excel Vers. ve Dili
excel 2010
Arkadaşlar Merhaba,
DÜŞEYARA formülünde aranan değere en yakın küçük değer yerine en yakın büyük değer nasıl bulunur? Teşekkürler
 

Haluk

Özel Üye
Katılım
7 Temmuz 2004
Mesajlar
10,384
Excel Vers. ve Dili
64 Bit 2010 - İngilizce
Liste sıralı mı?

.
 

uzmanamele

Uzman
Uzman
Katılım
26 Eylül 2007
Mesajlar
8,857
Excel Vers. ve Dili
excel 2010
Merhaba,
Bunu deneyiniz.

230424

=EĞERHATA(DÜŞEYARA(C2;A1:B6;2;0);İNDİS(A1:B6;KAÇINCI(DÜŞEYARA(C2;A1:B6;2;1);B1:B6;0)+1;2))
 

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
33,783
Excel Vers. ve Dili
Microsoft 365 Tr-En 64 Bit
Ofis 2016 Tr-En 32 Bit
Deneyiniz.

A sütununda 10 değerini ">=" mantığı ile arar. Karşılığında B sütunundaki değeri döndürür.

C++:
=ARA(2;1/(A1:A100>=10);B1:B100)

Bu da alternatif DİZİ formüldür.

C++:
=İNDİS(B1:B100;KÜÇÜK(EĞER(A1:A100>=10;SATIR(A1:A100));1))
 
Katılım
12 Temmuz 2017
Mesajlar
25
Excel Vers. ve Dili
excel 2010
Deneyiniz.

A sütununda 10 değerini ">=" mantığı ile arar. Karşılığında B sütunundaki değeri döndürür.

C++:
=ARA(2;1/(A1:A100>=10);B1:B100)

Bu da alternatif DİZİ formüldür.

C++:
=İNDİS(B1:B100;KÜÇÜK(EĞER(A1:A100>=10;SATIR(A1:A100));1))
Korhan Ayhan merhaba
Size de teşekkür ederim
 
Katılım
12 Temmuz 2017
Mesajlar
25
Excel Vers. ve Dili
excel 2010
Arkadaşlar tekrar merhaba,

peki bu formüle ek olarak uzmanamele'nin tablosundan örnek ile 8 rakamını arıyorsak bize d+d yada f+b sonucunu nasıl verir
 

ÖmerFaruk

Altın Üye
Katılım
22 Ekim 2017
Mesajlar
2,870
Excel Vers. ve Dili
Ofis 365 Türkçe
Bir sonraki aşamada sorunuz bu şekilde gelişecek mi?
9 için c+f ya da b+g
10 için c+g
21 için g+g+g
 
Üst