=ÇOKETOPLA Formülü 1'den fazla toplam sütunu belirlenince hata veriyor

Katılım
26 Ocak 2007
Mesajlar
3,841
Beğeniler
23
Excel Vers. ve Dili
Ofis 2016
#1
Merhaba Arkadaşlar,

ÇOKETOPLA formülüne toplam alınacak alan olarak sadece 1 sütun mu tanımalanabilir. 1'den fazla sayıda sütunun toplamını tek formülle bulmanın yolu var mıdır ?
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
4,396
Beğeniler
668
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#5
Bildiğim kadar çoketopla da eşit sayıda sütun olmalı.Dizi formülü olmadan.Topla.çarpım kullanılmadan.Etopla ile aşağıdaki şekilde olabilir.Düşünceme göre.Başka çözümler belki arakadaşlardan gelebilir.
Kod:
=ETOPLA(DEPO!$B$2:$B$6;A2;DEPO!$C$2:$C$6)+ETOPLA(DEPO!$B$2:$B$6;A2;DEPO!$D$2:$D$6)+ETOPLA(DEPO!$B$2:$B$6;A2;DEPO!$E$2:$E$6)
 
Katılım
26 Ocak 2007
Mesajlar
3,841
Beğeniler
23
Excel Vers. ve Dili
Ofis 2016
#6
Bildiğim kadar çoketopla da eşit sayıda sütun olmalı.Dizi formülü olmadan.Topla.çarpım kullanılmadan.Etopla ile aşağıdaki şekilde olabilir.Düşünceme göre.Başka çözümler belki arakadaşlardan gelebilir.
Kod:
=ETOPLA(DEPO!$B$2:$B$6;A2;DEPO!$C$2:$C$6)+ETOPLA(DEPO!$B$2:$B$6;A2;DEPO!$D$2:$D$6)+ETOPLA(DEPO!$B$2:$B$6;A2;DEPO!$E$2:$E$6)
Teşekkürler üstad. ÇOKETOPLA formülü veya 1'den fazla sayıda ölçüt kullanılabilecek bir formül gerekiyor !
bence de Dizin formülü gerekir sanırım !
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
4,396
Beğeniler
668
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#7
Topla.çarpım kullansnız olmaz mı?
Kod:
TOPLA.ÇARPIM((DEPO!$B$2:$B$6=$A2)*(DEPO!$C$2:$E$6))
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
4,396
Beğeniler
668
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#9
hiç olmaz mı üstadım. çok denedim ama sizin kurduğunuz formülü kuramamıştım. çıtır üstadım çok çok teşekkür ediyorum. Sağlıcakla kalın
Rica ederim.Dönüş yaptığınız için teşekkür ederim.Bilmukabele.
 
Üst