Boşlukları da "Hepsi" Kapsamına Aldırmak

Katılım
26 Ocak 2007
Mesajlar
3,841
Beğeniler
23
Excel Vers. ve Dili
Ofis 2016
#1
Merhaba Arkadaşlar,

ÇOKETOPLA formülünde tanımlı alandaki veri için seçim yapıldıysa o veriyi dikkate al, kriter verilmediyse "*" hepsini al şeklinde formül kurmak istiyorum. Ama Koşul aralığında hücre boşsa o hücreleri dikkate almıyor. Boş hücreleri HEPSİ kriterinde sayıma dahil etmenin bir yolu var mıdır ?

örnek dosya linki : https://yadi.sk/i/ZI91BXB_b5Y9hQ
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
4,396
Beğeniler
668
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#2
Deneyiniz.
Kod:
=EĞERSAY($K$2:$K$7;$A2&"")
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
4,396
Beğeniler
668
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#4
Yanılıyor olabilirim ben 1 koşul gördüm A sütundaki değerlere eşit olanların sayısı.Diğer koşulunuz veya koşullarınız nedir?
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
4,396
Beğeniler
668
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#7
Size göre kaç bulması ve hangi satıra yazması gerekli.
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
4,396
Beğeniler
668
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#9
Deneyiniz.
Kod:
=EĞER(KAYIT!$A2="";EĞERSAY(KAYIT!$L$2:$L$8;"<>");ÇOKEĞERSAY(KAYIT!$K$2:$K$8;KAYIT!$A2;KAYIT!$L$2:$L$8;">0"))
 
Katılım
26 Ocak 2007
Mesajlar
3,841
Beğeniler
23
Excel Vers. ve Dili
Ofis 2016
#10
çıtır üstadım çok teşekkür ederim. Bu çözümü uygulayacağım.
 
Üst