Tarif edemiyorum, uzun uzun anlatcam, anlayıp yardımcı olmak isteyenler gelsin :D

Katılım
1 Ağustos 2019
Mesajlar
4
Beğeniler
0
Excel Vers. ve Dili
Son versiyon, Türkçe
#1
Merhaba,
Özel bir şirkette muhasebe departmanında çalışıyorum. Ve işim gereği ithalat ihracat raporu hazırlıyorum. Şimdi hali hazırda bir excell sayfası ile size durumu anlatmaya çalışacağım.
Yaptığımız iş gereği yurt dışından ham maddeyi alıyoruz yani ithal ediyoruz. Ve işleyip tekrar ihraç ediyoruz. İthal olarak aldığımız miktar ve ihraç olarak çıkan miktarla aynı. Fakat ben bu ithal aldığım malları ihracat olarak çıkarırken ithal aldığım gibi tek seferde çıkarmıyorum. ÖRN: 18 ton ithal mal aldım, işledim ve ilk ay içinde 5 ton, ikinci ay içinde 10 ton, üçüncü ay içinde de 3 ton göndererek işlemi tamamlıyorum. Fakat ben ithal ettiğimiz malın ne kadarını gönderdik ne kadarının halen elimizde olduğunu yani halen göndermediğimizi görmek için bir formül yazmak istiyorum. Yani ithal olarak gelen malı ihraç olarak çıkarırken ne kadar gitti ne kadar kaldı onu görmek istiyorum.
Senaryo kısmından sonra işin excell kısmına değineyim; tam olarak şöyle bir şey yapmak istiyorum (tabii mümkün ise:D) Ben P hücresine bu formülü yazmak istiyorum.
" Eğer A hücresindeki ITHALAT'ın 'G' hücresindeki değeri, A hücresindeki IHRACAT'ın 'G' hücresindeki değerine eşitse, A hücresindeki ITHALAT'ın L hücresindeki değerinden, A hücresindeki IHRACAT'ın L hücresindeki değeri çıkar ve sonuca yaz.

Çalışmanın taslağının linki; https://s4.dosya.tc/server6/6ha435/Kitap1.xlsx.html Saygılarımla..
 
Son düzenleme:

Necdet

Moderatör
Yönetici
Katılım
4 Haziran 2005
Mesajlar
12,656
Beğeniler
121
Excel Vers. ve Dili
Ofis 2003 İngilizce
Ofis 2007 Türkçe
Ofis 2010 Türkçe
#2
Merhaba,

Tek bir ürün adını göremedim. Sadece ithal ve ihraç ürün kodu var. Dolayısıyla ithal edilen ve ihraç edilen ürünün karşılaştırılması olası değil.
Bu durumda isteğiniz olası değil.

Ya da siz kendiniz ihraç ve ithal ürün kodundan başka ürünün açık adını da belirtmeniz gerekir.
 
Katılım
1 Ağustos 2019
Mesajlar
4
Beğeniler
0
Excel Vers. ve Dili
Son versiyon, Türkçe
#3
Merhaba,

Tek bir ürün adını göremedim. Sadece ithal ve ihraç ürün kodu var. Dolayısıyla ithal edilen ve ihraç edilen ürünün karşılaştırılması olası değil.
Bu durumda isteğiniz olası değil.

Ya da siz kendiniz ihraç ve ithal ürün kodundan başka ürünün açık adını da belirtmeniz gerekir.
Şöyle söyleyeyim, açıklamamın eksik olduğunu fark ettim, aslında ürünün ne olduğuyla veya adıyla bir karşılaştırma olmaması lazım. Bu excelldeki bütün işlemlerin hepsi aynı ürün. İthalat ve ihracatta beyanname numaralarıyla giriş ve çıkış yapılır. Giren beyanname numarası yani ithalat beyanname numarası, çıkan beyanname numarasından yani ihracat beyanname numarasından farklıdır. Fakat aynı ürünün işlemi olduğu için, karşılaştırmayı yapmak için ithalat beyanname numarasını bütün işlemlere yazıyoruz.
 

Necdet

Moderatör
Yönetici
Katılım
4 Haziran 2005
Mesajlar
12,656
Beğeniler
121
Excel Vers. ve Dili
Ofis 2003 İngilizce
Ofis 2007 Türkçe
Ofis 2010 Türkçe
#4
O zaman İthal edilen miktarları toplayap, ihraç edilen miktarları çıkartmak istiyorsunuz. Doğru mu anladım?
Eğer öyleyse TOPLA.ÇARPIM yada ETOPLA fonksiyonlarını kullanabilirsiniz.
 
Katılım
8 Nisan 2010
Mesajlar
112
Beğeniler
50
Excel Vers. ve Dili
Office 2007 -2016 TR
#5
Aşağıdaki formülü P4 hücresine yazıp aşağıya doğru sürükleyin.

C#:
=ÇOKETOPLA($L$4:L4;$A$4:A4;"ITHALAT";$G$4:G4;G4)-ÇOKETOPLA($L$4:L4;$A$4:A4;"IHRACAT";$G$4:G4;G4)
 
Katılım
1 Ağustos 2019
Mesajlar
4
Beğeniler
0
Excel Vers. ve Dili
Son versiyon, Türkçe
#6
Aşağıdaki formülü P4 hücresine yazıp aşağıya doğru sürükleyin.

C#:
=ÇOKETOPLA($L$4:L4;$A$4:A4;"ITHALAT";$G$4:G4;G4)-ÇOKETOPLA($L$4:L4;$A$4:A4;"IHRACAT";$G$4:G4;G4)
ÖNCELİKLE ÇOK ÇOK TEŞEKKÜRLER. FAKAT BU KODU AŞAĞI SÜRÜKLEMEDEN YANİ BİLGİLERİ GİRDİĞİMDE OTOMATİK OLARAK GELECEK ŞEKİLDE AYARLAYABİLİR MİYİZ?
 
Katılım
8 Nisan 2010
Mesajlar
112
Beğeniler
50
Excel Vers. ve Dili
Office 2007 -2016 TR
#7
ÖNCELİKLE ÇOK ÇOK TEŞEKKÜRLER. FAKAT BU KODU AŞAĞI SÜRÜKLEMEDEN YANİ BİLGİLERİ GİRDİĞİMDE OTOMATİK OLARAK GELECEK ŞEKİLDE AYARLAYABİLİR MİYİZ?
Zaten bir defaya mahsus sürükleyeceksin (aşağıya fazla sürükle), Eğer makro istiyorsanız aşağıdaki kodu sayfanın kod bölümüne yazınız. Kalan sütununa değer girdikçe otomatik gelecektir.

C#:
Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Column <> 12 Or Target.Count > 1 Then Exit Sub
Application.EnableEvents = False
Dim wF As WorksheetFunction: Set wF = WorksheetFunction
ithalat = wF.SumIfs(Range("L4:L" & Target.Row), Range("A4:A" & Target.Row), "ITHALAT", Range("G4:G" & Target.Row), Range("G" & Target.Row))
ihracat = wF.SumIfs(Range("L4:L" & Target.Row), Range("A4:A" & Target.Row), "IHRACAT", Range("G4:G" & Target.Row), Range("G" & Target.Row))
    Cells(Target.Row, "P") = ithalat - ihracat
Application.EnableEvents = True
End Sub
 
Katılım
1 Ağustos 2019
Mesajlar
4
Beğeniler
0
Excel Vers. ve Dili
Son versiyon, Türkçe
#8
Zaten bir defaya mahsus sürükleyeceksin (aşağıya fazla sürükle), Eğer makro istiyorsanız aşağıdaki kodu sayfanın kod bölümüne yazınız. Kalan sütununa değer girdikçe otomatik gelecektir.

C#:
Private Sub Worksheet_Change(ByVal Target As Range)
If Target.Column <> 12 Or Target.Count > 1 Then Exit Sub
Application.EnableEvents = False
Dim wF As WorksheetFunction: Set wF = WorksheetFunction
ithalat = wF.SumIfs(Range("L4:L" & Target.Row), Range("A4:A" & Target.Row), "ITHALAT", Range("G4:G" & Target.Row), Range("G" & Target.Row))
ihracat = wF.SumIfs(Range("L4:L" & Target.Row), Range("A4:A" & Target.Row), "IHRACAT", Range("G4:G" & Target.Row), Range("G" & Target.Row))
    Cells(Target.Row, "P") = ithalat - ihracat
Application.EnableEvents = True
End Sub
Miktar sütununa değer girdikçe kalan sütununun otomatik olarak değişmesi gerekiyor.Bu mümkün müdür?
 
Üst