Çözüldü Koşullu veri çağırma

Katılım
3 Temmuz 2005
Mesajlar
265
Beğeniler
4
Excel Vers. ve Dili
excel 2019 tr
#1
İyi günler....
Eklediğim dosyada da görüleceği üzere;
Personele ait icra kesinti tutarının, K2 hücresinde yazılı ay ile İCRALIK sayfasındaki ay eşleştirilerek, İCRALIK sayfasından getirilmesi..

Dosya..
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
4,652
Beğeniler
746
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#2
Personel I2 hücresine kopyalayınız.Aşağı doğru çoğaltınız.
Kod:
=EĞERHATA(İNDİS(İCRALIK!$G$1:$V$30;TOPLAMA(15;6;(SATIR($A$3:$A$50)/(İCRALIK!$B$3:$B$50=$B2));SATIR($A$1));KAÇINCI(TARİH(YIL($K$2);AY($K$2);1);İCRALIK!$G$2:$V$2;0));"")
 

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
24,656
Beğeniler
438
Excel Vers. ve Dili
OFFICE 2019 PRO TR
#5
Alternatif;

Kod:
=EĞERHATA(YATAYARA(TARİH(YIL($K$2);AY($K$2);1);İCRALIK!$A$2:$X$21;KAÇINCI($B2;İCRALIK!$B$2:$B$21;0);0);0)
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
4,652
Beğeniler
746
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#7
I2 Hücresine kopyalayınız.Aşağı doğru çoğaltınız.
Kod:
=EĞERHATA(İNDİS(İCRALIK_2!$B$7:$I$30;KAÇINCI(TARİH(YIL($K$2);AY($K$2);1);KAYDIR(İCRALIK_2!A7;;KAÇINCI($B2;İCRALIK_2!$B$1:$I$1;0);24));KAÇINCI($B2;İCRALIK_2!$B$1:$I$1;0)+1);"")
 
Üst