• FORUMU MOBİL UYGULAMADAN TAKİP EDİN

    Forumu isteyen üyelerimiz Tapatalk (Harici bir hizmet) üzerinden mobil uygulamadan takip edebilirler.
    iOS için : https://itunes.apple.com/app/id307880732?mt=8
    Android için : https://play.google.com/store/apps/details?id=com.quoord.tapatalkpro.activity
    adreslerinden indirebilirsiniz.

    Bir iki haftaya da foruma özel kendi uygulamamız yayında olacak.
ALTIN ÜYELİK Hakkında Bilgi
-----------------------

Soru Girilen sayıyı Belirtilen sayılara bölme

kuvari

Destek Ekibi
Destek Ekibi
Katılım
4 Mayıs 2007
Mesajlar
2,714
Beğeniler
6
Excel Vers. ve Dili
OFİS 2013 TÜRKÇE-İNG. 64 BİT
#21
Sayın Çıtır merhaba,

Güzel sözleriniz için teşekkür ederim.Excel varsa imkansızlar değişebilir.
 
Katılım
8 Mart 2011
Mesajlar
11,029
Beğeniler
124
Excel Vers. ve Dili
Office 2013 TÜRKÇE
#22
Tebrikler Sayın @kuvari .

Bir hususu fark ettim;
hedef sayı olarak 3.513 kullanıldığında formülün sonucu 1 ve 182 (hedef sonuca ulaşma bakımından sorun yok elbette)
ancak çözüm için bir de (100,5 x 26) + (18,75 x 48) = 3.513 seçeneği var (20 numaralı cevapta verdiğim makronun sonucudur).
 
Son düzenleme:

kuvari

Destek Ekibi
Destek Ekibi
Katılım
4 Mayıs 2007
Mesajlar
2,714
Beğeniler
6
Excel Vers. ve Dili
OFİS 2013 TÜRKÇE-İNG. 64 BİT
#23
Ömer bey iyi akşamlar,

Konuyu açanın talebi ile 10. mesajda'ki formülü 17. no'lu mesaj'ta revize ettim, sanırım görmediniz.
 
Son düzenleme:

kuvari

Destek Ekibi
Destek Ekibi
Katılım
4 Mayıs 2007
Mesajlar
2,714
Beğeniler
6
Excel Vers. ve Dili
OFİS 2013 TÜRKÇE-İNG. 64 BİT
#24
Makro ile alternatif çözüm.

Kod:
Sub hesapla()

x = Int([A3] / [B1])

Do
x = x - 1
deg = ([A3] - ([B1] * x)) / 18.75
Loop While (deg / Int(deg)) <> 1

[B4] = x
[C4] = deg

End Sub
 
Katılım
8 Temmuz 2015
Mesajlar
12
Beğeniler
0
Excel Vers. ve Dili
2013 - TR
#25
Merhaba.

Makro ile çözüme alternatif olsun.
Rich (BB code):
Sub HESAPLA_BUL()
b = WorksheetFunction.Max([B1:C1]): k = WorksheetFunction.Min([B1:C1])
tam = Int([A3] / b) + 1
For kk = tam To 1 Step -1
    tam = tam - 1: kkk = ([A3] - b * tam) / k
    If Int(kkk) = kkk Then Exit For
Next
If tam = 0 And Int(kkk) <> kkk Then
    MsgBox "Verilen sayılara göre SONUÇ YOK"
Else
    MsgBox "-- Büyük sayıdan " & tam & " adet," & vbLf & _
        "-- Küçük sayıdan " & kkk & " adet" & vbLf & vbLf & vsLf & _
        Format([A3], "#,##0.00") & " = ( " & b & " x " & tam & " ) + ( " & k & " x " & kkk & " )"
End If
End Sub
emeği geçen herkese teşekkürler. en doğru ve net sonuçları bu makro ile aldım. Allah razı olsun hepinizden.
 

kuvari

Destek Ekibi
Destek Ekibi
Katılım
4 Mayıs 2007
Mesajlar
2,714
Beğeniler
6
Excel Vers. ve Dili
OFİS 2013 TÜRKÇE-İNG. 64 BİT
#26
Merhaba,

17 no'lu mesajda paylaştığım formülü denediniz mi?

Kod:
=EĞER(SÜTUN()=2;MAK((DÇARP(--((($B$2*SATIR($1:$1000))+DEVRİK_DÖNÜŞÜM($C$2*SATIR($1:$1000)))=$A$4);SATIR($1:$1000)^0))*SATIR($1:$1000));($A$4-(A$4*$B$2))/$C$2)
 
Katılım
8 Temmuz 2015
Mesajlar
12
Beğeniler
0
Excel Vers. ve Dili
2013 - TR
#27
Merhaba,

17 no'lu mesajda paylaştığım formülü denediniz mi?

Kod:
=EĞER(SÜTUN()=2;MAK((DÇARP(--((($B$2*SATIR($1:$1000))+DEVRİK_DÖNÜŞÜM($C$2*SATIR($1:$1000)))=$A$4);SATIR($1:$1000)^0))*SATIR($1:$1000));($A$4-(A$4*$B$2))/$C$2)
denedim üstad. hata aldım. belki ben de uyarlayamamış olabilirim. Birşey diyemem. Teşekkürler emeğine sağlık.
 

kuvari

Destek Ekibi
Destek Ekibi
Katılım
4 Mayıs 2007
Mesajlar
2,714
Beğeniler
6
Excel Vers. ve Dili
OFİS 2013 TÜRKÇE-İNG. 64 BİT
#28
denedim üstad. hata aldım. belki ben de uyarlayamamış olabilirim. Birşey diyemem. Teşekkürler emeğine sağlık.
Dizi formüllerini CTRL+SHIFT+ENTER ile kapatmak gerekir.Formülün başına ve sonuna süslü parantez { } gelir.
Formülü sizin eklediğiniz dosyaya göre hazırladım.Denediğiniz dosya'da muhtemelen eklediğiniz dosya'da bulunan 1. boş satırı sildiniz.
Sağlık olsun bunları ilerde foruma danışırsanız bilgi olarak yazmak istedim.
 
Katılım
8 Mart 2011
Mesajlar
11,029
Beğeniler
124
Excel Vers. ve Dili
Office 2013 TÜRKÇE
#29
Sayın @kuvari 'nin verdiği formül ve makro kod elbette tam olarak doğru ve benim verdiğim makro kod ile aynı sonucu üretiyor.
Dün cevap yazarken bir önceki formülü deneyerek 1 seçeneğine ilişkin not yazmış idim.

Sayın @kuvari 'nin verdiği formülün, çok güzel düşünüldüğünü ve tasarlandığını tekrar belirterek bir kez daha tebrik etmek istedim.

Sayın @cevherim anlaşılan o ki; formülü dizi formülüne dönüştürmüyor (CTRL+SHIFT+ENTER ile formül uygulaması).
.
 
Üst