Koşullu kümüle toplam aldırma

Katılım
10 Nisan 2019
Mesajlar
5
Beğeniler
0
Excel Vers. ve Dili
excel Office 16 - türkçe
#1
Ekte gönderdiğim excelde firmanın yeni tutar sütununda bir formül yer alıyor. bu formül tek firmaya göre ( b sütunu) uygulanabiliyor fakat konu birden fazla firmanın borç ve ödemesi olunca işe yaramıyor.(firma bazında kesilen faturalardan kalanları 1000 lerce farklı firmada alt alta görmek istiyorum)

B sütununda firma değişince abc firması için uygulanan formül xyz firması için tekrar başlatılabilir mi veya formüle ettiğim hücrede ( yeni tutar sütunu) koşullu kümüle toplam aldırma formülü var mıdır ?

çoketopla ve etopla formülleri işe yaramamaktadır.
 

Ekli dosyalar

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
24,656
Beğeniler
438
Excel Vers. ve Dili
OFFICE 2019 PRO TR
#2
F2 hücresine uygulayıp deneyiniz.

Kod:
=EĞER(C2="";0;EĞER(ÇOKETOPLA($E$2:$E$1000;$C$2:$C$1000;C2)-ÇOKETOPLA($D$2:D2;$C$2:C2;C2)>0;0;ÇOKETOPLA($D$2:D2;$C$2:C2;C2)-ÇOKETOPLA($E$2:$E$1000;$C$2:$C$1000;C2)-ÇOKETOPLA($F$1:F1;$C$1:C1;C1)))
 
Katılım
11 Nisan 2019
Mesajlar
2
Beğeniler
1
Excel Vers. ve Dili
Versiyon : Excel 2016
Dil : Türkçe
#3
Size makro ile yardımcı olabilirim isterseniz ?
 
Katılım
10 Nisan 2019
Mesajlar
5
Beğeniler
0
Excel Vers. ve Dili
excel Office 16 - türkçe
#4
Öncelikle yardımlarınız için teşekkür ederim

Yazılan formül 10 bin satır üstü harekette ortalama % 60 doğru sonuç vermektedir

Bazı istisnalar var aşağıya madde madde yazdım. Bunlarda doğru sonucu alamıyorum

Acaba makro veya formüle eklemeler yapılsa sorunlar giderilebilir mi?

Exceldeki formüllü sütun ile benim manuel yaptığım olması gereken sütun arasında olan farklar için fark sütunu açıp yanına da neden kaynaklandığını
yazdım. Özeti aşağıdadır

1564580766773.png
 

Ekli dosyalar

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
24,656
Beğeniler
438
Excel Vers. ve Dili
OFFICE 2019 PRO TR
#5
Önerdiğim formülü İlk eklediğiniz dosyaya uyguladığınızda nasıl sonuç aldınız?
 
Katılım
10 Nisan 2019
Mesajlar
5
Beğeniler
0
Excel Vers. ve Dili
excel Office 16 - türkçe
#6
Merhaba,

yukarıda belirttiğim hatalar dışında doğru sonuç veriyor,

ilk excelde 2 firmayla doğru sonucu veriyor fakat veri çoğaldıkça , gerçek verilere uyguladığımda yukarıdaki hatalar çıkmaktadır.

Saygılar
 
Üst