• Merhaba, 22 Ocak 2020 Çarşamba günü sabah 08:00 ile 12:00 saatleri arasında forumun bulunduğu sunucuda genel bakım çalışması yapılacaktır.
    Bu sürenin tamamında olmasa da bir süreliğine forum geçici olarak erişilemez olacaktır. Bilgilerinize

Koşullu kümüle toplam aldırma

gorkemerl91

Altın Üye
Katılım
10 Nisan 2019
Mesajlar
5
Excel Vers. ve Dili
excel Office 16 - türkçe
Ekte gönderdiğim excelde firmanın yeni tutar sütununda bir formül yer alıyor. bu formül tek firmaya göre ( b sütunu) uygulanabiliyor fakat konu birden fazla firmanın borç ve ödemesi olunca işe yaramıyor.(firma bazında kesilen faturalardan kalanları 1000 lerce farklı firmada alt alta görmek istiyorum)

B sütununda firma değişince abc firması için uygulanan formül xyz firması için tekrar başlatılabilir mi veya formüle ettiğim hücrede ( yeni tutar sütunu) koşullu kümüle toplam aldırma formülü var mıdır ?

çoketopla ve etopla formülleri işe yaramamaktadır.
 

Ekli dosyalar

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
25,536
Excel Vers. ve Dili
OFFICE 2019 PRO TR
F2 hücresine uygulayıp deneyiniz.

Kod:
=EĞER(C2="";0;EĞER(ÇOKETOPLA($E$2:$E$1000;$C$2:$C$1000;C2)-ÇOKETOPLA($D$2:D2;$C$2:C2;C2)>0;0;ÇOKETOPLA($D$2:D2;$C$2:C2;C2)-ÇOKETOPLA($E$2:$E$1000;$C$2:$C$1000;C2)-ÇOKETOPLA($F$1:F1;$C$1:C1;C1)))
 
Katılım
11 Nisan 2019
Mesajlar
2
Excel Vers. ve Dili
Versiyon : Excel 2016
Dil : Türkçe
Size makro ile yardımcı olabilirim isterseniz ?
 

gorkemerl91

Altın Üye
Katılım
10 Nisan 2019
Mesajlar
5
Excel Vers. ve Dili
excel Office 16 - türkçe
Öncelikle yardımlarınız için teşekkür ederim

Yazılan formül 10 bin satır üstü harekette ortalama % 60 doğru sonuç vermektedir

Bazı istisnalar var aşağıya madde madde yazdım. Bunlarda doğru sonucu alamıyorum

Acaba makro veya formüle eklemeler yapılsa sorunlar giderilebilir mi?

Exceldeki formüllü sütun ile benim manuel yaptığım olması gereken sütun arasında olan farklar için fark sütunu açıp yanına da neden kaynaklandığını
yazdım. Özeti aşağıdadır

1564580766773.png
 

Ekli dosyalar

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
25,536
Excel Vers. ve Dili
OFFICE 2019 PRO TR
Önerdiğim formülü İlk eklediğiniz dosyaya uyguladığınızda nasıl sonuç aldınız?
 

gorkemerl91

Altın Üye
Katılım
10 Nisan 2019
Mesajlar
5
Excel Vers. ve Dili
excel Office 16 - türkçe
Merhaba,

yukarıda belirttiğim hatalar dışında doğru sonuç veriyor,

ilk excelde 2 firmayla doğru sonucu veriyor fakat veri çoğaldıkça , gerçek verilere uyguladığımda yukarıdaki hatalar çıkmaktadır.

Saygılar
 

gorkemerl91

Altın Üye
Katılım
10 Nisan 2019
Mesajlar
5
Excel Vers. ve Dili
excel Office 16 - türkçe
Bakabilen oldu mu acaba?
 
Üst