• FORUMU MOBİL UYGULAMADAN TAKİP EDİN

    Forumu isteyen üyelerimiz Tapatalk (Harici bir hizmet) üzerinden mobil uygulamadan takip edebilirler.
    iOS için : https://itunes.apple.com/app/id307880732?mt=8
    Android için : https://play.google.com/store/apps/details?id=com.quoord.tapatalkpro.activity
    adreslerinden indirebilirsiniz.

    Bir iki haftaya da foruma özel kendi uygulamamız yayında olacak.
ALTIN ÜYELİK Hakkında Bilgi
-----------------------

Soru Belirtilen ürünün verilen tarih aralıklarını kapsayan toplam fiyatını nasıl alabilirim?

Katılım
12 Şubat 2014
Mesajlar
4
Beğeniler
0
Excel Vers. ve Dili
Office 2016 Türkçe
#1
Merhaba değerli üyeler ve site yöneticileri,

Ekli linkte bulunan tabloda B19 hücresine sonucu getiremiyorum.
Üç ana verim var. Tarih, ürün (LAND-SNG, SEA-DBL vs.) ve tarih aralıklarına göre değişen ürün fiyatları.
Sorum şu; Belirtilen ürünün verilen tarih aralıklarını kapsayan toplam fiyatını nasıl alabilirim?
Kullandığım formül ise şu; =TOPLA.ÇARPIM((C1:AI1=B18)*(A2:B11>=B16)*(A2:B11<=B17)*(C2:AI11))

Çözüm konusunda aydınlatabilirseniz çok memnun olurum.
Teşekkürler.

ekran alındısı
 
Katılım
8 Mart 2011
Mesajlar
11,568
Beğeniler
214
Excel Vers. ve Dili
Office 2013 ( 32 bit ) TÜRKÇE
#2
Merhaba.

Sorularınızı, ekran görüntüsü (görüntüleme için izin isteniyor) yerine gerçek belgenizin,
özel bilgi içermeyen, küçük boyutlu bir kopyası şeklinde hazırlayacağınız örnek belge üzerinden sorarsanız
daha hızlı ve net sonuca ulaşırsınız.
Örnek belge özellikleri ve örnek belge yükleme yöntemine ilişkin kısa açıklama cevabımın altındaki İMZA bölümünde var.
.
 
Katılım
12 Şubat 2014
Mesajlar
4
Beğeniler
0
Excel Vers. ve Dili
Office 2016 Türkçe
#3
Merhaba.

Sorularınızı, ekran görüntüsü (görüntüleme için izin isteniyor) yerine gerçek belgenizin,
özel bilgi içermeyen, küçük boyutlu bir kopyası şeklinde hazırlayacağınız örnek belge üzerinden sorarsanız
daha hızlı ve net sonuca ulaşırsınız.
Örnek belge özellikleri ve örnek belge yükleme yöntemine ilişkin kısa açıklama cevabımın altındaki İMZA bölümünde var.
.
Merhaba Ömer Bey,

Uyarınız için teşekkürler. Örnek dosya linkini paylaşıyorum.
İyi çalışmalar.
Link:
http://s7.dosya.tc/server9/q30fj7/formul_calismasi_2.xlsx.html
 

çıtır

Altın Üye
Altın Üye
Katılım
6 Mart 2005
Mesajlar
2,771
Beğeniler
169
Excel Vers. ve Dili
Excel Vers. ve Dili:
Office 2016 TR 64 Bit
#4
Aşağıdaki formülü B19 hücresine kopyalayınız.Biçimi para birimi yapınız.
Kod:
=TOPLA.ÇARPIM(($C$1:$AI$1=$B$18)*($A$2:$A$11>=$B$16)*($B$2:$B$11<=$B$17)*($C$2:$AI$11))
 
Son düzenleme:
Katılım
12 Şubat 2014
Mesajlar
4
Beğeniler
0
Excel Vers. ve Dili
Office 2016 Türkçe
#5
Aşağıdaki formülü B19 hücresine kopyalayınız.Biçimi para birimi yapınız.
Kod:
=TOPLA.ÇARPIM(($C$1:$AI$1=$B$18)*($A$2:$A$11>=$B$16)*($B$2:$B$11<=$B$17)*($C$2:$AI$11))
Sayın Çınar,
Yardımınız için çok teşekkür ederim. Fakat almak istediğim sonuç tam olarak bu değil.
Yapmak istediğim şey tarih periyotları içindeki gün sayısı ve o periyotun fiyatını kullanarak toplam sonuç almak.
Örnek vermek gerekirse x tarih periyotunun fiyatı 30 olsun, y periyotunun fiyatı 20 olsun. x periyotundan 2 gün, y periyotundan 2 gün alıp sonucun 100 olarak B19 hücresine getirebilmek amacım.
 

İdris SERDAR

Moderatör
Yönetici
Katılım
21 Ekim 2005
Mesajlar
15,138
Beğeniler
71
Excel Vers. ve Dili
Excel, 2016 - İngilizce
#6
.

Bunu deneyin.

Kod:
=SUMIFS(INDIRECT(ADDRESS(2;MATCH(B18;C1:AI1;0)+2;4)&":"&ADDRESS(11;MATCH(B18;C1:AI1;0)+2;4));B2:B11;">"&B16;B2:B11;"<"&B17)
.
 
Katılım
12 Şubat 2014
Mesajlar
4
Beğeniler
0
Excel Vers. ve Dili
Office 2016 Türkçe
#7
.

Bunu deneyin.

Kod:
=SUMIFS(INDIRECT(ADDRESS(2;MATCH(B18;C1:AI1;0)+2;4)&":"&ADDRESS(11;MATCH(B18;C1:AI1;0)+2;4));B2:B11;">"&B16;B2:B11;"<"&B17)
.
Merhaba İdris Bey,
Desteğiniz için teşekkürler. Biraz uğraştım ama istediğim sonucu alamadım. Tarih periyotlarını kaldırıp gün gün tarihleri yazarak bir tablo hazırlasam sonuç alabilirim diye düşünüyorum fakat bu sefer de listedeki satır sayısı bir hayli fazla olacak.
 

Korhan Ayhan

Moderatör
Yönetici
Katılım
15 Mart 2005
Mesajlar
23,589
Beğeniler
77
Excel Vers. ve Dili
OFFICE 2013-2016 PRO TR
#9
Ekteki örnek dosyayı inceleyiniz.
 

Ekli dosyalar

Üst