Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Diğer Excel Soruları
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Diğer Excel Soruları Yukarıdaki başlıklara uymayan Excel sorularınızı bu bölüme gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 02-02-2018, 23:48   #1
officer08
 
Giriş: 29/03/2013
Şehir: uşak
Mesaj: 37
Excel Vers. ve Dili:
office 2010
Question Tek hücre içinde yazılı satır sayısını saydırmak.

Örneğin A1 hücresi içinde aşağıdaki gibi satırlar var.

123456789 İSİM SOYİSİM
234578432 İSİM İSİM SOYİSİM
876543210 İSİM İSİM SOYİSİM
847562738 İSİM SOYİSİM

A1 hücresinde sayı veya metinden oluşan 4 satır bulunduğundan sonuç olarak A2 hücresine 4 sonucunu yazdırabilirmiyiz. Formülü varmıdır bunun.
officer08 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 02-02-2018, 23:59   #2
çıtır
Altın Üye
 
Giriş: 06/03/2005
Şehir: KDZ.EREĞLİ
Mesaj: 1,392
Excel Vers. ve Dili:
Excel Vers. ve Dili: Office 2016 TR 64 Bit
Varsayılan

Deneyiniz.Çözüm olabilir.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(UZUNLUK(KIRP(YERİNEKOY(A1;DAMGA(10);" ")))>0;UZUNLUK(KIRP(YERİNEKOY(A1;DAMGA(10);" ")))-UZUNLUK(YERİNEKOY(A1;DAMGA(10);""))+1;0)
Sayın Ömer BARAN uyarınız üzerine düzeltildi.Teşekkür ederim.Boş hücre olduğunda ALT+F11 geçilse 0 sonuçu verir.

Bu mesaj en son " 03-02-2018 " tarihinde saat 03:56 itibariyle çıtır tarafından düzenlenmiştir....
çıtır Çevrimiçi   Alıntı Yaparak Cevapla
Eski 03-02-2018, 02:36   #3
Ömer BARAN
Uzman
 
Giriş: 08/03/2011
Şehir: ANKARA / İSTANBUL
Mesaj: 9,670
Excel Vers. ve Dili:
Office 2013 TÜRKÇE
Varsayılan

Merhaba.

Sayın çıtır'ın gözünden kaçtı sanırım. Verilen formülün sonucu, açılış mesajındaki veri için 4 yerine 14 oluyor.

Aşağıdaki formülün istenilen sonucu vermesi gerekir.
(Tabi satırbaşı karakterinin ALT+F11 tuşu kullanılarak yazılmış olduğunu varsayıyorum)

►Sonuç alamıyorsanız; belgenizde mevcut gerçek verideki bir satırbaşı karakterini kopyalayın ve
bu karakteri örneğin B1 hücresine yapıştırın, C1'e de =KOD(B1) formülü uygulayın.
Bu formülün sonucu neyse, aşağıdaki formülde DAMGA(10) kısımlarındaki 10 sayısının yerine o sonucu yazın.

►Formül yine de istediğiniz sonucu vermiyorsa, birkaç hücrelik gerçek verinin olduğu bir örnek belge yükleyin onun üzerinden bakılsın.
Örnek belge yükleme yöntemine ilişkin kısa açıklama cevabımın altındaki İMZA bölümünde var.
.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(UZUNLUK(KIRP(A1))-UZUNLUK(YERİNEKOY(KIRP(A1);DAMGA(10);""))=0;0;UZUNLUK(KIRP(A1))-UZUNLUK(YERİNEKOY(KIRP(A1);DAMGA(10);""))+1)
__________________
.
☾✭ İnadına TÜRKÇE ✭☽

-- Sorunuzu, gerçek belgenizle aynı yapıda ve olması gereken sonuçların elle yazıldığı örnek belge ile destekleyiniz.
-- ALTIN ÜYELİK öneriyorum. / FORUM KURALLARInı mutlaka okuyunuz.
-- ALTIN ÜYE olmayanlar, örnek belgeyi dosya.tc, dosya.co gibi bir siteye yükleyip, belgeye erişim adresini verebilir.
-- Özel mesaj ile soru sormayınız. / Geri bildirimde bulunulmayan cevaplarımı siliyorum.
Ömer BARAN Çevrimdışı   Alıntı Yaparak Cevapla
Eski 03-02-2018, 19:18   #4
officer08
 
Giriş: 29/03/2013
Şehir: uşak
Mesaj: 37
Excel Vers. ve Dili:
office 2010
Varsayılan

Herzamanki gibi yine çok yardımcı oldunuz teşekkür ederim sizlere. Kusura bakmayın geç bakabildim çok güzel çalışıyor, ellerinize sağlık.
officer08 Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 19:39


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Karton Bardak- Çorlu Dil Konuşma Terapisti- Çorlu Dil Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Çorlu- Çorlu Araç Takip- Çorlu Su Arıtma- Gebze Emlak- Rampa- Rotary- Çorlu İnternet Sitesi- Çorlu Sürücü Kursu- Çorlu Sürücü Kursu- Şişli Avukat- Edirne Serbest Muhasebeci- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta- Kağıt Bardak- Kağıt Bardak- Kaplan Tekstil- Çorlu Perde- Çorlu Perde- Çorlu Havuz- Çorlu Havuz- Makina- Danışmazlar- Çorlu Perde Yıkama- Çorlu Perde Yıkama- Okul Danışmanlık- Çorlu Ayakkabı- İzmit Sigorta-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden