Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Excel'e Yeni Başlayanlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Excel'e Yeni Başlayanlar Excel kullanmaya yeni başladıysanız sorularınızı buraya gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 28-12-2017, 15:28   #1
redtacton
Altın Üye
 
Giriş: 01/12/2016
Şehir: TRABZON/İSTANBUL
Mesaj: 6
Excel Vers. ve Dili:
Excel 2016 Türkçe
Varsayılan İki koşul için tarih bazında filtreleyerek saydırma

Merhaba arkadaşlar,

Ekteki deneme.xlsx dosyasında veri alanı TAKIP sekmesi olup saydırma yaptırmak istediğim ama RAPOR sekmesidir. Yeşil boyalı alanlara fonksiyon yazarak veri getirmek istiyorum.

İstek şöyle;
- Sipariş sayısını; sipariş tarihini aylık olarak gözeterek saydırıp ilgili satış temsilcisi karşısına saydırsın. (Ben burda tarihten ay a çevirip saydırtamadım)

- "Sevkiyat türü" ne göre; adedini gene "sevk tarihi" ni baz alarak ilgili kargo şirketi karşına saydırsın. (Gene burada tarihden saydırma yapamadım.)

Yardımlarınız için şimdiden teşekkürler...
Eklenmiş Dosyalar
Dosya Türü: xlsx deneme.xlsx (11.6 KB, 8 Görüntülenme)
redtacton Çevrimdışı   Alıntı Yaparak Cevapla
Eski 28-12-2017, 16:23   #2
Ömer BARAN
Uzman
 
Giriş: 08/03/2011
Şehir: ANKARA / İSTANBUL
Mesaj: 9,488
Excel Vers. ve Dili:
Office 2013 TÜRKÇE
Varsayılan

Merhaba.

-- C3 hücresine uygulayın ve ardından sağa ve aşağı kopyalayın.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=TOPLA.ÇARPIM((TAKIP!$D$2:$D$9=$A3)*(AY(TAKIP!$C$2:$C$9)=KAÇINCI(C$1;{"OCAK";"ŞUBAT";"MART";"NİSAN";"MAYIS";"HAZİRAN";"TEMMUZ";"AĞUSTOS";"EYLÜL";"EKİM";"KASIM";"ARALIK"};0)))
-- C10 hücresine uygulayın ve ardından sağa ve aşağı kopyalayın
( RAPOR sayfasında KARGO firma isimlerinin sonundaki BOŞLUK karakterlerini silin, yani TAKIP sayfasındaki ile birebir aynı olmasını sağlayın )
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=TOPLA.ÇARPIM((TAKIP!$E$2:$E$9=$A10)*(AY(TAKIP!$F$2:$F$9)=KAÇINCI(C$1;{"OCAK";"ŞUBAT";"MART";"NİSAN";"MAYIS";"HAZİRAN";"TEMMUZ";"AĞUSTOS";"EYLÜL";"EKİM";"KASIM";"ARALIK"};0)))
__________________
.
☾✭ İnadına TÜRKÇE ✭☽

-- Sorunuzu, gerçek belgenizle aynı yapıda ve olması gereken sonuçların elle yazıldığı örnek belge ile destekleyiniz.
-- ALTIN ÜYELİK öneriyorum. / FORUM KURALLARInı mutlaka okuyunuz.
-- ALTIN ÜYE olmayanlar, örnek belgeyi dosya.tc, dosya.co gibi bir siteye yükleyip, belgeye erişim adresini verebilir.
-- Özel mesaj ile soru sormayınız. / Geri bildirimde bulunulmayan cevaplarımı siliyorum.
Ömer BARAN Çevrimdışı   Alıntı Yaparak Cevapla
Eski 29-12-2017, 10:10   #3
redtacton
Altın Üye
 
Giriş: 01/12/2016
Şehir: TRABZON/İSTANBUL
Mesaj: 6
Excel Vers. ve Dili:
Excel 2016 Türkçe
Thumbs up

Ömer bey,

Teşekkürler. İşe yaradı...

Yalnız bir ekstra durum sözkonusu...

Bu fonksiyona bir de yıl filtresi eklemek istersem nasıl yapabilirim. Şuan veri dosyasında 2016, 2017 var. Ancak bu formülle örneğin; 2017 aralıkla 2016 aralık takileri bir sayıyor.
2016 ocak.....aralık a; ayrı bir fonksiyon...
2017 ocak.....aralık a; ayrı bir fonksiyon girebilirim.

Hızlı cevabınız için şimdiden çok teşekkürler...
redtacton Çevrimdışı   Alıntı Yaparak Cevapla
Eski 29-12-2017, 11:38   #4
Ömer BARAN
Uzman
 
Giriş: 08/03/2011
Şehir: ANKARA / İSTANBUL
Mesaj: 9,488
Excel Vers. ve Dili:
Office 2013 TÜRKÇE
Varsayılan

Tekrar merhaba.

RAPOR sayfasının B1 hücresine ilgilenilen yıl bilgisini yazın (B1 hücresine veri doğrulama uygulayarak, açılır listeden yıl seçimi de yapabilirsiniz)
verdiğim her iki formüle, en sondaki parantezden önce *(YIL(TAKIP!$C$2:$C$9)=$B$1) ekleyip formülleri tekrar kopyalayın.
.
__________________
.
☾✭ İnadına TÜRKÇE ✭☽

-- Sorunuzu, gerçek belgenizle aynı yapıda ve olması gereken sonuçların elle yazıldığı örnek belge ile destekleyiniz.
-- ALTIN ÜYELİK öneriyorum. / FORUM KURALLARInı mutlaka okuyunuz.
-- ALTIN ÜYE olmayanlar, örnek belgeyi dosya.tc, dosya.co gibi bir siteye yükleyip, belgeye erişim adresini verebilir.
-- Özel mesaj ile soru sormayınız. / Geri bildirimde bulunulmayan cevaplarımı siliyorum.
Ömer BARAN Çevrimdışı   Alıntı Yaparak Cevapla
Eski 02-01-2018, 09:07   #5
redtacton
Altın Üye
 
Giriş: 01/12/2016
Şehir: TRABZON/İSTANBUL
Mesaj: 6
Excel Vers. ve Dili:
Excel 2016 Türkçe
Varsayılan

Merhabalar,

Harika! Tam istediğim gibi çalışıyor. Emeğinize sağlık...

Saygılar!
redtacton Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 01:58


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Karton Bardak- Çorlu Dil ve Konuşma Terapisti- Çorlu Dil ve Konuşma Terapisti- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Çorlu- Çorlu Araç Takip- Çorlu Su Arıtma- Gebze Emlak- Rampa- Rotary- Çorlu İnternet Sitesi- Çorlu Sürücü Kursu- Çorlu Sürücü Kursu- Şişli Avukat- Edirne Serbest Muhasebeci- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta- Kağıt Bardak- Kaplan Tekstil- Çorlu Perde- Çorlu Havuz- Makina- Danışmazlar-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden