Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Excel'e Yeni Başlayanlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Excel'e Yeni Başlayanlar Excel kullanmaya yeni başladıysanız sorularınızı buraya gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 04-01-2018, 13:31   #1
stier_22
Altın Üye
 
Giriş: 15/09/2009
Mesaj: 35
Excel Vers. ve Dili:
excell2003
Varsayılan 2 listede yer alan fatura numaralarını karşılaştırma

Arkadaşlar sizin için için çok basit benim için çok zor olan bir sorum olacak

1 Nolu listede yer alan sarı renkli fatura numaralarını 2 nolu Listede arasın olanlara var olmayanlara yok yazsın istiyorum

Yardımlarınızı rica ederim...

http://s3.dosya.tc/server13/onq8s8/1.xls.html

http://s3.dosya.tc/server13/q41hi0/2.xls.html
stier_22 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 04-01-2018, 14:07   #2
huseyinvurkan
 
Giriş: 12/08/2007
Şehir: İstanbul
Mesaj: 265
Excel Vers. ve Dili:
2003 türkçe 2016 türkçe
Varsayılan

Merhaba. İstediğiniz böyle bir şey mi?


http://s3.dosya.tc/server13/s14t7o/1.xls.html
huseyinvurkan Çevrimdışı   Alıntı Yaparak Cevapla
Eski 04-01-2018, 14:37   #3
stier_22
Altın Üye
 
Giriş: 15/09/2009
Mesaj: 35
Excel Vers. ve Dili:
excell2003
Varsayılan

Alıntı:
huseyinvurkan tarafından gönderildi Mesajı Görüntüle
Merhaba. İstediğiniz böyle bir şey mi?


http://s3.dosya.tc/server13/s14t7o/1.xls.html
Merhaba öncelikle cevabınız için teşekkürler fakat istediğim tam olarak bu değil şöyle ki; 1 nolu dosyada yer alan C sütunundaki fatura numaraları 2 nolu dosya da ki E sütununda yer alan fatura numaraları içinde yer alıyorsa "var" yer almıyorsa "yok" demesini istiyorum.
stier_22 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 04-01-2018, 14:49   #4
huseyinvurkan
 
Giriş: 12/08/2007
Şehir: İstanbul
Mesaj: 265
Excel Vers. ve Dili:
2003 türkçe 2016 türkçe
Varsayılan

Merhaba Dediğiniz gibi 1 Nolu dosyada eklediğim D sütunu

=EĞERSAY(C3;'[2.xls]İndirilecek KDV Listesi'!$E$5:$E$188)

formülüyle 2 nolu dosyadaki E5:E188 aralığında C sütunundaki veriyi arıyor varsa 1 yoksa 0 yazıyor. bu sütunu gizleyebilirsiniz.

E sütunu ise

=EĞER(D3=1;"VAR";"YOK")

D sütununda 1 yazıyorsa var 0 yazıyorsa yok yazıyor. Sizin istediğiniz de bu değil mi?
huseyinvurkan Çevrimdışı   Alıntı Yaparak Cevapla
Eski 04-01-2018, 15:02   #5
stier_22
Altın Üye
 
Giriş: 15/09/2009
Mesaj: 35
Excel Vers. ve Dili:
excell2003
Varsayılan

Alıntı:
huseyinvurkan tarafından gönderildi Mesajı Görüntüle
Merhaba Dediğiniz gibi 1 Nolu dosyada eklediğim D sütunu

=EĞERSAY(C3;'[2.xls]İndirilecek KDV Listesi'!$E$5:$E$188)

formülüyle 2 nolu dosyadaki E5:E188 aralığında C sütunundaki veriyi arıyor varsa 1 yoksa 0 yazıyor. bu sütunu gizleyebilirsiniz.

E sütunu ise

=EĞER(D3=1;"VAR";"YOK")

D sütununda 1 yazıyorsa var 0 yazıyorsa yok yazıyor. Sizin istediğiniz de bu değil mi?

fakat sizin yapmış olduğunuz listede yok çıkan fatura numaralarının bir kısmı ctrl+f ile arattığımda diğer dosyada var olarak çıkıyor

Örnek verecek olursak 71558 nolu fatura her iki listede de var ama sizin formülde yok olarak çıkmış
stier_22 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 04-01-2018, 15:32   #6
huseyinvurkan
 
Giriş: 12/08/2007
Şehir: İstanbul
Mesaj: 265
Excel Vers. ve Dili:
2003 türkçe 2016 türkçe
Varsayılan

Merhaba Evet haklısınız ancak bendeki hatanın sebebini bulamadım. İnşallah bir cevap veren olur da doğrusunu öğreniriz. Saygılar.
huseyinvurkan Çevrimdışı   Alıntı Yaparak Cevapla
Eski 04-01-2018, 15:34   #7
stier_22
Altın Üye
 
Giriş: 15/09/2009
Mesaj: 35
Excel Vers. ve Dili:
excell2003
Varsayılan

Alıntı:
huseyinvurkan tarafından gönderildi Mesajı Görüntüle
Merhaba Evet haklısınız ancak bendeki hatanın sebebini bulamadım. İnşallah bir cevap veren olur da doğrusunu öğreniriz. Saygılar.
Teşekkür ederim uğraştırdık sizi
stier_22 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 04-01-2018, 15:54   #8
huseyinvurkan
 
Giriş: 12/08/2007
Şehir: İstanbul
Mesaj: 265
Excel Vers. ve Dili:
2003 türkçe 2016 türkçe
Varsayılan

Ne demek estağfurullah. Ben de yavaş yavaş öğrenmeye çalışıyorum. İnşallah cevabı bulursam yazarım.
huseyinvurkan Çevrimdışı   Alıntı Yaparak Cevapla
Eski 04-01-2018, 18:15   #9
huseyinvurkan
 
Giriş: 12/08/2007
Şehir: İstanbul
Mesaj: 265
Excel Vers. ve Dili:
2003 türkçe 2016 türkçe
Varsayılan

Tekrar merhaba. Bu sefer doğruyu bulduğumu zannediyorum. eğersay formülü;

=EĞERSAY('[2.xls]İndirilecek KDV Listesi'!$E$5:$E$188;C3) şeklinde olmalıydı.


http://s3.dosya.tc/server13/1d2kw7/1.xlsx.html

Sadece D sütunu ekleyip D3 hücresine:

=EĞER(EĞERSAY('[2.xlsx]İndirilecek KDV Listesi'!$E$5:$E$188;C3)>0;"VAR";"YOK") yazıp aşağı doğru kopyalayıp aynı sonucu elde edebiliriz. Saygılar

Bu mesaj en son " 04-01-2018 " tarihinde saat 19:26 itibariyle huseyinvurkan tarafından düzenlenmiştir....
huseyinvurkan Çevrimdışı   Alıntı Yaparak Cevapla
Eski 04-01-2018, 19:39   #10
TanerSaydam
 
Giriş: 13/10/2017
Şehir: Kayseri
Mesaj: 155
Excel Vers. ve Dili:
2003-tr
Varsayılan

Hocam istediğin aşağıdaki gibi bir şeyse, bunu başka bir excel'den ara şeklinde düzenleyebilirim. Ya da daha basiti siz 2.ci exceldeki rakamları 1'e kopyalar ve tuşa basarsınız.

http://dosya.co/9shggw8rtwe8/1.xls.html

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
Private Sub CommandButton1_Click()
Dim son, x, a, v, y As Integer
son = Range("C" & Rows.Count).End(xlUp).Row
son1 = Range("E" & Rows.Count).End(xlUp).Row

Range("D3:D" & Range("D" & Rows.Count).End(3).Row).ClearContents

y = 2
For a = 3 To son
y = y + 1
    For x = 3 To son1
    If Range("C" & y) = Range("E" & x) Then
    Range("D" & y) = "VAR"
    GoTo atla
    End If
    Next x
atla:
    Next a
    
For y = 3 To son
If Range("D" & y) = "" Then
Range("D" & y) = "YOK"
End If
Next y


MsgBox "İşlem başarıyla tamamlandı!", vbOKOnly + vbInformation, "İŞLEM TAMAMLANDI!"
End Sub
TanerSaydam Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 04:33


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Karton Bardak- Çorlu Dil ve Konuşma Terapisti- Çorlu Dil ve Konuşma Terapisti- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Çorlu- Çorlu Araç Takip- Çorlu Su Arıtma- Gebze Emlak- Rampa- Rotary- Çorlu İnternet Sitesi- Çorlu Sürücü Kursu- Çorlu Sürücü Kursu- Şişli Avukat- Edirne Serbest Muhasebeci- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta- Kağıt Bardak- Kaplan Tekstil- Çorlu Perde- Çorlu Havuz- Makina- Danışmazlar-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden