Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Fonksiyonlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Fonksiyonlar Bir fonksiyonun, nasıl işlediğini veya aradığınız bir işleme uygun olup olmadığını bu başlık altında sorabilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 27-10-2017, 23:47   #1
myoverusedpasport
 
Giriş: 25/10/2017
Şehir: Sakarya
Mesaj: 10
Excel Vers. ve Dili:
2007 Türkçe
Varsayılan Hücre içindeki numarayı alma

Merhabalar, günlerdir manuel şekilde yaptığım numara ayırma için bir fonksiyon yada makro var mıdır acaba ?

Yaptığım örnek şu şekilde,

047310227990553017121105536486480

050134505301144834
052767629990553071546674234234
her biri ayrı hücre olarak düşünün hücrelerde bu şekilde numaralar var ama yanında sağında solunda rakamlar var. Bu hücrelerden numara ayıklanır mı var mıdır bunu bir fonksiyonu ? 0531,538 ile başlayandan sayıları al gibi mesela. Yardımcı olursanız çok sevinirim.
myoverusedpasport Çevrimdışı   Alıntı Yaparak Cevapla
Eski 27-10-2017, 23:59   #2
çıtır
 
Giriş: 06/03/2005
Şehir: kdz.ereğli
Mesaj: 922
Varsayılan

Hangi şartı taşıyanları ve kaç rakam almak istiyorsunuz?Bir örnekle açıklar mısınız?
çıtır Çevrimdışı   Alıntı Yaparak Cevapla
Eski 28-10-2017, 00:06   #3
myoverusedpasport
 
Giriş: 25/10/2017
Şehir: Sakarya
Mesaj: 10
Excel Vers. ve Dili:
2007 Türkçe
Varsayılan

Benim ihtiyacım olan 10 haneli cep telefon numaraları 5 ile başlayan 532, 501, 545 gibi tüm operatör numraları ile başlayan cep telefon numaraları örnek 5441112233 şu şekilde 10 haneli numara.
myoverusedpasport Çevrimdışı   Alıntı Yaparak Cevapla
Eski 28-10-2017, 00:19   #4
çıtır
 
Giriş: 06/03/2005
Şehir: kdz.ereğli
Mesaj: 922
Varsayılan

Şöyle bir formül deneyin, A1 , A2 vb hücrelerde ise B1 kopyalayıp aşağı çekerek çoğaltınız.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=PARÇAAL(A1;BUL("*";YERİNEKOY(A1;"05";"**";1);1);10)
çıtır Çevrimdışı   Alıntı Yaparak Cevapla
Eski 28-10-2017, 00:43   #5
myoverusedpasport
 
Giriş: 25/10/2017
Şehir: Sakarya
Mesaj: 10
Excel Vers. ve Dili:
2007 Türkçe
Varsayılan

Hocam çok teşekkürler işime yaradı, elinize sağlık. Tek sorunum var bazı hücrelerde 0 yerine direkt 5 ile başlıyor numara, bu formüle 05 ile başlayana ek olarak 53 ile başlayanlar diye ekleme yapmak mümkün mü ?
myoverusedpasport Çevrimdışı   Alıntı Yaparak Cevapla
Eski 28-10-2017, 00:45   #6
Ömer BARAN
Uzman
 
Giriş: 08/03/2011
Şehir: ANKARA / İSTANBUL
Mesaj: 9,323
Excel Vers. ve Dili:
Office 2013 TÜRKÇE
Varsayılan

Merhaba.

Verinin A1 hücresinde olduğu varsayılmıştır.

İki alternatif söyleyeyim, belki katkısı olur.
►1. alternatif;
-- B1 hücresine.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(UZUNLUK(A1)>11;EĞER(EHATALIYSA(PARÇAAL(A1;BUL("05";A1);11));"";PARÇAAL(A1;BUL("05";A1);11));"")
-- C1 hücresine.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(UZUNLUK(A1)>22;EĞER(EHATALIYSA(PARÇAAL(A1;BUL("05";A1;BUL("05";A1)+1);11));"";PARÇAAL(A1;BUL("05";A1;BUL("05";A1)+1);11));"")
►2'nci alternatif;
-- B1 hücresine.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(PARÇAAL(A1;1;2)="05";PARÇAAL(A1;1;11);"")
-- C1 hücresine.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(PARÇAAL(A1;23;2)="05";PARÇAAL(A1;23;11);"")
-- D1 hücresine.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(PARÇAAL(A1;23;2)="05";PARÇAAL(A1;23;11);"")
__________________
.
☾✭ İnadına TÜRKÇE ✭☽

-- Sorunuzu, gerçek belgenizle aynı yapıda ve olması gereken sonuçların elle yazıldığı örnek belge ile destekleyiniz.
-- ALTIN ÜYELİK öneriyorum. / FORUM KURALLARInı mutlaka okuyunuz.
-- ALTIN ÜYE olmayanlar, örnek belgeyi dosya.tc, dosya.co gibi bir siteye yükleyip, belgeye erişim adresini verebilir.
-- Özel mesaj ile soru sormayınız. / Geri bildirimde bulunulmayan cevaplarımı siliyorum.
Ömer BARAN Çevrimdışı   Alıntı Yaparak Cevapla
Eski 28-10-2017, 00:55   #7
myoverusedpasport
 
Giriş: 25/10/2017
Şehir: Sakarya
Mesaj: 10
Excel Vers. ve Dili:
2007 Türkçe
Varsayılan

Alıntı:
Ömer BARAN tarafından gönderildi Mesajı Görüntüle
Merhaba.

Verinin A1 hücresinde olduğu varsayılmıştır.

İki alternatif söyleyeyim, belki katkısı olur.
►1. alternatif;
-- B1 hücresine.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(UZUNLUK(A1)>11;EĞER(EHATALIYSA(PARÇAAL(A1;BUL("05";A1);11));"";PARÇAAL(A1;BUL("05";A1);11));"")
-- C1 hücresine.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(UZUNLUK(A1)>22;EĞER(EHATALIYSA(PARÇAAL(A1;BUL("05";A1;BUL("05";A1)+1);11));"";PARÇAAL(A1;BUL("05";A1;BUL("05";A1)+1);11));"")
►2'nci alternatif;
-- B1 hücresine.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(PARÇAAL(A1;1;2)="05";PARÇAAL(A1;1;11);"")
-- C1 hücresine.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(PARÇAAL(A1;23;2)="05";PARÇAAL(A1;23;11);"")
-- D1 hücresine.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(PARÇAAL(A1;23;2)="05";PARÇAAL(A1;23;11);"")
1. Alternatif B1 hücresindeki çalıştı sadece ancak

A1 B1
63022499054562900000 05456290000
6307699920541670000000 054167E+21
630924990541670000000 054167E+20
63102999054562900000 05456290000
63115999054562900000 05456290000

Bazı hücreler E+21 şeklinde çıkıyor bunu nasıl halledebilirim ? Elinize sağlık bu arada.
myoverusedpasport Çevrimdışı   Alıntı Yaparak Cevapla
Eski 28-10-2017, 00:57   #8
Murat OSMA
Altın Üye
 
Murat OSMA kullanıcısının avatarı
 
Giriş: 23/05/2011
Şehir: İstanbul
Mesaj: 4,871
Excel Vers. ve Dili:
Excel 2016 - Türkçe
Varsayılan

Ömer Bey, bu çözümleri deneyip sonuçları gözlemlediniz mi?
Formülleriniz 0527 - 0501 vs. gibi olmayan operatör kodlarını da alıyor..

Ayrıca operatör kodlarından önce 0 olmayan gruplar da mevcut. Üyemiz de 5. mesajında onu belirtmiş. Tekrar gözden geçirmenizde fayda var.

Saygılar
__________________
Excel'e dair her şey; excelarsivi.com 'da..
Murat OSMA Çevrimdışı   Alıntı Yaparak Cevapla
Eski 28-10-2017, 01:03   #9
Ömer BARAN
Uzman
 
Giriş: 08/03/2011
Şehir: ANKARA / İSTANBUL
Mesaj: 9,323
Excel Vers. ve Dili:
Office 2013 TÜRKÇE
Varsayılan

Alıntı:
myoverusedpasport tarafından gönderildi Mesajı Görüntüle
1. Alternatif B1 hücresindeki çalıştı sadece ancak

A1 B1
63022499054562900000 05456290000
6307699920541670000000 054167E+21
630924990541670000000 054167E+20
63102999054562900000 05456290000
63115999054562900000 05456290000

Bazı hücreler E+21 şeklinde çıkıyor bunu nasıl halledebilirim ? Elinize sağlık bu arada.
Ben öyle bir hata almıyorum.
Fikrim o ki; tüm durumları kapsayacak %100 bir çözüm biraz zor.
Veri türleri, uzunlukları filan öngörülemiyor.

Konu sahibinin, cevabımın altındaki İMZA bölümünü okuyarak bir örnek belge yüklemesinde yarar var.


Yazdığınızı geç fark ettim Sayın OSMA.
Operatör kodlarının bir listesi yok elimizde, ayrıca operatör kodlarındaki (başında 0 var veya yok hali ayrı bir sıkıntı zaten) rakamlar,
telefon numaralarında da aynı şekilde yer alıyor olabilir.
Tabii ki, konu sahibinin verdiği örnek verilerle deneme yaptım.
Ezbere cevap yazmadığımı biliyorsunuzdur ama ben operatör kodlarının tam lisetisini bilemiyorum.
__________________
.
☾✭ İnadına TÜRKÇE ✭☽

-- Sorunuzu, gerçek belgenizle aynı yapıda ve olması gereken sonuçların elle yazıldığı örnek belge ile destekleyiniz.
-- ALTIN ÜYELİK öneriyorum. / FORUM KURALLARInı mutlaka okuyunuz.
-- ALTIN ÜYE olmayanlar, örnek belgeyi dosya.tc, dosya.co gibi bir siteye yükleyip, belgeye erişim adresini verebilir.
-- Özel mesaj ile soru sormayınız. / Geri bildirimde bulunulmayan cevaplarımı siliyorum.
Ömer BARAN Çevrimdışı   Alıntı Yaparak Cevapla
Eski 28-10-2017, 01:13   #10
myoverusedpasport
 
Giriş: 25/10/2017
Şehir: Sakarya
Mesaj: 10
Excel Vers. ve Dili:
2007 Türkçe
Varsayılan

http://s6.dosya.tc/server11/xyvqx2/C...el_1.xlsx.html

Ekte görebilirsiniz, eğer hata görünmüyor ise ekran görüntüsü atabilirim.
Şuan kalan problemler 5 ile başlayan 10 haneli numaraları almıyor ve az önceki yorumda belirttiğim + hatası. Ayrıca bazı hücrelerde 13 haneli alıyor numaraları.
myoverusedpasport Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 23:38


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Kırklareli- Pronet Çerkezköy- Pronet Çorlu- Pronet Lüleburgaz- Pronet Keşan- Çorlu Araç Takip- Çorlu Su Arıtma- Gebze Emlak- Bakır Sülfat- Rampa- Rotary- Çorlu İnternet Sitesi- youngblood- Çorlu Sürücü Kursu- Çorlu Sandviç Panel- Şişli Avukat- Korona Test Kalemi- Çorlu Vinç- Çorlu Pimapen Tamiri- Çorlu Çelik Konstruksiyon- Çorlu Dans- Edirne Serbest Muhasebeci- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden