Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Diğer Excel Soruları (http://www.excel.web.tr/forumdisplay.php?f=50)
-   -   Bütün Virgülleri Silme (http://www.excel.web.tr/showthread.php?t=76607)

KaNooo 10-11-2009 00:57

Bütün Virgülleri Silme
 
Bir excel dosyasının A sütünu altında yaklaşık 6500 tane veri var...

Veriler harf harf mesela "acdfhl" şeklinde...

Fakat bazı veriler "a,c,d,f,h,l" şeklinde yazılmış, bazıları "a-c-d-f-h-l" şeklinde, yine bazıları ise "a c d f h l" şeklinde yazılmış...

Bana ilk yazdığım gibi yani "acdfhl" şeklinde lazım yani harflerin arasında ne boşluk, ne "-" işareti, ne de virgül olsun istiyorum.

Bütün hücrelerde 3-4 tane virgül boşluk veya tire olduğunu varsayarsak o kadar şeyi silmek çok zor olacağı için bi bilene sormanın daha iyi olduğunu düşündüm...

Varsa yardımı dokunabilecek yardımlarınızı bekliyorum...

Office 2007 Türkçe kullanıyorum...

Orion1 10-11-2009 06:22

Deiğiştirileck alanı seçin.
Ctrl+F tuşlarına basın.
çıkan pencerede değiştiri sekmesini seçin.
üste değiştirilecek veriyi yazın.
alta da boş bırakın tamamama basın işlem tamamdır.:cool:

ReBiwAr 10-11-2009 07:24

Evren hocam yine çok hızlısın tam ben cevaplayacaktım :)

kemalist 11-04-2011 19:05

1 Eklenti(ler)
arkadaşlar virgülleri silmek istiyorum dosya ektedir.yardımlarınız için şimdiden teşekkür ederim...

isteobenim 11-04-2011 19:42

Merhaba,
Ctrl+H kombinasyonu işinizi görmez mi?
Aranan değere " , "
Yeni değeri ise boş bırakarak sislebilirsiniz.

kemalist 11-04-2011 20:02

[quote=kendirliii;537494]Merhaba,
Ctrl+H kombinasyonu işinizi görmez mi?
Aranan değere " , "
Yeni değeri ise boş bırakarak sislebilirsiniz.[/QU

sayın kendirli işlem tamam..

oganbarsan 01-02-2018 09:40

kolay gelsin benim bir sorunum var
excelde satır satır sayılar mevcut manuel girilmiş şekilde farklı farklı aşağıdaki şekilde ben bu çift nokta olan noktaların ilkleri silmek istiyorum bunu yapabiliceğimiz bir formül varmı?
2.632.50---> 2632.50
3.234.90---> 3234.90
23.406---> 23.406
234---> 234
6.352.50---> 6352.50
6.629.35
4.341.15

YUSUF44 01-02-2018 10:04

Alıntı:

oganbarsan tarafından gönderildi (Mesaj 928676)
kolay gelsin benim bir sorunum var
excelde satır satır sayılar mevcut manuel girilmiş şekilde farklı farklı aşağıdaki şekilde ben bu çift nokta olan noktaların ilkleri silmek istiyorum bunu yapabiliceğimiz bir formül varmı?
2.632.50---> 2632.50
3.234.90---> 3234.90
23.406---> 23.406
234---> 234
6.352.50---> 6352.50
6.629.35
4.341.15

Verinizin A1 hücresinde olduğunu düşünürsek aşağıdaki formülü deneyin:
Kod:

=EĞER(UZUNLUK(YERİNEKOY(A1;".";""))<=UZUNLUK(A1)-1;SAĞDAN(A1;2)/100+YERİNEKOY(SOLDAN(A1;UZUNLUK(A1)-2);".";"")*1;A1)

çıtır 01-02-2018 10:14

Sayıların A1 Hücresinden başladığı varsayılmıştır.B1 Kopyalayınız .Aşağı çekerek çoğaltınız.
Kod:

=EĞER((UZUNLUK(A1)-UZUNLUK(YERİNEKOY(A1;".";"")))/UZUNLUK(".")>1;YERİNEKOY(A1;".";"";1);A1)
Sayın YUSUF44 cevabınızı görmedim.Alternatif olsun.Kusura bakmayın.
Uyarınız ve nezaket için teşekkürler.Düzeltildi.

YUSUF44 01-02-2018 10:26

Estağfurullah sayın çıtır. Ancak formülünüzde bir sıkıntı var gibi. formülün başında İki UZUNLUK formülü yazmışsınız ama arada herhangi bir işlem belirtmemişsiniz:


Saat 02:16

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.