Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Diğer Excel Soruları (http://www.excel.web.tr/forumdisplay.php?f=50)
-   -   Puantaj yardım lütfen !! (http://www.excel.web.tr/showthread.php?t=170422)

ntamero 09-02-2018 09:44

Puantaj yardım lütfen !!
 
1 Eklenti(ler)
Ekte yapmış olduğum puantajda yeni dönemde Ocak ayında saatlik çalışmaya dönüş yapmaya başladık.
Ancak saatlik çalışmada formüllerde eksiğim var. Yardımcı olursanız çok sevinirim.
Ocak ayı haftanın 5 günü çalışılıyor. Cumartesi ve Pazar Mesai olarak işleniyor.
Haftanın 5 günü 9 saatten 45 gün çalışılması mutlaka gerekiyor. Eğer hafta içi 45 günü tamamlamadı ise hafta sonu veya hafta içi kaldığı mesaiyi 45 güne ilave ediyor. Kalan saati mesaiye yazıyor. Ancak bunun yanında hafta içi gelmediği gün için harflendirmeler var. ilgili kolonlarda toplamasını yapıyor. Bu seferde mesai kolonuna toplamada #değer işareti geliyor.
Yardımcı olursanız sevinirim .
Teşekkür ediyorum şimdiden ilginize.

ntamero 10-02-2018 13:59

Konu ile ilgili destek verebiliecek bir arkadaş var mı acaba ?

YUSUF44 10-02-2018 21:01

AR3 hücresinde aşağıdaki formülü deneyin:

Kod:

=TOPLA(EĞER(ESAYIYSA(F3);MAK(F3-9;0);0);EĞER(ESAYIYSA(G3);MAK(G3-9;0);0);EĞER(ESAYIYSA(H3);MAK(H3-9;0);0);EĞER(ESAYIYSA(I3);MAK(I3-9;0););EĞER(ESAYIYSA(J3);MAK(J3-9;0);0);EĞER(ESAYIYSA(P3);MAK(P3-9;0);0);EĞER(ESAYIYSA(Q3);MAK(Q3-9;0);0);EĞER(ESAYIYSA(R3);MAK(R3-9;0);0);EĞER(ESAYIYSA(S3);MAK(S3-9;0);0);EĞER(ESAYIYSA(T3);MAK(T3-9;0);0);EĞER(ESAYIYSA(X3);MAK(X3-9;0);0);EĞER(ESAYIYSA(Y3);MAK(Y3-9;0);0);EĞER(ESAYIYSA(Z3);MAK(Z3-9;0);0);EĞER(ESAYIYSA(AA3);MAK(AA3-9;0);0);EĞER(ESAYIYSA(AB3);MAK(AB3-9;0);0);EĞER(ESAYIYSA(AF3);MAK(AF3-9;0);0);EĞER(ESAYIYSA(AG3);MAK(AG3-9;0);0);EĞER(ESAYIYSA(AH3);MAK(AH3-9;0);0);EĞER(ESAYIYSA(AI3);MAK(AI3-9;0);0);EĞER(ESAYIYSA(AJ3);MAK(AJ3-9;0);0);EĞER(ESAYIYSA(AN3);MAK(AN3-9;0);0);EĞER(ESAYIYSA(AO3);MAK(AO3-9;0);0);EĞER(ESAYIYSA(AP3);MAK(AP3-9;0);0))

ntamero 12-02-2018 16:53

Teşekkür ederim. Peki hafta sonu için nasıl bir formül kullanmam gerekir ?.


Saat 11:44

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.