Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Excel'e Yeni Başlayanlar (http://www.excel.web.tr/forumdisplay.php?f=14)
-   -   seçilen ve seçilmeyen verileri ayırmak (http://www.excel.web.tr/showthread.php?t=170404)

onuroz1456 08-02-2018 11:13

seçilen ve seçilmeyen verileri ayırmak
 
Merhaba arkadaşlar,
A sütununda bulunan verilerden rastgele seçim yapıp, seçilenleri B sütununa yazıyorum. Daha sonra seçilmeyenleri de C sütununa almak istiyorum. Yani seçilenler ile seçilmeyenleri ayrı listelemek istiyorum. Bunu nasıl yapabilirim?
yardımlar için teşekkürler...

çıtır 08-02-2018 11:39

A1 Hücresinden itibaren veriler.B1 Hücresinden itibaren seçilenler var olduğu varsayılmıştır.
Dizi formülü C1 Hücresine kopyalayınız.Formül çubuğuna tıklayınız.Ctrl ve Shift tuşuna basılı iken enter tuşlayınız aşağı çekerek çoğaltınız.Kolay gelsin.
Kod:

=EĞERHATA(İNDİS($A$1:$A$100;KÜÇÜK(EĞER(EĞERSAY($B$1:$B$100;$A$1:$A$100)=0;SATIR($A$1:$A$100));SATIR(A1));SÜTUN(A1));"")

onuroz1456 08-02-2018 12:05

Teşekkür ederim, formül çalışıyor, ancak aralığı siz 100 yazmışsınız ben onu değiştirince formül çalışmıyor. 5756 adet ana veri, 3000 adet seçilen veri var, f

çıtır 08-02-2018 13:00

Alıntı:

onuroz1456 tarafından gönderildi (Mesaj 929511)
Teşekkür ederim, formül çalışıyor, ancak aralığı siz 100 yazmışsınız ben onu değiştirince formül çalışmıyor. 5756 adet ana veri, 3000 adet seçilen veri var, f

Dizi formülü:
Formül çubuğuna tıklayınız.Ctrl ve Shift tuşuna basılı iken enter tuşlayınız aşağı çekerek çoğaltınız
Kod:

=EĞERHATA(İNDİS($A$1:$A$6000;KÜÇÜK(EĞER(EĞERSAY($B$1:$B$6000;$A$1:$A$6000)=0;SATIR($A$1:$A$6000));SATIR(A1));SÜTUN(A1));"")

onuroz1456 11-02-2018 15:38

Sn Çıtır, formülü alt satırlara kopyaladığımda bilgisayar aşırı derecede kasıyor, tamamını hesaplayamıyor. acaba formülden mi, blgisayarımdan mı kaynaklı? Büyük veri setlerine başka formullerde kullanıyorum böyle olmuyor.

çıtır 11-02-2018 18:07

Sorun formülden kaynaklanmaktadır.Dizi formülü olduğu için aşırı hesaplamalar zaman almakta ve bilgisayarı kasmakta.Tamamını hesaplar fakat bilgisayarı kasar ve zaman alabilir.

onuroz1456 11-02-2018 19:21

Teşekkürler...


Saat 19:51

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.