Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Excel'e Yeni Başlayanlar (http://www.excel.web.tr/forumdisplay.php?f=14)
-   -   Satırdaki ilk "x" değerini bul, karşılık gelen tarihi yaz (http://www.excel.web.tr/showthread.php?t=170397)

hopeful 08-02-2018 06:53

Satırdaki ilk "x" değerini bul, karşılık gelen tarihi yaz
 
2 Eklenti(ler)
Merhaba,
Her satırın bazı hücrelerinde "x" değeri bulunmaktadır.
Tarih bölümüne; ilgili satırda yazan ilk "x" değerini bulup, o değerin bulunduğu tarih bilgisini formülle ya da makro ile yazdırabilir miyiz?
Yardımınızı rica ederim.

çıtır 08-02-2018 07:09

Dizi Formülü B2 kopyalayınız.Formül çubuğuna tıklayınız Ctrl ve Shift tuşuna basılı iken enter tuşlayınız.Aşağı çekerek çoğaltınız.Kolay gelsin.
Kod:

=İNDİS($A$1:$T$1;SATIR($A$1);KÜÇÜK(EĞER($C2:$T2="x";SÜTUN($C$1:$T$1));SATIR($A$1)))
İndis=ındex
Satır=Row
Küçük=Small
Eğer=If
Sütun=Column

hopeful 08-02-2018 09:24

Alıntı:

çıtır tarafından gönderildi (Mesaj 929473)
Dizi Formülü B2 kopyalayınız.Formül çubuğuna tıklayınız Ctrl ve Shift tuşuna basılı iken enter tuşlayınız.Aşağı çekerek çoğaltınız.Kolay gelsin.
Kod:

=İNDİS($A$1:$T$1;SATIR($A$1);KÜÇÜK(EĞER($C2:$T2="x";SÜTUN($C$1:$T$1));SATIR($A$1)))
İndis=ındex
Satır=Row
Küçük=Small
Eğer=If
Sütun=Column

Çok teşekkürler Sn Çıtır,

çıtır 08-02-2018 09:44

Alıntı:

hopeful tarafından gönderildi (Mesaj 929492)
Çok teşekkürler Sn Çıtır,

Rica ederim.Dönüş yaptığınız için teşekkür ederim.

mehmetuca 10-02-2018 09:22

B2 hücresine aşağıdaki formülü yazıp aşağıya doğru sürükleyin.

Kod:

=DOLAYLI(ADRES(SATIR()-(SATIR()-1);KAÇINCI("x";C2:T2;0)+2))

hmuratbtt 10-02-2018 18:28

Sayın çıtır ve Sayın Mehmetuca formüllerinizin mantığını, açıklamasını yazabilir misiniz? Farklı örnekleri öğrenmek iyi oluyor


Saat 01:27

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.