Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Excel'e Yeni Başlayanlar (http://www.excel.web.tr/forumdisplay.php?f=14)
-   -   formülde filtre (http://www.excel.web.tr/showthread.php?t=170392)

Bayaz 07-02-2018 21:57

formülde filtre
 
Merhaba,

=TOPLA.ÇARPIM((AY(A1:A4)=AY(TARİHSAYISI(C1&" 1")))*(YIL(A1:A4)=D1)*(A1:A4<>""))

Yukarıdaki Formül ÇOKEĞERSAY ile yapılabilir mi?

Eğer olamıyorsa da Olmaz cevabı veriniz Ltf. Tşkler.


-

çıtır 07-02-2018 22:08

Sayın Bayaz anlayabildiğim kadar A1:A4 tarih var.C1 ve D1 Hücrelerinde ne yazıyor? ve ne yapmak istediğinizi kısaça açıklar mısınız?

Bayaz 07-02-2018 22:30

A1:A4 (ölçüt aralığı) da "gg.aa.yyyy" formatında tarihler var.
C1 (ölçüt-1) de AY ismi (Ör: Ocak) var
D1 (ölçüt-2) de YIL (Ör: 2017) var

Ben bu tarihler arasından örnek kaç tane Ocak.2017 var, veya kaç tane Ocak.2018 var saydırmak istiyorum. Bu yukarıdaki formül ile oluyor ancak çalışma kitabını çok yavaşlatıyor. ÇOKEĞERSAY daha hızlı çalışıyor. Tşkler.

çıtır 07-02-2018 23:05

Maalesef çözüm oluşturamadım.Çözüm bulur isem yazarım.Kusura bakmayın.Çözüm bulan biri olur herhalde.

çıtır 08-02-2018 01:54

Sayın Bayaz;
A1:A4 Hücrelerinde Tarihler, C1 Hücresinde 1.Ölçüt Ay İsmi(Örn:Ocak) D1 Hücresinde 2.ölçüt Yıl (Örn:2017) Olduğu varsayımıştır.Çokeğersayla sorunuzun çözümü formülü aşağıda. Deneyiniz.
Kod:

=ÇOKEĞERSAY(A1:A4;">="&TARİHSAYISI(1&C1&D1);A1:A4;"<="&SERİAY(TARİHSAYISI(1&C1&D1);0))

Bayaz 08-02-2018 19:42

Sn. Çıtır;

Aklınıza, elinize sağlık teşekkür ederim.

çıtır 08-02-2018 21:22

Alıntı:

Bayaz tarafından gönderildi (Mesaj 929559)
Sn. Çıtır;

Aklınıza, elinize sağlık teşekkür ederim.

Rica ederim.Güzel dilekleriniz için ve dönüş yaptığınız için teşekkür ederim.

Bayaz 15-02-2018 14:02

Sn Çıtır, Yukarıda verdiğiniz formül çok işimi gördü tekrar teşekkürler.
Sizden tekrar bir ricam olacak.

aynı formülü ;
Kod:

=ÇOKEĞERSAY(A1:A4;">="&TARİHSAYISI(1&C1&D1);A1:A4;"<="&SERİAY(TARİHSAYISI(1&C1&D1);0))
AY ve YIL olarak ayrı ayrı hücrelerde kullanabilmek için formülü bölebilir miyiz?

Kolay gelsin.

çıtır 15-02-2018 14:13

Ay ve Yıl farklı hücrelerde.Ay C1 Hücresinde,Yıl D1 hücresinde .Bu hücreleri değiştirerek formülü kullanabilirsiniz.Sorunuz bu değil ise açıklayınız.Kusura bakmayın anlayamadım.

Bayaz 15-02-2018 15:12

Yok sorun bu değil. Bir tek YIL baktırabilir miyiz? Yani D1'e baksın C1'i iptal edelim. Kolondaki tarihler arasından YIL'ı süzsün istiyorum. :( Ben uğraştım ama yapamadım.
.


Saat 04:05

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.