Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Fonksiyonlar (http://www.excel.web.tr/forumdisplay.php?f=47)
-   -   ile göre numaralandırma (http://www.excel.web.tr/showthread.php?t=170370)

dimple77 07-02-2018 09:39

ile göre numaralandırma
 
Merhaba Arkadaşlar,
2 sütunum var birincisinden 1 den başlayarak numara yazdırıyorum ancak B sütunundaki il bilgisi değiştiğinde yine sayı 1 den başlaması gerekecek. Ancak foksiyonlarla bunu yapamadım. Bilen var mıdır?

Necdet 07-02-2018 10:16

Merhaba,

B sütununda illerin olduğu ve B1 hücresinin Başlık olduğu varsayarak :

A2 Formül

Kod:

=EĞERSAY($B$2:B2;B2)
ve formülü alt satırlara kopyalayın.

dimple77 07-02-2018 10:31

Çok teşekkür ederim. Çok işime yaradı. Bir sorum daha olacak. Eğer il yanında bir koşul daha eklesek örneğin hem Il bilgisine baksa ve yanındaki hücredeki değişikliğe göre tekrar 1 den başlasa nasıl yapabiliriz. Eğersay sanırım tek koşula bağlı çalışıyor. Örnek vermek gerekirse
SAYI IL DURUM
1 ADANA A
2 ADANA A
1 ADANA B
2 ADANA B
1 İZMİR A

Alıntı:

Necdet Yeşertener tarafından gönderildi (Mesaj 929357)
Merhaba,

B sütununda illerin olduğu ve B1 hücresinin Başlık olduğu varsayarak :

A2 Formül

Kod:

=EĞERSAY($B$2:B2;B2)
ve formülü alt satırlara kopyalayın.


ekoert 07-02-2018 11:46

=çokeğersay($b$2:b2;b2;$c$2:c2;c2)

dimple77 07-02-2018 11:54

Harikasınız teşekkür ederim.

Alıntı:

ekoert tarafından gönderildi (Mesaj 929380)
=çokeğersay($b$2:b2;b2;$c$2:c2;c2)



Saat 11:10

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.