Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Diğer Excel Soruları (http://www.excel.web.tr/forumdisplay.php?f=50)
-   -   Tek hücre içinde yazılı satır sayısını saydırmak. (http://www.excel.web.tr/showthread.php?t=170282)

officer08 02-02-2018 23:48

Tek hücre içinde yazılı satır sayısını saydırmak.
 
Örneğin A1 hücresi içinde aşağıdaki gibi satırlar var.

123456789 İSİM SOYİSİM
234578432 İSİM İSİM SOYİSİM
876543210 İSİM İSİM SOYİSİM
847562738 İSİM SOYİSİM

A1 hücresinde sayı veya metinden oluşan 4 satır bulunduğundan sonuç olarak A2 hücresine 4 sonucunu yazdırabilirmiyiz. Formülü varmıdır bunun.

çıtır 02-02-2018 23:59

Deneyiniz.Çözüm olabilir.
Kod:

=EĞER(UZUNLUK(KIRP(YERİNEKOY(A1;DAMGA(10);" ")))>0;UZUNLUK(KIRP(YERİNEKOY(A1;DAMGA(10);" ")))-UZUNLUK(YERİNEKOY(A1;DAMGA(10);""))+1;0)
Sayın Ömer BARAN uyarınız üzerine düzeltildi.Teşekkür ederim.Boş hücre olduğunda ALT+F11 geçilse 0 sonuçu verir.

Ömer BARAN 03-02-2018 02:36

Merhaba.

Sayın çıtır'ın gözünden kaçtı sanırım. Verilen formülün sonucu, açılış mesajındaki veri için 4 yerine 14 oluyor.

Aşağıdaki formülün istenilen sonucu vermesi gerekir.
(Tabi satırbaşı karakterinin ALT+F11 tuşu kullanılarak yazılmış olduğunu varsayıyorum)

►Sonuç alamıyorsanız; belgenizde mevcut gerçek verideki bir satırbaşı karakterini kopyalayın ve
bu karakteri örneğin B1 hücresine yapıştırın, C1'e de =KOD(B1) formülü uygulayın.
Bu formülün sonucu neyse, aşağıdaki formülde DAMGA(10) kısımlarındaki 10 sayısının yerine o sonucu yazın.

►Formül yine de istediğiniz sonucu vermiyorsa, birkaç hücrelik gerçek verinin olduğu bir örnek belge yükleyin onun üzerinden bakılsın.
Örnek belge yükleme yöntemine ilişkin kısa açıklama cevabımın altındaki İMZA bölümünde var.
.
Kod:

=EĞER(UZUNLUK(KIRP(A1))-UZUNLUK(YERİNEKOY(KIRP(A1);DAMGA(10);""))=0;0;UZUNLUK(KIRP(A1))-UZUNLUK(YERİNEKOY(KIRP(A1);DAMGA(10);""))+1)

officer08 03-02-2018 19:18

Herzamanki gibi yine çok yardımcı oldunuz teşekkür ederim sizlere. Kusura bakmayın geç bakabildim çok güzel çalışıyor, ellerinize sağlık.


Saat 21:57

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.