Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Fonksiyonlar (http://www.excel.web.tr/forumdisplay.php?f=47)
-   -   Topla.çarpım da koşula göre sayı dağıtma ve toplama (http://www.excel.web.tr/showthread.php?t=170277)

McDregin 03-02-2018 17:43

Hocam ilk hali öğle idi hesaplama her veri değişiminde 10-12 sn. tutuyordu.
Sonraki formülünüz ile 0,5 sn. ye indi.

Ay seçimi için bir kaç varyasyon deneyeceğim.
Teşekkürler.

McDregin 05-02-2018 12:53

Ömer Hocam merhaba,
32 satırdan başlayan sayı dağılımlarında ;

BBB - CCC - DDD - EEE kategori isimlerine bir sayı yazmadığımda ( satış olmadığında ) da arefe ~ milli bayramlarda ~ dini bayramlarda Tatil sayı azaltımları sayılarını getiriyor. ( B - D - H - F - J 4-10 Arası hücrelerde ) (b3 ten o3 e kadar olan taramayı k3 e kadar kısattım bu sefer #yok uyarısı verdi. Olmayan ürün gurubuna satış sayı yazmaması için.

Birde BBB kategorisi ürünlerin D 4-10 Arasına yazılan verilerinin C16-C457 Dağılımını sadece kendi satış adetleri üzerinden dağılımı için ne yapmam gerekir ? ( Tatil % Azaltımından sayı almadan. )

Teşekkürler.

Ömer BARAN 05-02-2018 15:07

1 Eklenti(ler)
Merhaba.

Belki de ekteki gibi bir tablo yapısı düşünmelisiniz.
.

McDregin 05-02-2018 15:40

Ömer hocam,
B4>>B15 manuel mi tarih değiştiriyoruz ?
Formülasyon alıyor ama B2 yi mart a getirince B4-B15 arası değişmedi.

Ömer BARAN 05-02-2018 15:53

Amacınızı bilemediğim için öyle yapmıştım.

B4 hücresinde yer alan METNEÇEVİR işlevi parantezinin içindeki TARİH(YIL($B$2);SATIR(A1);1) kısmını
TARİH(YIL($B$2);AY($B$2)+SATIR(A1)-1;1) olarak değiştirip aşağı doğru kopyalayın.

McDregin 05-02-2018 16:59

Tatil günleri için ayrı bir tablo oluşturarak ı kolonuna bağlayacağım.
Böylece tarih değiştiğinde otomatik tatil günleri de değişecek formülü yazıyorum.
Bu şekilde yeni tablo yapısını sağlamlaştırırım diye düşünüyorum.

McDregin 05-02-2018 17:01

1 Eklenti(ler)
Hocam yan sayfada Yıllık tatilleri işledim.
I 19 Hücresi
Bağladım ama örneğin Yılbaşını Normal gördü.

Ömer BARAN 05-02-2018 17:47

Tekrar merhaba.

Önce bir hatırlatma; Ulusal Bayram sadece ☾✭ Cumhuriyet Bayramı ✭☽ olup 28 Ekim öğle'den itibaren 1,5 gündür.
Diğerlerinin durumu Cumhuriyet Bayramı'ndan farklıdır.
(ULUSAL BAYRAM VE GENEL TATİLLER HAKKINDA KANUN için tıklayın)

Tablonuzda bu tatil/arefe günleri için gerekli düzenlemeleri yaparsınız artık.

►H19 hücresine;
Kod:

=EĞER(EĞERSAY('YILLIK TATİLLER'!$A$1:$A$47;$B19)=0;"";EĞER(KAYDIR('YILLIK TATİLLER'!$B$1;KAÇINCI($B19;'YILLIK TATİLLER'!$A$1:$A$47;0)-1;0)=0;"";KAYDIR('YILLIK TATİLLER'!$B$1;KAÇINCI($B19;'YILLIK TATİLLER'!$A$1:$A$47;0)-1;0)))
► I19 hücresine;
Kod:

=EĞER(EĞERSAY('YILLIK TATİLLER'!$A$1:$A$47;$B19)=0;"NORMAL";KAYDIR('YILLIK TATİLLER'!$C$1;KAÇINCI($B19;'YILLIK TATİLLER'!$A$1:$A$47;0)-1;0))

McDregin 06-02-2018 09:50

Ömer hocam,
Çok teşekkür ederim.
Her satış gurubu için ayrı % kriter tablosu oluşturdum.
Tam oturdu.
Elinize sağlık.
Hakkınızı helal edin.
Saygılar.

McDregin 06-02-2018 16:15

Ömer hocam merhaba,
M19>>O19 arasındaki yüzde oranı kadar alıyorken (100 adet %80 ise 80 adet..)
P19 >> S19 arası yazılan % kadar bırakıyor. ( 100 adet %80 de 20 adet kalıyor.)
Düzeltmem için ne yapmam gerekir ?
Teşekkürler.


Saat 20:14

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.