Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Diğer Excel Soruları (http://www.excel.web.tr/forumdisplay.php?f=50)
-   -   Yapamadığım 3 Formül var, yardım edermisiniz (http://www.excel.web.tr/showthread.php?t=170232)

officer08 31-01-2018 21:18

Yapamadığım 3 Formül var, yardım edermisiniz
 
Yapamadığım formulleri içerir tabloyu aşağıdaki linke attım. Yardım ederseniz çok sevinirim.Teşekkürler.



http://s7.dosya.tc/server2/rljqy3/TABLO.xlsx.html

faye_efsane 31-01-2018 21:56

Merhaba,
1. Sorunuz için :
Kod:

=EĞERSAY(C2:C17;E1)
2. Sorunuz için : Ayların olduğu sütunda Ocak-Şubat-Mart eşleşmesi olmadığı için toplatamazsınız.
3. Sorunuz için :
Kod:

=ÇOKETOPLA(B2:B17;C2:C17;E1)
formülünü kullanabilirsiniz.

Ömer BARAN 31-01-2018 21:58

Merhaba.

Anladığım kadarıyla 3 formüle ihtiyaç yok, istedikleriniz için iki adet formül yeterli olur.

Hem tek ay adı seçtiğinizde hem de bir'den fazla ay adını içeren seçeneği seçtiğinizde geçerli olmak üzere;
adet sayımı için birinci formülü, B sütunu toplamı için ikinci formülü kullanabilirsiniz.

Formülleri iki ayrı hücreye uygulayın ve
B sütunundaki sayılar ile C sütunundaki ay adlarında değişiklikler yaparak formül sonuçlarındaki değişiklikleri gözlemleyin.
.
Kod:

=TOPLA.ÇARPIM(--(UZUNLUK($E$1)<>UZUNLUK(YERİNEKOY($E$1;$C$2:$C$17;""))))
=TOPLA.ÇARPIM((UZUNLUK($E$1)<>UZUNLUK(YERİNEKOY($E$1;$C$2:$C$17;"")))*($B$2:$B$17))


officer08 31-01-2018 22:13

Arkadaşlar ikinize de çok teşekkür ederim. Çok yardımcı oldunuz. Daha sizlerden öğrenecek çok şey var.

officer08 01-02-2018 00:49

Hata
 
Arkadaşlar bir sorun oluştu. Şöyleki formulünüzde kullanılan bir hücrede baska bir formül yazılıysa kabul etmiyor.Ancak o formulü silip elle manuel değer girersem çalışıyor.

Ömer BARAN 01-02-2018 03:02

Tekrar merhaba.

-- C sütunundaki bir formülü paylaşın,
-- veya örnek belgenizin gerçek belgenizle aynı yapıda olmasını (kullandığınız formüller içerisinde olacak şekilde) sağlayın
ki deneme yapabilelim değil mi?

Aslında örnek belgelerin, gerçek belgenin küçük bir kopyası
(veri yığınının büyük tutulmaması, ancak desteğe ihtiyaç duyulan durum/sorulan hususu etkileyen hücrelerle ilgili tüm seçenekleri içermesi beklenir)
olarak kaydedilip eklenmesi beklenir ve çabuk ve net çözüme ulaşmanın yolu da bu.
Tabi ki; belgedeki özel bilgileri gerçek olmayan verilerle değiştirebilir/silebilirsiniz.
.


Saat 03:17

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.