Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Fonksiyonlar (http://www.excel.web.tr/forumdisplay.php?f=47)
-   -   Birden fazla veriyi bulup işlem yapma (http://www.excel.web.tr/showthread.php?t=170147)

mesutaygun70 29-01-2018 07:43

Birden fazla veriyi bulup işlem yapma
 
Ekteki gibi bir formum var. Sales içerisinde veriler var. Sayfa1 de ise tablo var.
Sayfa1 deki tarihi "Sales" içerisinde arayacak bulduğu tarihteki b sutunundaki eşleşen verilerin toplamını c sutununa yazacak. Hangi işlevi kullanacağımı bilemedim.
http://www.dosya.tc/server11/japdiy/...SATIS.rar.html

çıtır 29-01-2018 08:19

Sayfa1 C2 Hücresine kopyalayınız.Aşağı çekerek çoğaltınız.Kolay gelsin.
Kod:

=TOPLA.ÇARPIM((TAMSAYI(Sales!$A$2:$A$2000)=$A2)*(Sales!$B$2:$B$2000=$B2)*(Sales!$C$2:$C$2000))

McDregin 31-01-2018 11:19

Çoklu veri toplamada Tarih yazım uyuşmazlığı hk.
 
1 Eklenti(ler)
Merhaba Hocam,
Tarihleri belirlemede sıkıntı yaşadım.
Ekteki tabloda 2 sayfa var.
Buralarda sarı ile takıldığım noktayı yazdım.
Destek olabilir misiniz.
Şimdiden Teşekkürler.

Korhan Ayhan 02-02-2018 23:43

Deneyiniz.

C2;
Kod:

=DÜŞEYARA(C1;'XXX YEMEK GÜN SAYI'!$A$16:$D$29;4;0)
C4;
Kod:

=DÜŞEYARA(C1;'XXX YEMEK GÜN SAYI'!$A$16:$D$29;2;0)
C6;
Kod:

=DÜŞEYARA(C1;'XXX YEMEK GÜN SAYI'!$A$16:$D$29;3;0)

Diğer sayfada B16 hücresine;

Kod:

=TOPLA.ÇARPIM((METNEÇEVİR($A$32:$A$455;"aa yyy")=METNEÇEVİR(A16;"aa yyy"))*(B$32:B$455))
Formülünü uygulayın alta ve sağa doğru sürükleyin.


Saat 16:09

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.