Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Makro-VBA (http://www.excel.web.tr/forumdisplay.php?f=48)
-   -   Formülde hücre değerlerini otomatik arttırma (http://www.excel.web.tr/showthread.php?t=169484)

ersingur 03-01-2018 22:08

Formülde hücre değerlerini otomatik arttırma
 
Merhabalar,
sabit bir formülde alınan referans numaraları 25 er artmaktadır bu hücre değerlerini otomatik olarak 25 er arttırmamız mümkün mü acaba ? Şimdiden teşekkür ederim.Aşağıdaki e hücre değerini 25 er arttırmak istiyorum.

=TOPLA('02 br 04 veri'!E1632:E1656)

Haluk 03-01-2018 22:38

Merhaba;

Aşağıdaki formül; 02 br 04 veri sayfasında E2:E1800 aralığında, E2 hücresinden başlayarak 25'erlik artışlarla hücrelerin içindeki verileri toplar.

Yani; E2 + E27 + E52 + E77 ......

Kod:

=SUMPRODUCT((MOD(ROW('02 br 04 veri'!$E$2:$E$1800);25)=0)*('02 br 04 veri'!$E$2:$E$1800))
Excel'iniz Türkçe ise, formülde Türkçe karşılıkları kullanmanız gerekir.

Forum üyelerinden İdris Beyin sitesinden indirebileceğiniz dosya ile karşılıklarını bulabilirsiniz;

http://www.excelgurusu.com/excel-isl...-alphabetical/


.

Ömer BARAN 03-01-2018 23:01

Merhaba.

Konuyu Makro VBA bölümüne açmışsınız ancak formül ile çözüme ilişkin fikrimi söylemek istedim.

Gördüğüm kadarıyla; satır numaraları arasında (... * 25+7 ve ... * 25+6) şeklinde bir ilişki var
ama gereksiz mesajlaşmalara neden olmamak bakımından,
formülün uygulandığı ilk birkaç hücrenin olduğu bir örnek belge yüklemenizde yarar var.

Örnek belgenizin gerçek belgeyle aynı yapıda olmasını ve anlamlı veriler içermesini sağlayınız.
Örnek belge özellikleri ve örnek belge yükleme yöntemine ilişkin kısa açıklama cevabımın atındaki İMZA bölümünde var.

-- İsterseniz aşağıdaki formülü işlem yapılacak ilk hücreye uygulayın ve aşağı doğru yeterince satıra kopyalayın.
-- Verdiğim formüle göre; ilk formül hücresinde toplanacak alan E7:E31 iken bir sonrakinde E32:E56...... formülün uygulandığı 66'ncı satırda ise sorunuzda belirttiğiniz E1632:E1656 olur.
.
Kod:

=TOPLA(DOLAYLI("'02 br 04 veri'!"&ADRES((SATIR(A1)-1)*25+7;5;4)&":"&ADRES((SATIR(A1))*25+6;5;4)))

ersingur 04-01-2018 18:09

cevabınız için teşekkür ederim toplam için formülünüzü uygulayabildim linkteki excelde max ve ortalama içinde formül yazmıştım acaba bunlarada sizin formülünüzü uyarlayabilir miyiz ?
Teşekkürler.

http://dosya.co/kruh38fo4tvv/MERSİN_..._(1).xlsx.html


Saat 20:55

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.