Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Fonksiyonlar (http://www.excel.web.tr/forumdisplay.php?f=47)
-   -   sıfırdan büyük değeri olan malzemeleri sıralamak (http://www.excel.web.tr/showthread.php?t=169467)

yucel baygul 03-01-2018 12:10

sıfırdan büyük değeri olan malzemeleri sıralamak
 
1 Eklenti(ler)
ekli dosyada ürünlerin malzemelerini sıralamak istiyorum. tablodaki sıfırdan büyük değeri olan malzemeleri sıralamk istiyorum.
bunu YERLEŞİK FONKSİYON larla yapmak istiyorum. İlginize teşekkürler

Ömer BARAN 03-01-2018 13:40

Merhaba.

-- P3 hücresine uygulayıp dizi formülüne dönüştürün ve yeterince aşağı doğru kopyalayın.
.
Kod:

=EĞERHATA(KAYDIR($A$3;0;KÜÇÜK(EĞER($A$4:$A$8=$P$2;EĞER($B$4:$M$8>0;SÜTUN($B$4:$M$8)));SATIR(A1))-1);"")

Formülün dizi formülüne dönüştürülmesi:
- Formülü hücreye yapıştırın,
- F2 tuşuna basarak hücre içerisine girin,
- CTRL ve SHIFT tuşları basılı durumda iken ENTER tuşuna basarak işlemi tamamlayın.
İşlem doğru yapılmışsa formül kendiliğinden {....} gibi köşeli parantez arasına alınır.

-- Q3 hücresine uygulayın ve yeterince aşağı doğru kopyalayın.
.
Kod:

=EĞER(P3="";"";TOPLA.ÇARPIM(($A$4:$A$8=$P$2)*($B$3:$M$3=P3)*($B$4:$M$8)))

yucel baygul 04-01-2018 08:46

sn Ömer BARAN ilginize teşekkürler. çözüm oldunuz.

Ömer BARAN 04-01-2018 14:12

.
İyi çalışmalar dilerim.
.


Saat 10:17

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.