Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Diğer Excel Soruları (http://www.excel.web.tr/forumdisplay.php?f=50)
-   -   İki Zaman Arasındaki Fark (http://www.excel.web.tr/showthread.php?t=169434)

serdx 02-01-2018 12:05

İki Zaman Arasındaki Fark
 
Merhaba Arkadaşlar...

Mesai saatleri konusunda yardımınıza ihtiyacım var.

a kişisi 21 saat 20 dakika daha çalışması gerekirken 4 saat 45 dakika çalışmış.

Geriye 16 saat 35 dakika daha çalışması gerekiyor.


b kişisi de 9 saat 30 çalışması gerekirken 11 saat 15 dakika çalışmış. 1 saat 45 dakika fazla mesaisi var.


Sorum şu:
büyük saatten küçük saati çıkarınca normal fakat küçük saatten büyük saat çıkarınca ###### oluyor. Bunu nasıl düzeltebilirim?

çıtır 02-01-2018 12:52

Hücre biçimi saat veya hücre refaranslı
Kod:

=MUTLAK("04:45"-"21:20")

serdx 02-01-2018 12:59

Alıntı:

çıtır tarafından gönderildi (Mesaj 924182)
Hücre biçimi saat veya hücre refaranslı
Kod:

=MUTLAK("04:45"-"21:20")


Teşekkür ederim formülü kendime göre düzenleyip sonucu aldım.Bir sorum sana olacak 35 saat 30 dakika olan kişilerde var fakat 35:30 yazdığım zaman 00:00 olarak değiştiriyor. Bunu nasıl düzeltebilirim?

bmutlu966 02-01-2018 12:59

1 Eklenti(ler)
Sanırım işinizi çözecektir.

serdx 02-01-2018 13:08

Alıntı:

bmutlu966 tarafından gönderildi (Mesaj 924184)
Sanırım işinizi çözecektir.


Maalesef dosya indiremiyorum.

parametre 02-01-2018 13:47

selamlar c8 yapılacak işlem olarak varsayılmıstır hücreleri değiştirerek ilgili yerlere kopyalayınız bmutlu arkadasımızın onerdigi formuldur
Kod:

=+EĞER(C8>D8;C8-D8;D8-C8)

çıtır 02-01-2018 14:13

Çalışılan süre A2 de Çalışılması gereken süre B2 de olduğu varsayımıştır.C2 ye kopyalayınız
Kod:

=MUTLAK(A2-B2)
ve C2 nin hücre biçimini isteğe göre düzenlenmiş tür kısmına [s]:dd:nn yazınız veya seçiniz sonuçu aşağıdaki alanlarada uygulayınız.

Ömer BARAN 02-01-2018 14:13

Merhaba.

Alternatif olsun.
Başlangıç saati A1, bitiş saati B1 hücresinde ise EĞER işlevini kullanmadan aşağıdaki şekilde de olabilir.
Kırmızı kısım, başlangıç saati bitişten büyükse 1 sonucunu verir (1 sayısı zaman işlevlerinde 24 saat demek oluyor) ve işlem hatasız sonuçlandırılır.

NOT: 24:00 'ten büyük saat verisi yazabilmek veya işlem sonucunu bundan büyük olacak şekilde elde etmek için,
ilgili hücrenin biçimini İSTEĞE UYANLANMIŞ kısmını kullanarak [s]:dd olarak ayarlayınız.
.
Kod:

=(A1>B1)+B1-A1

serdx 02-01-2018 15:22

B1 c1 d1 e1
kişi çalışması gereken çalışmış kalan saat gün sayısı
a 21:20 04:45 16:35
b 35:30 04:45 30:45



d1 iki saat arasındaki fark formül olarak

e1 sütununu da d1/8:15

8:15 toplam mesai saati
e1 gün sayısı



böyle karmaşık bir formül lazım inşallah anlatabilmişimdir...

serdx 02-01-2018 15:25

https://resmim.net/f/EOaaAk.jpg


Saat 21:19

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.