Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Excel'e Yeni Başlayanlar (http://www.excel.web.tr/forumdisplay.php?f=14)
-   -   İki koşul için tarih bazında filtreleyerek saydırma (http://www.excel.web.tr/showthread.php?t=169329)

redtacton 28-12-2017 15:28

İki koşul için tarih bazında filtreleyerek saydırma
 
1 Eklenti(ler)
Merhaba arkadaşlar,

Ekteki deneme.xlsx dosyasında veri alanı TAKIP sekmesi olup saydırma yaptırmak istediğim ama RAPOR sekmesidir. Yeşil boyalı alanlara fonksiyon yazarak veri getirmek istiyorum.

İstek şöyle;
- Sipariş sayısını; sipariş tarihini aylık olarak gözeterek saydırıp ilgili satış temsilcisi karşısına saydırsın. (Ben burda tarihten ay a çevirip saydırtamadım)

- "Sevkiyat türü" ne göre; adedini gene "sevk tarihi" ni baz alarak ilgili kargo şirketi karşına saydırsın. (Gene burada tarihden saydırma yapamadım.)

Yardımlarınız için şimdiden teşekkürler...

Ömer BARAN 28-12-2017 16:23

Merhaba.

-- C3 hücresine uygulayın ve ardından sağa ve aşağı kopyalayın.
Kod:

=TOPLA.ÇARPIM((TAKIP!$D$2:$D$9=$A3)*(AY(TAKIP!$C$2:$C$9)=KAÇINCI(C$1;{"OCAK";"ŞUBAT";"MART";"NİSAN";"MAYIS";"HAZİRAN";"TEMMUZ";"AĞUSTOS";"EYLÜL";"EKİM";"KASIM";"ARALIK"};0)))
-- C10 hücresine uygulayın ve ardından sağa ve aşağı kopyalayın
( RAPOR sayfasında KARGO firma isimlerinin sonundaki BOŞLUK karakterlerini silin, yani TAKIP sayfasındaki ile birebir aynı olmasını sağlayın )
Kod:

=TOPLA.ÇARPIM((TAKIP!$E$2:$E$9=$A10)*(AY(TAKIP!$F$2:$F$9)=KAÇINCI(C$1;{"OCAK";"ŞUBAT";"MART";"NİSAN";"MAYIS";"HAZİRAN";"TEMMUZ";"AĞUSTOS";"EYLÜL";"EKİM";"KASIM";"ARALIK"};0)))

redtacton 29-12-2017 10:10

Ömer bey,

Teşekkürler. İşe yaradı...

Yalnız bir ekstra durum sözkonusu...

Bu fonksiyona bir de yıl filtresi eklemek istersem nasıl yapabilirim. Şuan veri dosyasında 2016, 2017 var. Ancak bu formülle örneğin; 2017 aralıkla 2016 aralık takileri bir sayıyor.
2016 ocak.....aralık a; ayrı bir fonksiyon...
2017 ocak.....aralık a; ayrı bir fonksiyon girebilirim.

Hızlı cevabınız için şimdiden çok teşekkürler...

Ömer BARAN 29-12-2017 11:38

Tekrar merhaba.

RAPOR sayfasının B1 hücresine ilgilenilen yıl bilgisini yazın (B1 hücresine veri doğrulama uygulayarak, açılır listeden yıl seçimi de yapabilirsiniz)
verdiğim her iki formüle, en sondaki parantezden önce *(YIL(TAKIP!$C$2:$C$9)=$B$1) ekleyip formülleri tekrar kopyalayın.
.

redtacton 02-01-2018 09:07

Merhabalar,

Harika! Tam istediğim gibi çalışıyor. Emeğinize sağlık...

Saygılar!


Saat 00:06

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.