Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Makro-VBA (http://www.excel.web.tr/forumdisplay.php?f=48)
-   -   Tablo kesişim hücresini renklendirme (http://www.excel.web.tr/showthread.php?t=169213)

admadm_61 24-12-2017 14:03

Tablo kesişim hücresini renklendirme
 
1 Eklenti(ler)
Merhabalar
Ekli dosyada kriterlere göre tabloda kesişim noktasını renklendirmek ve sonucu C4 hücresine yazdırmak istiyorum. Yardımlarınız için teşekkür ederim.

YUSUF44 24-12-2017 14:56

C4 hücresinde aşağıdaki formülü kullanın:

Kod:

=İNDİS($C$7:$G$10;KAÇINCI($F$1;$B$7:$B$10;);KAÇINCI($F$2;$C$6:$G$6;))
Sonuç hücresinin renklenmesi için C7:G10 aralığını seçin
Koşullu biçimlendirme menüsünü açın
Yeni kural ekleyin
Kural olarak formül kullanmayı seçin
Açılan formül çubuğuna aşağıdaki formülü yazın:

Kod:

=VE($F$1=$B7;$F$2=C$6)
Biçim düğmeisnden istediğiniz biçimi ayarlayıp çıkın.

admadm_61 24-12-2017 15:22

Teşekkür ederim YUSUF44.

admadm_61 03-01-2018 08:21

Merhabalar,
Öğrenmek açısından aynı işlemi vba kodlarıyla nasıl yapabilirim.

YUSUF44 04-01-2018 07:29

Aşağıdaki kodları ilgili sayfanın kod bölümüne (sayfa adına sağ tıklayıp Kod Görüntüle deyince açılan sayfaya) kopyalarsanız, F1 ve F2 hücrelerini değiştirdiğinizde istediğiniz işlemi yapar:

Kod:

Private Sub Worksheet_Change(ByVal Target As Range)
On Error Resume Next
If Intersect(Target, [F1:F2]) Is Nothing Then Exit Sub
sonsat = Cells(Rows.Count, "B").End(3).Row
sonsüt = Cells(6, Columns.Count).End(xlToLeft).Column
a = WorksheetFunction.Match([F1], Range("B7:B" & sonsat), 0)
b = WorksheetFunction.Match([F2], Range(Cells(6, "C"), Cells(6, sonsüt)), 0)
Range(Cells(6, "B"), Cells(sonsat, sonsüt)).Interior.Color = xlNone
Cells(a + 6, b + 2).Interior.Color = vbYellow
[C4] = Cells(a + 6, b + 2)
End Sub



Saat 10:40

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.