Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Excel'e Yeni Başlayanlar (http://www.excel.web.tr/forumdisplay.php?f=14)
-   -   Çoklu DüşeyAra (http://www.excel.web.tr/showthread.php?t=168054)

husocan005 10-11-2017 15:57

Çoklu DüşeyAra
 
Arkadaşlar bir formul yazdım fakat formülü aşağı doğru çektiğimde düşeyara bilgileri getirmiyor.


açıklamalar ektedir.

http://s5.dosya.tc/server5/cy9stx/20...2017.xlsx.html

1903emre34@gmail.com 10-11-2017 17:59

Mevcut sayfasında F2 hücresine aşağıdaki formülü denermisiniz

Kod:

=ÇOKETOPLA('DIŞARIDAN GELEN'!E:E;'DIŞARIDAN GELEN'!C:C;MEVCUT!C2;'DIŞARIDAN GELEN'!D:D;MEVCUT!D2)

husocan005 10-11-2017 19:27

yok hocam olmadı değerleri getirmedi. Eskiden bir arkadaş =IF(AND(VLOOKUP(C2;'DIŞARIDAN GELEN'!$C:$E;3;FALSE);VLOOKUP(D2;'DIŞARIDAN GELEN'!$D:$E;2;FALSE));VLOOKUP(D2;'DIŞARIDAN GELEN'!$D:$E;2;FALSE);"YOK") Bu formülü uyarlamıştı fakat bunu yazdığımda sanırım belirli bi sutuna göre ayarlandığı için sanırım aynı verileri getiriyor. bu formülü tüm verileri düşeyaramak için sonsuz yapabilirmiyix

husocan005 10-11-2017 20:30

FARKLI bir yöntem varmıdır arkadaslar

asri 11-11-2017 10:59

Alternatif;

Sayfanızda otomatik hesaplama kapalı. Değer getirmeme sebebi bu olabilir mi?
Çoketopla ile yaptığımda değerleri getiriyor.

Kod:

=TOPLA.ÇARPIM((C2='DIŞARIDAN GELEN'!C2:C100000)*(D2='DIŞARIDAN GELEN'!D2:D100000)*('DIŞARIDAN GELEN'!E2:E100000))


Saat 00:08

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.