Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Diğer Excel Soruları (http://www.excel.web.tr/forumdisplay.php?f=50)
-   -   Yıllık İzin Hesaplama sorun... (http://www.excel.web.tr/showthread.php?t=168049)

serdx 10-11-2017 13:22

Yıllık İzin Hesaplama sorun...
 
merhaba excel.web.tr ailesi yıllık izinler hakkında yardımınıza ihtiyacım var.

sorum şu:

yıllık izin hesaplarken 1-5 yıl 14, 6-14 yıl 20, 15 ve üstü 26 gün yıllık izin hakettiği için 10.11.2000 yılında işe giren bir insanın toplam 10.11.2017 tarihi itibariyle 328 gün izni olması gerekiyor.

şimdi otomatik olarak tarih ilerledikçe 5 yıldan sonra nasıl 20 gün olarak hesaplar?

toplam 17 yıl çalıştığına göre ilk 5 yıl 14, 6-14 20, 15 ve üstü 26 yı otomatik hesaplatabilir miyiz? yani bir hücrede tarih ilerledikçe otomatik olarak 328 nasıl yazar?

Ömer 10-11-2017 14:38

Merhaba,

İşe giriş tarihi A1 hücresinde düşünüldü.

Kod:

=TOPLA.ÇARPIM(ARA(SATIR(DOLAYLI("1:"&ETARİHLİ(A1;BUGÜN();"y")));{1;6;15};{14;20;26}))


.

serdx 10-11-2017 14:45

çok teşekkür ederim elinize sağlık tam istediğim gibi.
Ufak bir sorum daha olacak giriş tarihleri 2017 olanlarda hata veriyor onu nasıl düzeltirim?

Ömer 10-11-2017 14:49

Bu şekilde deneyin.

Kod:

=EĞER(ETARİHLİ(A1;BUGÜN();"y")=0;0
 ;TOPLA.ÇARPIM(ARA(SATIR(DOLAYLI("1:"&ETARİHLİ(A1;BUGÜN();"y")));{1;6;15};{14;20;26})))



.

serdx 10-11-2017 14:53

bu şekilde 20 gün olanları bile sadece 14 gün veriyor

Ömer 10-11-2017 14:58

Mesajı düzeltmiştim. #4 numaralı mesajdaki yeni formülü kopyalayıp tekrar denermisiniz.

.

serdx 10-11-2017 15:02

Alıntı:

ömer tarafından gönderildi (Mesaj 916960)
mesajı düzeltmiştim. #4 numaralı mesajdaki yeni formülü kopyalayıp tekrar denermisiniz.

.



çok teşekkür ederim elinize sağlık...


Saat 12:50

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.