Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Excel'e Yeni Başlayanlar (http://www.excel.web.tr/forumdisplay.php?f=14)
-   -   7 den fazla eğer formülünde sayı biçimlendirme veya formülü küçültme (http://www.excel.web.tr/showthread.php?t=168046)

acarmuhasebeci 10-11-2017 10:33

7 den fazla eğer formülünde sayı biçimlendirme veya formülü küçültme
 
1 Eklenti(ler)
Sayın Üstadlarım Merhabalar,
=EĞER($CK$5=11;CK14+CB14;"")&EĞER($CK$5=10;CK14+CB 14+BV14;"")&EĞER($CK$5=9;CK14+CB14+BV14+BP14;""&EĞ ER($CK$5=8;CK14+CB14+BV14+BP14+BJ14;"")&(EĞER($CK$ 5=7;CK14+CB14+BV14+BP14+BJ14+BD14;"")&(EĞER($CK$5= 6;CK14+CB14+BV14+BP14+BJ14+BD14+AX14;"")&EĞER($CK$ 5=5;CK14+CB14+BV14+BP14+BJ14+BD14+AX14+AR14;"")&EĞ ER($CK$5=4;CK14+CB14+BV14+BP14+BJ14+BD14+AX14+AR14 +AL14;"")&EĞER($CK$5=3;CK14+CB14+BV14+BP14+BJ14+BD 14+AX14+AR14+AL14+AF14;"")&EĞER($CK$5=2;CK14+CB14+ BV14+BP14+BJ14+BD14+AX14+AR14+AL14+AF14+Z14;""))))

böyle uzun bir formülüm var. Buradaki amacım CK 5 e 1 den 12 nci aya kadar hangi ayı yazarsam kalan ayların sayılarını toplasın. Örneğin CK5 e 10 yazarsam 11 nci ve 12 nci ayları toplasın. Bu formülümle Topluyor. Ancak sayı biçimlendirmesi yapamıyorum. ve Formül de çok uzun. Bunun bir çözümü varsa yazarsanız çok memnun olurum.Örnek dosya ektedir.
Saygılarımla,

Emir Hüseyin Çoban 10-11-2017 10:52

.

Kod:

=SAYIYAÇEVİR(formülünüz)
.

acarmuhasebeci 10-11-2017 10:55

Sayın Emir Hüseyin Çoban,
Çok teşekkürler. Formülü kısaltma yolu veya başka bir formül varmıdır. Yoksa bu şekilde mi kalmalı.

Ömer BARAN 10-11-2017 12:37

Merhaba.

Aşağıdaki formülü kullanabilirsiniz.
Formülü sağa doğru, CO ve CP sütunlarına da kopyalayabilirsiniz.
.
Kod:

=CK7+TOPLA.ÇARPIM((MOD(SÜTUN($N$6:$CG$6)-13;6)=SÜTUN(A1))*(((SÜTUN($N$6:$CG$6)-11)/6>$CK$5))*($N7:$CG7))

acarmuhasebeci 10-11-2017 13:14

Sayın Ömer Baran Üstadım.
Gerçekten müthişsiniz. Çok teşekkür ederim.
Formül süper çalışıyor. Aklınıza, elinize, emeğinize sağlık.
Tekrar tekrar teşekkürler.
Saygılarımla,


Saat 10:12

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.