Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Diğer Excel Soruları (http://www.excel.web.tr/forumdisplay.php?f=50)
-   -   İki değer arasındaki sütundaki ortalamayı alma (http://www.excel.web.tr/showthread.php?t=167838)

ufukozcan2011 02-11-2017 01:18

İki değer arasındaki sütundaki ortalamayı alma
 
1 Eklenti(ler)
Merhaba. Ekteki örnekte yapmak istediğim şey bir sütundaki iki değer arasındaki sayıların ortalamasını almak istiyorum.Örnek dosyada B2:B11 arasında veriler var, fakat verileri kopyalacağım sitede bu değerler değişken olabiliyor daha fazla veya daha az olabiliyor.Örneğin B2:B35 gibi. benim istediğim ise B3 ile son hücreden bir önceki hücreye kadar olan yere kadar ortalama yapmak. B3:B10 gibi. Bunun için nasıl formül kullanmalıyım?

Ömer BARAN 02-11-2017 01:43

Merhaba.

B sütunu için, aşağıdaki formülü kullanabilirsiniz (D sütunu için mavi renklendirdiğim kısmı D2 olarak değiştirin.
Son satırın tespiti C sütunu üzerinden (tümü metin olduğundan) yapılıyor.
.
Kod:

=ORTALAMA(KAYDIR(B2;;;KAÇINCI("ZZZ";$C:$C;1)-3))

ufukozcan2011 02-11-2017 01:51

Alıntı:

Ömer BARAN tarafından gönderildi (Mesaj 915821)
Merhaba.

B sütunu için, aşağıdaki formülü kullanabilirsiniz (D sütunu için mavi renklendirdiğim kısmı D2 olarak değiştirin.
Son satırın tespiti C sütunu üzerinden (tümü metin olduğundan) yapılıyor.
.
Kod:

=ORTALAMA(KAYDIR(B2;;;KAÇINCI("ZZZ";$C:$C;1)-3))

Teşekkürler hemen deniyorum

ufukozcan2011 02-11-2017 01:56

Ömer Bey yalnız ilk değer B11 hücresi benim istediğim B2:B11 arasındaki B3:B10 ortalamaları. B11 değişken olabiliyor ben bunun için =ARA(2;1/(C2:C1001<>"");C2:C1001) formülünü kullanmıştım. böylece en alttaki değeri bulabiliyordum.

Ömer BARAN 02-11-2017 02:05

Verdiğim formülün sonucunu kontrol edin.
Belirttiğiniz ARA işleviyle son değeri buluyorsunuz, size lazım olan son değer değil, son satır numarası.

ufukozcan2011 02-11-2017 02:09

verdiğiniz formülün sonucu B3:B11 ortalamasını alıyor. Bu ara formülünü bu formülün içne nasıl dahil edebiliriz?Ayrıca "ZZZ" değerini anlmadım?

Ömer BARAN 02-11-2017 02:26

Yanılıyorsunuz.
Formül B3:B10 arasının ortalamasını alıyor. Mevcut verilere göre verdiğim formülün sonucu 0,97125.

-- Kaydırılacak hücre: B2.
-- Kaydırma satır sayısı: 8 (KAÇINCI("ZZZ";$C:$C;1)-3) , yani varılacak hücre adresi B10 oluyor.

Sayısal gibi görünen B ve D sütununda METİN de olduğundan (B11 ve D11), tümü metin olan C sütunu üzerinden son satır numarasını bulmayı düşündüm.
KAÇINCI formülü, C sütununda ZZZ değerini arar, bulamayınca son METİN değerinin satır numarasını bulur (sondaki 1 sayısı).
Bundan sonra 3 çıkartma işlemini de şöyle söyleyeyim:
-- KAYDIR işlevinde başlangıç hücresi HARİÇ satır sayısı verilir.
-- Başlangıç satırı 2 ise ve KAÇINCI("ZZZ";$C:$C;1) sonucu 11 ise, 11'den 3 çıkartarak kaydırma satır sayısına ulaşılır.
.

ufukozcan2011 02-11-2017 02:34

Kusura bakmayın şimdi anladım .İlginiz için teşekkürler.

Ömer BARAN 02-11-2017 02:39

Daha iyi anlaşılması için aşağıdaki formülü herhangi bir hücreye uygulayın ve aşağı doğru 10 satır kopyalayın.
Formül ortalaması alınacak değerlerin listesini verir.

8 yerine 10 satır kopyalayın dememin sebebi, BOŞ sonuçları da görmeniz.
.
Kod:

=EĞER(KAÇINCI("ZZZ";$C:$C;1)-3<SATIR(A1);"";KAYDIR($B$2;SATIR(A1);0))
Bir de aşağıdaki formülü G3 hücresine uygulayın ve aşağı doğru 10 satır kopyalayın (aynı sonucu verecektir).
Kod:

=EĞERHATA(KAYDIR($B$2;;;KAÇINCI("ZZZ";$C:$C;1)-2);"")

ufukozcan2011 02-11-2017 02:52

peki ömer bey şöyle bir sorumdaha olucak;
=EĞERHATA(İNDİS(L3:L171;KAÇINCI(DOĞRU;L3:L171<>""; 0));"") bu formül ile bir sütundaki ilk değer buluyorum.Bu sütunda ilk değeri değilde 2nci değeri bularak yukardaki sizin verdiğiniz örneğe uyarlamak istiyorum. Bunun için nasıl formül uygulamalayım. Daha kısa yolu varmı?. Yani işlem aynı sadece veriler değişken olduğu için belli bir boşlukta olabiliyor.


Saat 23:41

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.