Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Fonksiyonlar (http://www.excel.web.tr/forumdisplay.php?f=47)
-   -   Çoklu Kriterlere Göre Metin Sayma (http://www.excel.web.tr/showthread.php?t=167668)

fledermaus 26-10-2017 15:38

Çoklu Kriterlere Göre Metin Sayma
 
1 Eklenti(ler)
Merhaba,

Ekte göndermiş olduğum tabloda kırmızı ile işaretli olan kriterlere göre H3 ve H4 hücrelerinde metin saymak istiyorum.

Sonuçları daha iyi alabilmek adına dinamik alan oluşturarak formülü düzenlendim ancak seçilmiş olan kriterlere göre sonucu alamıyorum.

Yardımlarınızı rica ederim.

Syg,

fledermaus 26-10-2017 16:38

Tekrar Merhaba,

Yardımcı olabilecek birileri var mı acaba ?

Syg,

parametre 26-10-2017 16:55

ilgilenirmisiniz çok orneklem mevcut

fledermaus 26-10-2017 17:34

Merhaba,

Denedim ancak nerede hata yaptığımı bulamıyorum.

Syg,

Korhan Ayhan 27-10-2017 00:39

Eklediğiniz dosyanın hangi sayfasında hangi işlemi yapmak istiyorsunuz?

fledermaus 27-10-2017 10:03

1 Eklenti(ler)
Korhan Bey Merhaba,

Kusura bakmayın yanlış dosya göndermişim. Doğrusu ekteki gibidir.

I3 Sonuç hücresi için;

B15,B19&B20 ve I2 deki kriterlere göre I25:I5000 arasında yazılmış olan metinleri saymak.

H3 Sonuç hücresi için;

B15,B19&B20 deki kriterlere göre I25:I5000 arasında yazılmış olan metinleri saymak.

Yardımlarınız için şimdiden teşekkür ederim.


Syg,

Ömer BARAN 27-10-2017 11:32

Merhaba.

Aşağıdaki şekilde dener misiniz?

-- I2 hücresi:
Öncelikle I2 hücresindeki Commercial kelimesini alttaki tablodaki haliyle (yani COMMERCIAL şeklinde) değiştirin.
Formülün son kısmında alanın adresi yerine AD TANIMLAMAda yeni bir isimle
(ficao => =I25:I868 şeklinde formül kullanarak) tanımlama yaparak da sonuç alınabilir.

-- H2 hücresi:
H2 hücresinde ise aynı formüldeki ;--(Flight_Type=$I$2) kısmını silerek sonuç alınabilir.
Sanırım istediğiniz bu.
.
Kod:

=YUVARLA(TOPLA.ÇARPIM(--(Date>=$B$19);--(Date<=$B$20);--(Flight_Type=$I$2);--(1/EĞERSAY(I25:I868;I25:I868&"")));0)
=YUVARLA(TOPLA.ÇARPIM(--(Date>=$B$19);--(Date<=$B$20);--(Flight_Type=$I$2);--(1/EĞERSAY(ficao;ficao&"")));0)


fledermaus 31-10-2017 08:59

1 Eklenti(ler)
Ömer Bey Merhaba,

Sanırm kouşullarda bir eksiklik var. Rica etsem tekrar bakarmısınız.

Dosya ektedir.


Syg,

fledermaus 31-10-2017 15:04

Ömer Bey Merhaba,

Bakabildiniz mi acaba?

Syg,

fledermaus 02-11-2017 08:00

Ömer Bey Tekrar Merhaba,

Tekrar bakabilme şansınız oldumu ? Tşk,

Syg,


Saat 16:28

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.