Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Fonksiyonlar (http://www.excel.web.tr/forumdisplay.php?f=47)
-   -   Tarihe göre Düşeyara hk. (http://www.excel.web.tr/showthread.php?t=122085)

talebeyim 27-11-2012 16:57

Tarihe göre Düşeyara hk.
 
1 Eklenti(ler)
Sayfa 1'deki tarih ne ise, Sayfa2'de O tarihin altında düşeyara yaparak veriyi getirmesi için yardımcı olabilirmisiniz ?

Örnek olması açısından bir dosya ekledim.

Ömer 27-11-2012 17:03

Merhaba,

Metin değerlerinin sırası tüm tarihlerde aynı sanırım. Farklı olacaksa formülü değiştirmek gerekir.
B3 hücresine yazıp alt satırlara kopyalayın.

Kod:

=KAYDIR(Sayfa2!$A2;;KAÇINCI($A$2;Sayfa2!$A$1:$R$1;0))
.

talebeyim 27-11-2012 17:39

ömer bey bu şekilde olmuyor maalesef, düşey ara bulamadığı değerlerede hata verdiği için bu hata kodlarını biz başka yerdede kullanıyoruz.
Kaydır yerine eğer ve düşeyarayı içiçe kullanarak birşey yapabilirmiyiz ?

talebeyim 28-11-2012 11:45

eğer ve düşeyara ile bu formulü kurabilirmiyiz ?

talebeyim 28-11-2012 15:46

günceldir.

İdris SERDAR 28-11-2012 17:46

1 Eklenti(ler)
Alıntı:

talebeyim tarafından gönderildi (Mesaj 665983)
Sayfa 1'deki tarih ne ise, Sayfa2'de O tarihin altında düşeyara yaparak veriyi getirmesi için yardımcı olabilirmisiniz ?

Örnek olması açısından bir dosya ekledim.

.

Ne yapmak istediğinizi anlayamadım. Bunu örneklendirirseniz, belki anlarım.

Kaldı ki; Ömer beyin verdiği formül neden olmuyor?

Buna göre yapılmış dosyanız ekte.


.

talebeyim 28-11-2012 19:02

Sayfa1 deki a , b , c yerine herhangi bir harf yazarsanızda sonuc 5 veriyor.

ikincisi yukardada belirtiğim gibi. d.ara bir değeri bulamadığında #YOK gibi bir mesaj veriyor.
işte bu verilen mesajıda biz başka yerde kullanıyoruz.

Bir örneklendirmede daha bulunuyum. Sayfa1deki tarih ne ise Onun hangi sutunda oldugunu sayfa2de bulsun ver. altında bulunan ürün kodlarına göre düşeyara yapsın...


Daha geniş açıklamam gerekirse, bir stok alıyor, stok kodu miktarı, biz bunu hergün yapıyoruz.
Sayfa1e öyle bir tarih girelimki. geçmiş hangi tarihi girersek o günki stoğu göstersin.

İdris SERDAR 28-11-2012 19:25

.

Bunu deneyin.

Kod:

=VLOOKUP(A3;Sayfa2!$A$1:$R$4;MATCH($A$2;Sayfa2!$A$1:$Q$1;0)+1;0)

=DÜŞEYARA(A3;Sayfa2!$A$1:$R$4;KAÇINCI($A$2;Sayfa2!$A$1:$Q$1;0)+1;0)

.

talebeyim 29-11-2012 08:50

Tam anlamıyla istediğim buydu, teşekkür ederim, yurtas bey..

ahmet-61 15-06-2013 16:52

tarihe göre düşey ara
 
1 Eklenti(ler)
=DÜŞEYARA(A3;Sayfa2!$A$1:$R$4;KAÇINCI($A$2;Sayfa2! $A$1:$Q$1;0)+1;0)

bu formulu kullandığımda neden gelmesi gereken rakamın sonuna 1 geliyor
atıyorum 5440 olması gerekirken 54401 oluyor.

ben de iki koşul için düşeyara yapmaya çalışıyorum ancak sanırım bi yerde hata yapıyorum.

not: ekli dosyada sayfa2 de ham veriler mevcut bu listeden alınacak verilerin tarihe göre ilgili sayfalarda ilgili yerlere yazılması gerekiyor. ya bi türlü yapamadım :(
yardım pls


Saat 20:27

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.