Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Uygulamalı Excel Eğitimi (http://www.excel.web.tr/forumdisplay.php?f=157)
-   -   Makrosuz Form Denetimli Personel Resmi Getirme (http://www.excel.web.tr/showthread.php?t=118949)

TASADAM366 25-08-2012 22:14

Makrosuz Form Denetimli Personel Resmi Getirme
 
Makrosuz Personel Resmi Getirme
Aslında tereciye tere satacağım.Bu konu anlatımında kullandığım formüller daha önce sitede yayınlanmıştı.Yurttaş adlı yönetici tarafından bir konu anltımında verilmişti.
Ona buradan teşekür ederim.Ayrıca Korhan Ayhan adlı yöneticiye de...
Bu konuda makro kullanmadan form denetim çubuğunu da kullanarak personel(öğrenci veya başka bir ürün(ben meyve isimleri kullandım.)...vs)hem resimlerini gösterip hem de bilgilerini
getirmeyi anlatacağım dilim döndününce..Hazırsanız başlayalım.
1.Önce excelde açtığımız sayfaları yeniden isimlendirelim.(TEMEL,FOTO,BİLGİ...gibi).Bu isimlere göre formüllerin değişeceğinizi unutmayınız.
2.Fotografları koyacağınız sayfaya(Ben de FOTO isimli sayfada) fotografların sahiplerinin isimlerini A2 hücresinden başlayarak yazınız.
http://i.imgur.com/fu3Jt.png
3.B2 hücresinden başlayarak bu fotografların isimlerinin sicil veya okul numaralarını yaz.
4.C2 hücresinden başlayarak her kişi için her C hücresine bir fotograf yerleştirin.Fotolar hücre sınırları içinde olsun.
5.Belirlediğiniz bir sayfada A3 den başlayıp A... kadar sıra numarası veriniz.
Yine bu sayfada B3 hücresinden başlayarak B... ye kadar aşağıdaki formülü giriniz.
=EĞER(FOTO!A2="";"";FOTO!A2)
Formülde FOTO! kodu fotografların bulunduğu sayfanın ismidir.
Bu formülde A2 kısmını B4 hücresinde A3, B5 hücresinde A4.... yapınız.Taki son personele kadar bunu
devam etiriniz.(Bilirsiniz fareyi hücrenin sağ alt köşesine götürü artı işaretini gösterdiğinde yukarıdan aşağ sürüklerseniz otomatik olarak hücrelere ardışık değer verir.)
http://i.imgur.com/U71wQ.png
Yine bu sayfada C3 hücresinden başlayarak C... hücresine kadar aşağıdaki formülü giriniz.
=EĞER(FOTO!B2="";"";FOTO!B2)
bu formülü tıpkı B sutunundaki hücrelere girdiğimiz gibi kaydırarak gerektiği kadar yazınız.
http://i.imgur.com/lf0W3.png
6.Şimdi TEMEL yazan sayfayı açalım.Üst şeritten geliştirici sekmesinde Tasarım Modunun solundaki Ekle açılır butonuna tıklayalım.
Ve oradan Form Denetimlerinden üstten 2. sıradaki Birleşik Form Denetimine Tıklayalım.
http://i.imgur.com/jFDv6.png
Ve sayfamızda uygun gördüğümüz bir yere enini boyunu ayarlayarak kutumuzu ekleyelim.
http://i.imgur.com/wrDzz.png
7.Şimdi bu kutumuza sağ tıklayıp Denetimi Biçimlendir seçeneğine tıklayalım.
http://i.imgur.com/UdK6t.png
Açılan pencerede Girdi Aralığı yazan satıra
FOTO!$A$2:$A$34

formülünü girelim.Yine bu pencerede Hücre bağlantısı yazan yere A1 yazalım.Ve Tamam butonuna tıklayalım.

http://i.imgur.com/f9oZb.png

Eğer doğru yaptıysanız kutucuktaki okla tıkladığınızda açılan listede meyve isimleri görünür.

http://i.imgur.com/VzeQ6.png

8.Şimdi kutucukla aynı satır numarasına sahip olan yandaki sutunda olan hücreye geçip şu formülü yazalım.
=DÜŞEYARA(TEMEL!A1;BİLGİ!A3:C49;3;YANLIŞ)

http://i.imgur.com/nZQSs.png

Bu formülde TEMEL!A1 form denetiminde seçilen meyveye göre satır numarasını kontrol ederek BİLGİ sayfasından
ilgili resmi getirmemizi sağlayacaktır.Eğer doğru yaptıysanız form denetiminde seçtiğiniz meyvenin
kodu bu formülü girdiğimiz hücrede görünecektir.
9.Şimdi form denetim çubuğunun hemen üstündeki hücreyi enine ve boyuna genişletelim.
Buraya resimlerimiz gelecek.Burası birazcık beklesin...
http://i.imgur.com/9XNIl.png
10.Şimdi Formüller sekmesine tıklayın.Ad Yöneticisini seçin.
http://i.imgur.com/zdgMY.png
A-) Yeni sekmesine tıklayınız.Ve Gelen pencerede Ad yazan satıra Adı
Başvuru Yeri yazan satıra ise aşağıdaki formülü giriniz.
=FOTO!$A$2:$A$34
Formülü doğru girdiyseniz bu pencerede meyve isimlerini görürsünüz.
http://i.imgur.com/JN0GQ.png

B-) Şimdi yine Yeni sekmesine tıklayalım ve Adı yazan satıra Resim yazalım.
Başvuru yazan yere ise:
=KAYDIR(FOTO!$C$2;KAÇINCI(TEMEL!$D$3;ResimListesi; 0)-1;0;1;1)

Bu formülde FOTO!$C$2 kısmı foto sayfasında hangi sütün ve hangi satırdan kısaca hücreden başlanarak resmi koyacağını belirler.
TEMEL!$D$3 kısmı ise bu resimleri neye göre yani hangi meyve ismine göre göstereceğini belirler.Temel D3 hücresi
Temel sayfasındaki A1 hücresine bağlı olarak değişir.Bu A1 hücresi de form denetiminde seçtiğiniz meyvenin bulunduğu satıra otomatik bir numara verir göre
Böylece bağlantımızı kurduk.
Form Çubuğu, A1 hücresine meyvenin sıra numarasına göre bir sıra numarası atar.Bu atama meyvelerin blunduğu satıra göre değil.
seçili meyvenin diğer meyveler göre durumuna göredir.
A1 hücresi D3 hücresinin değerini belirler.
D3 hücresi de gelecek olan resmi belirler.İsterseniz bu D3 hücresini referans gösterek yeni açacağınız sayfadaki bilgileri,
TEMEL isimli sayfanızda görebilirsiniz.
http://i.imgur.com/fcRGw.png
C-) Şimdi Ad Yönetici penceresinde yine yeni sekmesine tıklayalım.
Gelen pencerede Adı kısmına ResimListesi yazalım.
Başvuru Yeri kısmına ise
=KAYDIR(FOTO!$B$1;1;0;BAĞ_DEĞ_DOLU_SAY(FOTO!$A:$A)-1;1)
formülünü girelim.
http://i.imgur.com/QuVd4.png
3 formülümüzü de girdik.Ad yöneticimizde son durum aşağıdaki resimdeki gibi olmalıdır.
http://i.imgur.com/4uEvk.png
11. Şimdi form denetimi çubuğunun hemen üstündeki hücreyi genişletmiştik hatırlarsanız.
Şimdi o hücre seçiliyken Geliştirici sekmesini seçip ekle butonuna basalım aşağı açılan listeden
Activex denetimleri kısmından en altta soldan 4.sırada yer alan Resim (Active Denetimi) yazan resim denetim modunu seçelim.
http://i.imgur.com/B6BKZ.png
Ve hücre içinde resminizin boyutuna (en x boy piksel olarak) bağlı olarak bir image nesnesi dikdörtgeni çizelim.
http://i.imgur.com/mT4Ws.png
12.Çizdiğimiz bu image nesnesi üzerine resim ekleyeceğiz.Bunun için excel sayfasının en üstündeki Ekle penceresini açıp
Resim(Dosyadan resim ekle) deyip küçük bir resim(image nesnesinin alanına sığacak kadar.Taşırmadan) ekleyelim.
http://i.imgur.com/i80tJ.png

13.Şimdi bu eklediğimiz resme bir tıklayıp seçili hale getirelim.Ve formül sekmesine
=Resim
yazalım.Formül sekmesinin solundaki satırda Resim 1 yazdığından emin olunuz.Yoksa hata verir.
http://i.imgur.com/lktXC.png
Eğer doğru yaptıysanız form denetimi çubuğundan bir meyve ismi seçtiğinizde otomatik olarak o meyvenin resmi de görünecektir.
http://i.imgur.com/59XkG.png
İmage nesenesinin boyutu Foto sayfasında resimlerin olduğu hücrenin eni ve boyu kadar olur.Resmin boyutu da yine Foto sayfasında
eklediğiniz resmin boyutu kadar olur.Bu nedenle resimlerin olduğu hücreleri ve içindeki resimleri uygun biçimde ayarlamalısınız.
Diyelimki meyve koduna göre de form denetimi yapmak istiyorsunuz.
14.O zaman yine form denetim çubuğu oluşturalım.Enini boyunu ayarlayalım.
15.Bu ikinci form çubuğuna sağ tıklayalım ve Denetimi Biçimlendir yazısına tklayalım.(6. ve 7.aşamayı aynen tekrarlayınız)
Gelen pencerede Girdi Aralığı satırına bu sefer,
FOTO!$B$2:$B$34
formülünü giriyoruz.Hücr Bağlantısı kısmına yine A1 yazıyoruz.Böylece meyve kodu değiştikçe hem resim ve hem de
meyvenin adı değişecektir.Ve A1 hücresine bağlanmış tüm bilgiler...
Dikkat ederseniz Foto sayfasında B sutununda meyve kodları vardır.
İsterseniz A1 hücresinin yazı rengini beyaz yapıp gizleyebilirsiniz.Hatta meyve kodlarını gösteren hücrenin de yazı rengini beyaz yapıp gizleyebilirsiniz.
Saygılarımla....

Anlatımda Kullanılan Dosyalar(esimler ve örnek excel dosyası)

http://www.mediafire.com/?ki6asip43qkyc7m

586kb lık bir arşiv dosyasıdır

Mahir ÇÜMEN 26-08-2012 01:45

Merhaba,

Faydalı bir paylaşım, elinize sağlık.

Ayşavkı 29-08-2012 12:07

katkılarından dolayı adı geçen uzmanlarımıza ve paylaşımınız için size teşekkür ederim.

halil.tefci 30-10-2013 16:58

hocam bu sizin formüllemelere göre bi excel çalışması yaptım ama baskı önizlemede resimler kayık çıkıyor ayarlamasını bi türlü yapamadım yardımcı olabilirsen sevinirim çalışmam şu konuda altında inceleyebilirsiniz http://www.excel.web.tr/f48/formulle...tml#post728808

HASAN48 29-08-2014 12:14

Teşekkürler faydalı bir anlatım olmuş.

baydeniro 24-09-2014 12:51

TASADAM366 paylaşım için teşekkürler.

akrep8 26-09-2014 10:49

Ellerine sağlık.

pesimistik 13-03-2015 16:43

çok teşükkerler, elinize sağlık. yine faydalı ve son derece kullanışlı bir paylaşım daha.

M_K_o 21-04-2015 17:24

merhaba
 
Ben a sayfasinda bir degisken ism listem var ve b sayfasindada. Resimli.Isim lstem dusey arada oldugu gibi ordaki kisinin resmini diger a sayfasindaki taraftaki yerine kouymasini nasil yapabilirim


Saat 07:12

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.