Excel Forum

Excel Forum (http://www.excel.web.tr/index.php)
-   Fonksiyonlar (http://www.excel.web.tr/forumdisplay.php?f=47)
-   -   Filtrelenmiş Sütundaki Tekrarlayan Sayıları Sayma (http://www.excel.web.tr/showthread.php?t=161914)

ilhanaraz 09-02-2017 18:19

Filtrelenmiş Sütundaki Tekrarlayan Sayıları Sayma
 
Merhaba arkadaşlar.
Benim problemim şöyle: A sütununda 1 den 9'a kadar karışık tekrarlayan rakamlar, B sütununda ise 10-15-20 olarak karışık tekrarlayan 3 sayı var böyle yaklaşık 20000 satır var. C1 hücresine öyle bir formül yazmam lazım ki filtre uygulayarak A sütununda 1'i veya başka rakamı filtrelediğimde karşılığında B sütunundaki 10'dan kaç adet olduğunu yazsın.
= ALTTOPLAM olarak yazıyorum filtreyi görüyor fakat 10'ları saydıramıyorum.
=EĞERSAY olarak yazıyorum 10'ları sayıyor filtreyi görmüyor bütün sütunu sayıyor.

bzace 09-02-2017 18:55

Merhaba,
Deneyiniz.
Kod:

=TOPLA.ÇARPIM(ALTTOPLAM(103;KAYDIR(A1;SATIR(1:2000);))*(B1:B2000=10))
Saygılar,
Şeşen

ilhanaraz 10-02-2017 07:38

Cevap için teşekkürler. Fakat ben pratik bir formül olacağını düşündüğümden sütun ve hücreleri öylesine yazmıştım. Gerçekte H14 hücresinden aşağı 10 15 20 ler var. Listemde A - AL sütunları arasında veriler var. herhangi bir sütunda filreleme yaptığımda H sütunundaki 10 ları saysın. Sizin gönderdiğiniz formülü H ye göre uyguladım fakat çok farklı sayılar veriyor.

Ömer BARAN 10-02-2017 10:18

Alıntı:

ilhanaraz tarafından gönderildi (Mesaj 881276)
Cevap için teşekkürler. Fakat ben pratik bir formül olacağını düşündüğümden sütun ve hücreleri öylesine yazmıştım. Gerçekte H14 hücresinden aşağı 10 15 20 ler var. Listemde A - AL sütunları arasında veriler var. herhangi bir sütunda filreleme yaptığımda H sütunundaki 10 ları saysın. Sizin gönderdiğiniz formülü H ye göre uyguladım fakat çok farklı sayılar veriyor.

İşte tam da bu nedenle; soruların, gerçek belgeyle aynı yapıda örnek belge üzerinden sorulmasını isteniliyor.
Örnek belge özellikleri ve örnek belge yükleme yöntemine ilişkin açıklamalar, cevabımın altındaki İMZA bölümünde var.
.

ilhanaraz 12-02-2017 13:22

Örnek bir dosya yaptım. Buyrun. http://s3.dosya.tc/server10/1wn94e/F...ilar.xlsx.html

Korhan Ayhan 12-02-2017 15:10

H3 hücresine aşağıdaki formülü uygulayıp deneyiniz.

Kod:

=TOPLA.ÇARPIM(ALTTOPLAM(103;KAYDIR($A$14;SATIR($14:$20000)-14;))*($B$14:$H$20000=D3))

ilhanaraz 13-02-2017 09:13

Çok teşekkür ederim. Formül doğru. Sadece sonundaki ($H$14:$H$20000=D3)) olacakmış B olunca B-H arasındaki 10'ları sayıyor. Bu şekilde değiştirince doğru veriler geliyor. Çok teşekkür ederim. =TOPLA.ÇARPIM(ALTTOPLAM(103;KAYDIR($A$14;SATIR($14 :$20000)-14;))*($H$14:$H$20000=D3))


Saat 07:54

Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.