Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Diğer Excel Soruları
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Diğer Excel Soruları Yukarıdaki başlıklara uymayan Excel sorularınızı bu bölüme gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 13-12-2017, 13:23   #1
martax410
 
Giriş: 05/05/2007
Mesaj: 39
Excel Vers. ve Dili:
2003
Varsayılan karışık olan verileri eşleştirmek

http://www.dosya.tc/server10/j0jazh/Kitap1.xlsx.html
martax410 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 13-12-2017, 13:31   #2
çıtır
Altın Üye
 
Giriş: 06/03/2005
Şehir: KDZ.EREĞLİ
Mesaj: 1,194
Excel Vers. ve Dili:
Excel Vers. ve Dili: Office 2016 TR 64 Bit
Varsayılan

Aşağıdaki formülü Sayfa2 B3 kopyalayarak D3 e kadar sağa ve yeterinçe aşağı çekerek çoğaltınız.Kolay gelsin.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞERHATA(DÜŞEYARA($A3;Sayfa1!$A$2:$D$2000;SÜTUN(B$1);0);"")
veya excel versiyonunuza göre
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(EHATALIYSA(DÜŞEYARA($A3;Sayfa1!$A$2:$D$2000;SÜTUN(B$1);0));"";DÜŞEYARA($A3;Sayfa1!$A$2:$D$2000;SÜTUN(B$1);0))

Bu mesaj en son " 13-12-2017 " tarihinde saat 13:40 itibariyle çıtır tarafından düzenlenmiştir....
çıtır Çevrimiçi   Alıntı Yaparak Cevapla
Eski 13-12-2017, 22:50   #3
TanerSaydam
 
Giriş: 13/10/2017
Şehir: Kayseri
Mesaj: 155
Excel Vers. ve Dili:
2003-tr
Varsayılan

Çalışma kitabını makroyla uyumlu şekilde kaydet (97-2003 çalışma kitabı ya da makrolu çalışma kitabı). Sonrasında sayfa 2 deyken Alt+F11 yap ve aşağıdaki kodu yapıştır. Başka bir şey yapmana gerek yok. Eğer tablon tam olarak bu şekildeyse, her satır eklediğinde ya da değiştirdiğinde otomatik arama yapıp eşleşen satırları C-D'ye aktaracak

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
Private Sub WorkSheet_Change(ByVal Target As Range)
Dim ilk As Integer, son As Integer
Dim S1_ilk As Integer, S1_son As Integer
Dim v As Integer, yer As Integer
On Error Resume Next
ilk = 3
son = Sayfa2.Range("A" & Rows.Count).End(xlUp).Row
S1_ilk = 3
S1_son = Sayfa1.Range("A" & Rows.Count).End(xlUp).Row

yer = ilk
For v = ilk To son
If Not Sayfa2.Range("C" & yer) = "" Then GoTo vatla
Sayfa2.Range("C" & yer).Value = Application.WorksheetFunction.VLookup(Sayfa2.Range("A" & yer).Value, Sayfa1.Range("A:D"), 3, 0)
Sayfa2.Range("D" & yer).Value = Application.WorksheetFunction.VLookup(Sayfa2.Range("A" & yer).Value, Sayfa1.Range("A:D"), 4, 0)
vatla:
yer = yer + 1
Next v
End Sub
TanerSaydam Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 05:54


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Çorlu Dil Konuşma Terapisti- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Çorlu- Çorlu Araç Takip- Çorlu Su Arıtma- Gebze Emlak- Rampa- Rotary- Çorlu İnternet Sitesi- Çorlu Sürücü Kursu- Çorlu Sürücü Kursu- Şişli Avukat- Edirne Serbest Muhasebeci- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta- Kağıt Bardak- Kaplan Tekstil- Çorlu Perde- Çorlu Havuz- Makina- Danışmazlar-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden