Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Diğer Excel Soruları
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Diğer Excel Soruları Yukarıdaki başlıklara uymayan Excel sorularınızı bu bölüme gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 16-05-2017, 16:45   #1
interstellar
Altın Üye
 
Giriş: 27/10/2016
Mesaj: 27
Excel Vers. ve Dili:
excel 2010 Türkçe
Question Hücre içi işlem

Merhabalar,

Bir hücre içinde yazılar ve sayılar var. Ben 6 haneli olan sayıyı almak istiyorum.

Bunu yapacak formül nedir ? (Makro istemiyorum)


Bu mesaj en son " 16-05-2017 " tarihinde saat 21:52 itibariyle interstellar tarafından düzenlenmiştir....
interstellar Çevrimdışı   Alıntı Yaparak Cevapla
Eski 16-05-2017, 21:51   #2
interstellar
Altın Üye
 
Giriş: 27/10/2016
Mesaj: 27
Excel Vers. ve Dili:
excel 2010 Türkçe
Varsayılan

Tekrardan merhaba ,

Hücre içinden 6 basamaklı olan sayıları nasıl alabileceğimize dair herhangi bir formül biliyormusunuz
interstellar Çevrimdışı   Alıntı Yaparak Cevapla
Eski 16-05-2017, 22:20   #3
çıtır
 
Giriş: 06/03/2005
Şehir: kdz.ereðli
Mesaj: 274
Varsayılan

A1 Hücresi esas alınmış, B1 kopyalayınız, aşağı çekin A1,A2....A10 değerler yazın.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(VE(ESAYIYSA(A1);UZUNLUK(A1)=6);A1;"")
çıtır Çevrimdışı   Alıntı Yaparak Cevapla
Eski 16-05-2017, 22:40   #4
interstellar
Altın Üye
 
Giriş: 27/10/2016
Mesaj: 27
Excel Vers. ve Dili:
excel 2010 Türkçe
Varsayılan

hücre sadece sayılardan oluşmuyor sayı ve metin karışık örnek olarak

abcdefgh 123456 asdfghjklşi 123456789123456787

1234 afhdfgjkfgh :456123 hjkhkj

ben 123456 ve 456123 şeklinde 6 basamak almak istiyorum

Bu mesaj en son " 16-05-2017 " tarihinde saat 22:45 itibariyle interstellar tarafından düzenlenmiştir....
interstellar Çevrimdışı   Alıntı Yaparak Cevapla
Eski 16-05-2017, 22:48   #5
çıtır
 
Giriş: 06/03/2005
Şehir: kdz.ereðli
Mesaj: 274
Varsayılan

Daha kısası olabilir mi? bilmiyorum.Biraz uzun oldu.
B1 Kopyala Dizi formülü Ctrl+shift+ enter le çıkınız


Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(UZUNLUK(A1)-UZUNLUK(YERİNEKOY(YERİNEKOY(YERİNEKOY(YERİNEKOY(YERİNEKOY(YERİNEKOY(YERİNEKOY(YERİNEKOY(YERİNEKOY(YERİNEKOY(A1;"1";"");"2";"");"3";"");"4";"");"5";"");"6";"");"7";"");"8";"");"9";"");"0";""))=6;TOPLA(PARÇAAL(A1;BÜYÜK(ESAYIYSA(--PARÇAAL(A1;SATIR($1:$25);1))*SATIR($1:$25);SATIR($A$1:İNDİS($A:$A;BAĞ_DEĞ_SAY(--PARÇAAL(A1;SATIR($1:$25);1)))));1)*10^(SATIR(İNDİS($1:$25;BAĞ_DEĞ_SAY(--PARÇAAL(A1;SATIR(İNDİS($1:$25;1;1):İNDİS($1:$25;UZUNLUK(A21);1));1));1):İNDİS($1:$25;1;1))-1));"")
çıtır Çevrimdışı   Alıntı Yaparak Cevapla
Eski 16-05-2017, 23:48   #6
interstellar
Altın Üye
 
Giriş: 27/10/2016
Mesaj: 27
Excel Vers. ve Dili:
excel 2010 Türkçe
Varsayılan

formül çalışmadı
interstellar Çevrimdışı   Alıntı Yaparak Cevapla
Eski 17-05-2017, 08:43   #7
bzace
 
bzace kullanıcısının avatarı
 
Giriş: 23/09/2013
Şehir: İstanbul
Mesaj: 1,322
Excel Vers. ve Dili:
Excel 2007 İngilizce - Excel 2010 Türkçe - Excel 2013 Türkçe -
Varsayılan

Merhabalar,
Deneyiniz.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=METNEÇEVİR(-ARA(;-PARÇAAL(" "&A1;MBUL(" ?????? ";
  YERİNEKOY(" "&A1&" ";"";"  ");SATIR($1:$38));7));"000000")
Not: Hücre uzunluğunuz 38 karakterden fazla ise 38 sayısını çoğaltınız.
Saygılar,
Leperuj
__________________
BEDAVA PEYNİR sadece FARE KAPANINDA var!

Bu mesaj en son " 17-05-2017 " tarihinde saat 10:19 itibariyle bzace tarafından düzenlenmiştir....
bzace Çevrimdışı   Alıntı Yaparak Cevapla
Eski 17-05-2017, 08:48   #8
YUSUF44
Destek Ekibi
 
YUSUF44 kullanıcısının avatarı
 
Giriş: 04/01/2006
Şehir: Manisa, Kula
Mesaj: 5,771
Excel Vers. ve Dili:
İş : Ofis 2016 - Türkçe Ev: Yok maalesef.
Varsayılan

Sayın bzace, son verdiğiniz formül 6 basamaktan uzun sayıların da 6 basamağını alıyor. Arkadaşın sorusundan anladığım hücredeki 6 basamaklı sayıyı almak şeklinde, verdiği örnekler de bu yönde.
__________________
Sorularınızı örnek dosyayla desteklemeniz çözüme ulaşmanızı kolaylaştırır.

Altın Üye olmanızı öneririm. Altın Üye değilseniz dosyanızı dosya yükleme sitelerinden birine yükleyip linkini paylaşabilirsiniz.
YUSUF44 Çevrimiçi   Alıntı Yaparak Cevapla
Eski 17-05-2017, 10:20   #9
bzace
 
bzace kullanıcısının avatarı
 
Giriş: 23/09/2013
Şehir: İstanbul
Mesaj: 1,322
Excel Vers. ve Dili:
Excel 2007 İngilizce - Excel 2010 Türkçe - Excel 2013 Türkçe -
Varsayılan

Yusuf Bey,
Uyarınız için teşekkürler.
Gerekli düzeltme yapıldı.
" ?????? " kısmına sonradan bir karakter boşluk (" ") eklendi.
__________________
BEDAVA PEYNİR sadece FARE KAPANINDA var!
bzace Çevrimdışı   Alıntı Yaparak Cevapla
Eski 17-05-2017, 10:23   #10
YUSUF44
Destek Ekibi
 
YUSUF44 kullanıcısının avatarı
 
Giriş: 04/01/2006
Şehir: Manisa, Kula
Mesaj: 5,771
Excel Vers. ve Dili:
İş : Ofis 2016 - Türkçe Ev: Yok maalesef.
Varsayılan

Dizi formülü olduğunu da belirtirseniz iyi olur.
__________________
Sorularınızı örnek dosyayla desteklemeniz çözüme ulaşmanızı kolaylaştırır.

Altın Üye olmanızı öneririm. Altın Üye değilseniz dosyanızı dosya yükleme sitelerinden birine yükleyip linkini paylaşabilirsiniz.
YUSUF44 Çevrimiçi   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 11:11


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Hurda - Torna - Çorlu Web Tasarım - Tarot Falı - Fenerbahçe Haberleri - Trakya Haberleri - Investing - Hurda - Tekirdağ Samsung - Kozmetik Ürünler - Sağlıklı Makyaj Ürünleri - Yaşlanma Karşıtı Ürünler - Excel Eğitimi - Çorlu osgb - Lingerie - Dyeing Machine - Çorlu Temizlik- Çorlu Ambar- Hava Çekimi- Hazır Site- SEO- Çorlu Burun Estetiği- Çorlu Pimapen- Karton Bardak- Marka Tescil Danışmanlık- Marmara Ereğlisi Restaurant- Çorlu Baskı- Çorlu Sigorta- Çorlu Pimapenci- İstanbul Avukat-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden