Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Diğer Excel Soruları
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Diğer Excel Soruları Yukarıdaki başlıklara uymayan Excel sorularınızı bu bölüme gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 18-12-2017, 22:35   #1
remo7
 
Giriş: 09/07/2012
Mesaj: 5
Excel Vers. ve Dili:
2007 türkçe
Varsayılan Excel de kosullu satir icinde hucre kopyalama yardim istegi

Merhabalar,
Zor bir sorum var beyler.

ekteki dosyada webden al ile doviz kurlari verileri geliyor, 2. sayfada. bu normal calisiyor.

ayrica 1. ve 3. sayfada da web den makro ile veriler geliyor.

simdi sorun su:
web sayfasinda makro ile verilerin geldigi satirlar yer degistirebiliyor.
(1 ve 3. sayfada)

benim istedigim ise veriler yer degistirse bile ilk ve ucuncu sayfada almak istedigim veriyi arayip bulsun ve 2. sayfada ki belirli hucreye kopyalasin.

bu mumkun mu?

mesela 1. sayfadan kraken (a15) i bulsun, sonra ayni satirdaki 5. sutundaki veriyi (E15) ikinci sayfada C16 ya kopyalasin.
ayni islemi BITFINEX,BITSTAMP,CEXIO,POLONIEX,BITTREX,BINANCE,B TCTURK,PARIBU,KOINEKS,KOINIM
icinde yapmali.

sadece USD degerleri olan satirlari bulup 5. kolondaki ayni satirdaki veriyi getirip 2. sayfadaki yerine kopyalacak. yani kraken a15 i bulacak ama b15 de USD degerini teyit etmeli. usd ise E15 i kopyalayip 2. sayfadaki yerine yazmali.

ayrica bunu 3. sayfada da yapip, 2. sayfadaki C29 ile ..... C36 arasindaki hucrelere de yapmali.

bu internet sitesinden gelen verilerin satirlarinin yer degistirmesinin sebebi guncel volume gore siralanmasindan dolayi.


Zor is gibi, yardimci olabileceklere simdiden cok cok tesekkurler.

http://s3.dosya.tc/server13/u0m0yq/a....xlsx.zip.html
remo7 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 19-12-2017, 11:04   #2
Ahmet ÖZGÜR
Altın Üye
 
Ahmet ÖZGÜR kullanıcısının avatarı
 
Giriş: 08/06/2010
Şehir: İstanbul
Mesaj: 278
Excel Vers. ve Dili:
Office 2003 TR Office 2007
Varsayılan

Merhaba,

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=DÜŞEYARA(B16;Sheet1!$A$2:$F$38;5;2)/100
Sheet2 C16 hücresine uygulayıp C26 hücrsine kadar aşağı doğru sürükleyiniz.
__________________
"Korkaklıkta ar, İlerlemekte şeref var." (Ebu Dücane R.A.)
Ahmet ÖZGÜR Çevrimdışı   Alıntı Yaparak Cevapla
Eski 19-12-2017, 13:07   #3
remo7
 
Giriş: 09/07/2012
Mesaj: 5
Excel Vers. ve Dili:
2007 türkçe
Varsayılan

Alıntı:
Ahmet ÖZGÜR tarafından gönderildi Mesajı Görüntüle
Merhaba,

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=DÜŞEYARA(B16;Sheet1!$A$2:$F$38;5;2)/100
Sheet2 C16 hücresine uygulayıp C26 hücrsine kadar aşağı doğru sürükleyiniz.
asagidaki hatayi verdi

remo7 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 19-12-2017, 13:20   #4
Ahmet ÖZGÜR
Altın Üye
 
Ahmet ÖZGÜR kullanıcısının avatarı
 
Giriş: 08/06/2010
Şehir: İstanbul
Mesaj: 278
Excel Vers. ve Dili:
Office 2003 TR Office 2007
Varsayılan

Bende bir hata vermiyor.

Şuradan indirip denermisiniz: http://s8.dosya.tc/server5/0oa4dy/dene66.rar.html
__________________
"Korkaklıkta ar, İlerlemekte şeref var." (Ebu Dücane R.A.)
Ahmet ÖZGÜR Çevrimdışı   Alıntı Yaparak Cevapla
Eski 19-12-2017, 13:37   #5
remo7
 
Giriş: 09/07/2012
Mesaj: 5
Excel Vers. ve Dili:
2007 türkçe
Varsayılan

Alıntı:
Ahmet ÖZGÜR tarafından gönderildi Mesajı Görüntüle
Bende bir hata vermiyor.

Şuradan indirip denermisiniz: http://s8.dosya.tc/server5/0oa4dy/dene66.rar.html
calisti tesekkurler
sorun herhalde kullandigim ingilizce excel den kaynaklandi,

indirdigim excel de komut su sekilde
Alıntı:
=VLOOKUP(B16,Sheet1!$A$2:$F$38,5,2)/100
fakat yine de bir sorun var,
kraken i ilk sayfada buluyor sanirim ama CAD (kanada dolari) cinsinden olan satirdaki krakeni kopyaliyor. Kraken USD satirindaki E16 yi kopyalayip almasi gerek

Komutun icerigini yani
Alıntı:
$A$2:$F$38,5,2
burayi anlatirsaniz sanirim cozebilirim.

Ilgilendiginiz icin cok cok tesekkurler.
remo7 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 19-12-2017, 14:09   #6
remo7
 
Giriş: 09/07/2012
Mesaj: 5
Excel Vers. ve Dili:
2007 türkçe
Varsayılan

asagidaki resimdeki gibi yapmaya calistim.

[IMG][/IMG]

a16 ya kraken ekledim
a17 ye usd yi
yani Kraken 1. sutun ile usd 2. sutunu aranan degeri bulsun
sonra tablo dizisini sheet1 ABCD yi sectim
sonra sutun indeks de E sutununu sectim
son olarak da 0 verdim

formul bu
Alıntı:
=VLOOKUP(Sheet1!A16:B16,Sheet1!A:E,Sheet1!E:E,0)/100
remo7 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 20-12-2017, 01:03   #7
remo7
 
Giriş: 09/07/2012
Mesaj: 5
Excel Vers. ve Dili:
2007 türkçe
Varsayılan

cozdum beyler,
aramada ilk cikanlari otomatik silerek cozdum
remo7 Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 13:59


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Çorlu Dil Konuşma Terapisti- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Çorlu- Çorlu Araç Takip- Çorlu Su Arıtma- Gebze Emlak- Rampa- Rotary- Çorlu İnternet Sitesi- Çorlu Sürücü Kursu- Çorlu Sürücü Kursu- Şişli Avukat- Edirne Serbest Muhasebeci- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta- Kağıt Bardak- Kaplan Tekstil- Çorlu Perde- Çorlu Havuz- Makina- Danışmazlar-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden