Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Diğer Excel Soruları
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Diğer Excel Soruları Yukarıdaki başlıklara uymayan Excel sorularınızı bu bölüme gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 14-12-2017, 08:47   #1
levo26
 
levo26 kullanıcısının avatarı
 
Giriş: 22/04/2010
Şehir: Eskişehir
Mesaj: 524
Excel Vers. ve Dili:
Excel 2007 TR
Varsayılan ANAHESAP yazan hücrenin üstündeki veri

Merhaba;
Ekte örneğini vermiş olduğum dosyada B sütununda ANA HESAP yazan yerler var. Burada ANA HESAP yazan hücrenin üstündeki hücrenin ilk 3 rakamını alacak ANA HESAP yazan hücrenin soluna yazacak. Bunu kod veya formül ile yapabiliriyim? Teşekkürler.

http://s3.dosya.tc/server13/bq9sng/ANA_HESAP.xlsx.html
levo26 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 14-12-2017, 10:20   #2
çıtır
Altın Üye
 
Giriş: 06/03/2005
Şehir: KDZ.EREĞLİ
Mesaj: 1,724
Excel Vers. ve Dili:
Excel Vers. ve Dili: Office 2016 TR 64 Bit
Varsayılan

A3 hücresine kopyalayıp aşağı çekerek çoğaltınız.Kolay gelsin.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞERHATA(EĞER($B3="ANA HESAP";SOLDAN($B2;3);"")+0;"")

Bu mesaj en son " 14-12-2017 " tarihinde saat 10:33 itibariyle çıtır tarafından düzenlenmiştir....
çıtır Çevrimdışı   Alıntı Yaparak Cevapla
Eski 14-12-2017, 11:35   #3
levo26
 
levo26 kullanıcısının avatarı
 
Giriş: 22/04/2010
Şehir: Eskişehir
Mesaj: 524
Excel Vers. ve Dili:
Excel 2007 TR
Varsayılan

Alıntı:
çıtır tarafından gönderildi Mesajı Görüntüle
A3 hücresine kopyalayıp aşağı çekerek çoğaltınız.Kolay gelsin.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞERHATA(EĞER($B3="ANA HESAP";SOLDAN($B2;3);"")+0;"")
Teşekkürler Sayın Çıtır. Tam istediğim gibi... Sağolun.
levo26 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 14-12-2017, 14:49   #4
çıtır
Altın Üye
 
Giriş: 06/03/2005
Şehir: KDZ.EREĞLİ
Mesaj: 1,724
Excel Vers. ve Dili:
Excel Vers. ve Dili: Office 2016 TR 64 Bit
Varsayılan

Alıntı:
levo26 tarafından gönderildi Mesajı Görüntüle
Teşekkürler Sayın Çıtır. Tam istediğim gibi... Sağolun.
Rica ederim .Dönüş yaptığınız için teşekkür ederim.Sayfanın kod bölümüne kopyalarsanız aşağıdaki kodda işinizi görür.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
Private Sub Worksheet_Change(ByVal Target As Range)
If Intersect(Target, [B1:B10000]) Is Nothing Then Exit Sub
On Error GoTo çıkış
If Target.Value = "ANA HESAP" Then
Target.Offset(0, -1) = Left(Target.Offset(-1, 0), 3)
Target.Offset(0, -1).Font.Name = "Comic Sans MS"
Target.Offset(0, -1).Font.Size = 10
Target.Offset(0, -1).Font.Bold = True
Target.Offset(0, -1).Font.Italic = True
Target.Offset(0, -1).HorizontalAlignment = xlCenter
Target.Offset(0, -1).VerticalAlignment = xlCenter
Target.Offset(0, -1).Font.ColorIndex = 55
Target.Offset(0, -1).Interior.ColorIndex = 6
Target.Offset(0, -1).Borders(xlEdgeLeft).Weight = xlMedium
Target.Offset(0, -1).Borders(xlEdgeTop).Weight = xlMedium
Target.Offset(0, -1).Borders(xlEdgeBottom).Weight = xlMedium
Target.Offset(0, -1).Borders(xlEdgeRight).Weight = xlMedium
Else
Target.Offset(0, -1) = ""
Target.Offset(0, -1).Interior.ColorIndex = xlNone
Target.Offset(0, -1).Borders(xlEdgeLeft).LineStyle = xlNone
Target.Offset(0, -1).Borders(xlEdgeTop).LineStyle = xlNone
Target.Offset(0, -1).Borders(xlEdgeBottom).LineStyle = xlNone
Target.Offset(0, -1).Borders(xlEdgeRight).LineStyle = xlNone
End If
çıkış:
End Sub
çıtır Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 19:14


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Karton Bardak- Çorlu Dil Konuşma Terapisti- Çorlu Dil Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Çorlu- Çorlu Araç Takip- Rampa- Çorlu İnternet Sitesi- Çorlu Sürücü Kursu- Şişli Avukat- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta- Kağıt Bardak- Kağıt Bardak- Çorlu Havuz- Çorlu Havuz- Çorlu Perde Yıkama- Okul Danışmanlık- ADR'li taşıma kabı imalatı- Mekanik Tesisat- Çorlu Grafik Tasarım- Çorlu Sondaj- Çorlu Etüt- Futbol Cafe- Beylikdüzü Temizlik- Çorlu Kurs- Çorlu Ders- İzmit Mimar- Hurda Bakır Kablo- Hurda Bakır Kablo- Çorlu Pronet- Çorlu Yönetim- Çorlu Apartman Yönetimi- Çorlu Marangoz- Çorlu Avukat-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden