Excel Forum


Geri Git   Excel Forum > EXCEL-Soruları > Diğer Excel Soruları
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ

Diğer Excel Soruları Yukarıdaki başlıklara uymayan Excel sorularınızı bu bölüme gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama



Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 07-04-2010, 19:23   #1
kemerkayalı
 
Giriş: 28/11/2006
Şehir: istanbul
Mesaj: 56
Excel Vers. ve Dili:
excell 2010 türkçe
Arrow 3-4 kriterde etopla formülünü uygulama

Arkadaşlar, Etopla formülünde çizelgemde dönem ve ürün seçenekleri ve tutar haneleri var. Toplam aldırırken döneme , ürüne göre pozitif miktarları ayrı yere, negatif miktarları ayrı yere toplatmam gerek, bunu kodla yapmışlardı ama ben fonksiyonla anlamak ve yapabilmek istiyorum şimdiden teşekkürler.örnek ektedir
Eklenmiş Dosyalar
Dosya Türü: rar Kriterli_toplamda_negatif_pozitif_ayrımlı_toplam.rar (7.2 KB, 53 Görüntülenme)
kemerkayalı Çevrimdışı   Alıntı Yaparak Cevapla
Eski 07-04-2010, 19:33   #2
İdris SERDAR
Moderatör
 
İdris SERDAR kullanıcısının avatarı
 
Giriş: 21/10/2005
Mesaj: 12,667
Excel Vers. ve Dili:
Excel, 2013 - İngilizce
Varsayılan

Alıntı:
kemerkayalı tarafından gönderildi Mesajı Görüntüle
Arkadaşlar, Etopla formülünde çizelgemde dönem ve ürün seçenekleri ve tutar haneleri var. Toplam aldırırken döneme , ürüne göre pozitif miktarları ayrı yere, negatif miktarları ayrı yere toplatmam gerek, bunu kodla yapmışlardı ama ben fonksiyonla anlamak ve yapabilmek istiyorum şimdiden teşekkürler.örnek ektedir
.

Buradaki örnekleri inceleyin.



Toplama Ve Sayma

Sumproduct-Topla.Çarpım Fonksiyonu ve Uygulamaları


.
__________________
Çalışmalarımı görmek için:

http://www.excelgurusu.com/

İdris SERDAR
İdris SERDAR Çevrimdışı   Alıntı Yaparak Cevapla
Eski 08-04-2010, 17:28   #3
kemerkayalı
 
Giriş: 28/11/2006
Şehir: istanbul
Mesaj: 56
Excel Vers. ve Dili:
excell 2010 türkçe
Varsayılan Yanlış sonuç verdi

Hocam verdiğiniz örnekleri inceledim. Topla çarpımla uygulamaya çalıştım, formül çalıştı sonunda ama bu sefer yanlış toplam veriyor, hatam nerede acaba. etopla ile mi yapsam daha doğru olur. Öğrenmenin yolu sizleri biraz yormaktan geçiyor, emeğinize sağlık...
Eklenmiş Dosyalar
Dosya Türü: rar Kriterli_toplamda_negatif_pozitif_ayrımlı_toplam.rar (7.2 KB, 48 Görüntülenme)
kemerkayalı Çevrimdışı   Alıntı Yaparak Cevapla
Eski 08-04-2010, 22:49   #4
Vedat Özer
Uzman
 
Vedat Özer kullanıcısının avatarı
 
Giriş: 04/01/2010
Şehir: ANTALYA
Mesaj: 1,923
Excel Vers. ve Dili:
2007 TÜRKÇE
Varsayılan

=TOPLA.ÇARPIM(($A$3:$A$22=$E$3)*($B$3:$B$22=$F$3)* ($C$3:$C$22<0)*($C$3:$C$22)) Sıfırdan Küçük Rakamlar
=TOPLA.ÇARPIM(($A$3:$A$22=$E$3)*($B$3:$B$22=$F$3)* ($C$3:$C$22>0)*($C$3:$C$22)) Sıfırdan Büyük Rakamlar

İnanki Bu Förmülü Tamamen Sayın Yurtaşın Verdiği Örnek Dosyadan Yararlanarak Yaptım
Emeğinize Ve Vermiş Oldugunuz Çalışmalarınız İçin Teşşekkürler
Sayın Yurttaş
__________________
Forum Kuralları
Vedat Özer Çevrimdışı   Alıntı Yaparak Cevapla
Eski 09-04-2010, 11:41   #5
kemerkayalı
 
Giriş: 28/11/2006
Şehir: istanbul
Mesaj: 56
Excel Vers. ve Dili:
excell 2010 türkçe
Varsayılan

Vedat bey teşekkür ederim. Aslında formülüm doğru imiş ama ben çarpım işareti (*) yerine, (--) işareti koymuşum. Aynı işi görüdüğünü zannediyordum. Enteresandır farklı sonuçlar veriyor.
Onları düzeltince çalıştı.Benim formülüm şu idi:
=TOPLA.ÇARPIM(--($A$3:$A$22=$E$3)--($B$3:$B$22=$F$3)--($C$3:$C$22>0)--($C$3:$C$22))
sizin düzelttiğiniz formül de şu:
=TOPLA.ÇARPIM(($A$3:$A$22=$E$3)*($B$3:$B$22=$F$3)* ($C$3:$C$22<0)*($C$3:$C$22))
Çok teşekkürler. Bir haftadır bununla uğraşıyordum. Sağolun
kemerkayalı Çevrimdışı   Alıntı Yaparak Cevapla
Eski 09-04-2010, 11:47   #6
Ömer
Moderatör
 
Ömer kullanıcısının avatarı
 
Giriş: 18/08/2007
Mesaj: 17,452
Excel Vers. ve Dili:
Excel 2010 Türkçe
Varsayılan

Merhaba,

-- kullanımında hatalı yazım olduğu için yanlış sonuçlar almışsınızdır.

=TOPLA.ÇARPIM(--($A$3:$A$22=$E$3);--($B$3:$B$22=$F$3);--($C$3:$C$22<0);--($C$3:$C$22))

Bu şekilde kullanırsanız aynı sonucu elde edersiniz.

Detaylı bilgi için linki inceleyiniz..

Sumproduct-Topla.Çarpım Fonksiyonu ve Uygulamaları

.
__________________
.
Ömer Çevrimdışı   Alıntı Yaparak Cevapla
Eski 09-04-2010, 11:52   #7
İdris SERDAR
Moderatör
 
İdris SERDAR kullanıcısının avatarı
 
Giriş: 21/10/2005
Mesaj: 12,667
Excel Vers. ve Dili:
Excel, 2013 - İngilizce
Varsayılan

Alıntı:
kemerkayalı tarafından gönderildi Mesajı Görüntüle
Vedat bey teşekkür ederim. Aslında formülüm doğru imiş ama ben çarpım işareti (*) yerine, (--) işareti koymuşum. Aynı işi görüdüğünü zannediyordum. Enteresandır farklı sonuçlar veriyor.
Onları düzeltince çalıştı.Benim formülüm şu idi:
=TOPLA.ÇARPIM(--($A$3:$A$22=$E$3)--($B$3:$B$22=$F$3)--($C$3:$C$22>0)--($C$3:$C$22))
sizin düzelttiğiniz formül de şu:
=TOPLA.ÇARPIM(($A$3:$A$22=$E$3)*($B$3:$B$22=$F$3)* ($C$3:$C$22<0)*($C$3:$C$22))
Çok teşekkürler. Bir haftadır bununla uğraşıyordum. Sağolun
.
Aynı işi görür. Ancak;

=TOPLA.ÇARPIM(--($A$3:$A$22=$E$3)--($B$3:$B$22=$F$3)--($C$3:$C$22>0)--($C$3:$C$22))

Öyle bir yazılış biçimi yok.

Aşağıdaki gibi yazmalısınız.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=SUMPRODUCT(--($A$3:$A$22=$E$3);--($B$3:$B$22=$F$3);--($C$3:$C$22<0);--($C$3:$C$22))

.
__________________
Çalışmalarımı görmek için:

http://www.excelgurusu.com/

İdris SERDAR
İdris SERDAR Çevrimdışı   Alıntı Yaparak Cevapla
Eski 10-04-2010, 14:31   #8
Vedat Özer
Uzman
 
Vedat Özer kullanıcısının avatarı
 
Giriş: 04/01/2010
Şehir: ANTALYA
Mesaj: 1,923
Excel Vers. ve Dili:
2007 TÜRKÇE
Varsayılan

Sayın Hocalarım Benim Yazdıgım Formül Sadece 2 ölçüde Uyanların Toplamını alıyo saydırmak için ne yapmak lazım
__________________
Forum Kuralları
Vedat Özer Çevrimdışı   Alıntı Yaparak Cevapla
Eski 10-04-2010, 14:41   #9
Vedat Özer
Uzman
 
Vedat Özer kullanıcısının avatarı
 
Giriş: 04/01/2010
Şehir: ANTALYA
Mesaj: 1,923
Excel Vers. ve Dili:
2007 TÜRKÇE
Varsayılan

Merhaba,

=TOPLA.ÇARPIM(($A$3:$A$22=$E$3)*($B$3:$B$22=$F$3)* ($C$3:$C$22<0)) bu formül sayesinde kaç tane oldugunu buldum ama benim öğrenmek istediğim rakamların oldugu yerde harfler olsa onları nasıl saydırcaz mesela yukarda <0 toplamını alıyo ben diyecem vedat geçen hücreleri say şimdiden teşşekkürler
__________________
Forum Kuralları
Vedat Özer Çevrimdışı   Alıntı Yaparak Cevapla
Eski 10-04-2010, 14:44   #10
Ömer
Moderatör
 
Ömer kullanıcısının avatarı
 
Giriş: 18/08/2007
Mesaj: 17,452
Excel Vers. ve Dili:
Excel 2010 Türkçe
Varsayılan

Vedat bey,

Bu istediklerinizin tümü verdiğim linkte mevcuttur. Dosyanıza uyarlayamadıysanız küçük bir örnek dosya ekleyerek açıklarsanız daha net bir cevap verebiliriz.

.
__________________
.
Ömer Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 08:29


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.


Bahis Forum - Termal Kemer - Define - Samsung Fernseher - Plastik - Excel Eğitim - Çorlu Kamera - Kırklareli Kız Yurdu - Kırklareli Kız Apart - Yurt Kırklareli - Kız Yurdu Kırklareli - Kız Öğrenci Yurdu Kırklareli - Kız Öğrenci Apart - Kırklareli Sembol - Kırklareli Pansiyon - Kırklareli Kız Apart - Kırklareli Kız Apart - Kırklareli Apart - Kırklareli Yurt - Kırklareli Kız Yurdu - Çorlu Demir Çelik - Kırklareli Kız Öğrenci - Çorlu Petek Temizleme
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2014, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden