Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Diğer Excel Soruları
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Diğer Excel Soruları Yukarıdaki başlıklara uymayan Excel sorularınızı bu bölüme gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 07-04-2010, 19:23   #1
kemerkayalı
 
Giriş: 28/11/2006
Şehir: istanbul
Mesaj: 56
Excel Vers. ve Dili:
excell 2010 türkçe
Arrow 3-4 kriterde etopla formülünü uygulama

Arkadaşlar, Etopla formülünde çizelgemde dönem ve ürün seçenekleri ve tutar haneleri var. Toplam aldırırken döneme , ürüne göre pozitif miktarları ayrı yere, negatif miktarları ayrı yere toplatmam gerek, bunu kodla yapmışlardı ama ben fonksiyonla anlamak ve yapabilmek istiyorum şimdiden teşekkürler.örnek ektedir
Eklenmiş Dosyalar
Dosya Türü: rar Kriterli_toplamda_negatif_pozitif_ayrımlı_toplam.rar (7.2 KB, 53 Görüntülenme)
kemerkayalı Çevrimdışı   Alıntı Yaparak Cevapla
Eski 07-04-2010, 19:33   #2
İdris SERDAR
Moderatör
 
İdris SERDAR kullanıcısının avatarı
 
Giriş: 21/10/2005
Şehir: Ankara
Mesaj: 14,265
Excel Vers. ve Dili:
Excel, 2016 - İngilizce
Varsayılan

Alıntı:
kemerkayalı tarafından gönderildi Mesajı Görüntüle
Arkadaşlar, Etopla formülünde çizelgemde dönem ve ürün seçenekleri ve tutar haneleri var. Toplam aldırırken döneme , ürüne göre pozitif miktarları ayrı yere, negatif miktarları ayrı yere toplatmam gerek, bunu kodla yapmışlardı ama ben fonksiyonla anlamak ve yapabilmek istiyorum şimdiden teşekkürler.örnek ektedir
.

Buradaki örnekleri inceleyin.



Toplama Ve Sayma

Sumproduct-Topla.Çarpım Fonksiyonu ve Uygulamaları


.
__________________
Çalışmalarımı görmek için:

http://www.excelgurusu.com/

İdris SERDAR
İdris SERDAR Çevrimdışı   Alıntı Yaparak Cevapla
Eski 08-04-2010, 17:28   #3
kemerkayalı
 
Giriş: 28/11/2006
Şehir: istanbul
Mesaj: 56
Excel Vers. ve Dili:
excell 2010 türkçe
Varsayılan Yanlış sonuç verdi

Hocam verdiğiniz örnekleri inceledim. Topla çarpımla uygulamaya çalıştım, formül çalıştı sonunda ama bu sefer yanlış toplam veriyor, hatam nerede acaba. etopla ile mi yapsam daha doğru olur. Öğrenmenin yolu sizleri biraz yormaktan geçiyor, emeğinize sağlık...
Eklenmiş Dosyalar
Dosya Türü: rar Kriterli_toplamda_negatif_pozitif_ayrımlı_toplam.rar (7.2 KB, 48 Görüntülenme)
kemerkayalı Çevrimdışı   Alıntı Yaparak Cevapla
Eski 08-04-2010, 22:49   #4
Vedat Özer
Uzman
 
Vedat Özer kullanıcısının avatarı
 
Giriş: 04/01/2010
Şehir: Antalya
Mesaj: 2,015
Excel Vers. ve Dili:
OFFICE 2007 PRO TR - Win7 X64
Varsayılan

=TOPLA.ÇARPIM(($A$3:$A$22=$E$3)*($B$3:$B$22=$F$3)* ($C$3:$C$22<0)*($C$3:$C$22)) Sıfırdan Küçük Rakamlar
=TOPLA.ÇARPIM(($A$3:$A$22=$E$3)*($B$3:$B$22=$F$3)* ($C$3:$C$22>0)*($C$3:$C$22)) Sıfırdan Büyük Rakamlar

İnanki Bu Förmülü Tamamen Sayın Yurtaşın Verdiği Örnek Dosyadan Yararlanarak Yaptım
Emeğinize Ve Vermiş Oldugunuz Çalışmalarınız İçin Teşşekkürler
Sayın Yurttaş
__________________
حَسْبُنَا اللهُ وَنِعْمَ الْوَكِيلُ
Allah bize yeter, O ne güzel vekildir.

Forum Kuralları
Vedat Özer Çevrimdışı   Alıntı Yaparak Cevapla
Eski 09-04-2010, 11:41   #5
kemerkayalı
 
Giriş: 28/11/2006
Şehir: istanbul
Mesaj: 56
Excel Vers. ve Dili:
excell 2010 türkçe
Varsayılan

Vedat bey teşekkür ederim. Aslında formülüm doğru imiş ama ben çarpım işareti (*) yerine, (--) işareti koymuşum. Aynı işi görüdüğünü zannediyordum. Enteresandır farklı sonuçlar veriyor.
Onları düzeltince çalıştı.Benim formülüm şu idi:
=TOPLA.ÇARPIM(--($A$3:$A$22=$E$3)--($B$3:$B$22=$F$3)--($C$3:$C$22>0)--($C$3:$C$22))
sizin düzelttiğiniz formül de şu:
=TOPLA.ÇARPIM(($A$3:$A$22=$E$3)*($B$3:$B$22=$F$3)* ($C$3:$C$22<0)*($C$3:$C$22))
Çok teşekkürler. Bir haftadır bununla uğraşıyordum. Sağolun
kemerkayalı Çevrimdışı   Alıntı Yaparak Cevapla
Eski 09-04-2010, 11:47   #6
Ömer
Moderatör
 
Ömer kullanıcısının avatarı
 
Giriş: 18/08/2007
Şehir: Kuşadası
Mesaj: 18,768
Excel Vers. ve Dili:
Excel 2010 Türkçe
Varsayılan

Merhaba,

-- kullanımında hatalı yazım olduğu için yanlış sonuçlar almışsınızdır.

=TOPLA.ÇARPIM(--($A$3:$A$22=$E$3);--($B$3:$B$22=$F$3);--($C$3:$C$22<0);--($C$3:$C$22))

Bu şekilde kullanırsanız aynı sonucu elde edersiniz.

Detaylı bilgi için linki inceleyiniz..

Sumproduct-Topla.Çarpım Fonksiyonu ve Uygulamaları

.
__________________
.
Ömer Çevrimdışı   Alıntı Yaparak Cevapla
Eski 09-04-2010, 11:52   #7
İdris SERDAR
Moderatör
 
İdris SERDAR kullanıcısının avatarı
 
Giriş: 21/10/2005
Şehir: Ankara
Mesaj: 14,265
Excel Vers. ve Dili:
Excel, 2016 - İngilizce
Varsayılan

Alıntı:
kemerkayalı tarafından gönderildi Mesajı Görüntüle
Vedat bey teşekkür ederim. Aslında formülüm doğru imiş ama ben çarpım işareti (*) yerine, (--) işareti koymuşum. Aynı işi görüdüğünü zannediyordum. Enteresandır farklı sonuçlar veriyor.
Onları düzeltince çalıştı.Benim formülüm şu idi:
=TOPLA.ÇARPIM(--($A$3:$A$22=$E$3)--($B$3:$B$22=$F$3)--($C$3:$C$22>0)--($C$3:$C$22))
sizin düzelttiğiniz formül de şu:
=TOPLA.ÇARPIM(($A$3:$A$22=$E$3)*($B$3:$B$22=$F$3)* ($C$3:$C$22<0)*($C$3:$C$22))
Çok teşekkürler. Bir haftadır bununla uğraşıyordum. Sağolun
.
Aynı işi görür. Ancak;

=TOPLA.ÇARPIM(--($A$3:$A$22=$E$3)--($B$3:$B$22=$F$3)--($C$3:$C$22>0)--($C$3:$C$22))

Öyle bir yazılış biçimi yok.

Aşağıdaki gibi yazmalısınız.

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=SUMPRODUCT(--($A$3:$A$22=$E$3);--($B$3:$B$22=$F$3);--($C$3:$C$22<0);--($C$3:$C$22))

.
__________________
Çalışmalarımı görmek için:

http://www.excelgurusu.com/

İdris SERDAR
İdris SERDAR Çevrimdışı   Alıntı Yaparak Cevapla
Eski 10-04-2010, 14:31   #8
Vedat Özer
Uzman
 
Vedat Özer kullanıcısının avatarı
 
Giriş: 04/01/2010
Şehir: Antalya
Mesaj: 2,015
Excel Vers. ve Dili:
OFFICE 2007 PRO TR - Win7 X64
Varsayılan

Sayın Hocalarım Benim Yazdıgım Formül Sadece 2 ölçüde Uyanların Toplamını alıyo saydırmak için ne yapmak lazım
__________________
حَسْبُنَا اللهُ وَنِعْمَ الْوَكِيلُ
Allah bize yeter, O ne güzel vekildir.

Forum Kuralları
Vedat Özer Çevrimdışı   Alıntı Yaparak Cevapla
Eski 10-04-2010, 14:41   #9
Vedat Özer
Uzman
 
Vedat Özer kullanıcısının avatarı
 
Giriş: 04/01/2010
Şehir: Antalya
Mesaj: 2,015
Excel Vers. ve Dili:
OFFICE 2007 PRO TR - Win7 X64
Varsayılan

Merhaba,

=TOPLA.ÇARPIM(($A$3:$A$22=$E$3)*($B$3:$B$22=$F$3)* ($C$3:$C$22<0)) bu formül sayesinde kaç tane oldugunu buldum ama benim öğrenmek istediğim rakamların oldugu yerde harfler olsa onları nasıl saydırcaz mesela yukarda <0 toplamını alıyo ben diyecem vedat geçen hücreleri say şimdiden teşşekkürler
__________________
حَسْبُنَا اللهُ وَنِعْمَ الْوَكِيلُ
Allah bize yeter, O ne güzel vekildir.

Forum Kuralları
Vedat Özer Çevrimdışı   Alıntı Yaparak Cevapla
Eski 10-04-2010, 14:44   #10
Ömer
Moderatör
 
Ömer kullanıcısının avatarı
 
Giriş: 18/08/2007
Şehir: Kuşadası
Mesaj: 18,768
Excel Vers. ve Dili:
Excel 2010 Türkçe
Varsayılan

Vedat bey,

Bu istediklerinizin tümü verdiğim linkte mevcuttur. Dosyanıza uyarlayamadıysanız küçük bir örnek dosya ekleyerek açıklarsanız daha net bir cevap verebiliriz.

.
__________________
.
Ömer Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 16:38


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Torna - Çorlu Web Tasarım - Tarot Falı - invest in turkey - Hurda - Lingerie - Dyeing Machine - Çorlu Temizlik- Karton Bardak- Çorlu Pimapenci- İstanbul Avukat- Çorlu Kekemelik- Edirne Su Arıtma- Çorlu Perde Yıkama- Site Yönetimi- Led Aydınlatma- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Kırklareli- Pronet Çerkezköy- Pronet Çorlu- Pronet Lüleburgaz- Pronet Keşan- Çorlu Araç Takip- Çorlu Su Arıtma- Çorlu İnşaat- Marmara Ereğlisi Yurt- Çorlu Solucan Gübresi- Boru Profil- Gebze Emlak- Beylikdüzü Temizlik- İstanbul Burun Estetiği- Su Deposu Temizliği- Bakır Sülfat- Rampa- Rotary-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden