Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Diğer Excel Soruları
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Diğer Excel Soruları Yukarıdaki başlıklara uymayan Excel sorularınızı bu bölüme gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 13-11-2017, 16:37   #1
enesyildiz
Altın Üye
 
Giriş: 26/02/2014
Mesaj: 19
Excel Vers. ve Dili:
2016
Varsayılan 2 şarta bağlı veri getirme yardım

dosya ekledim arkdaşlar. isim ve soyisim karşılaştırmasıına bağlı olarak not bilgisi çekmek istiyorum. yardımlarınızı bekliyorum.
Eklenmiş Dosyalar
Dosya Türü: xlsx excelweb.xlsx (9.9 KB, 13 Görüntülenme)
enesyildiz Çevrimdışı   Alıntı Yaparak Cevapla
Eski 14-11-2017, 08:12   #2
Vedat Özer
Uzman
 
Vedat Özer kullanıcısının avatarı
 
Giriş: 04/01/2010
Şehir: Antalya
Mesaj: 2,038
Excel Vers. ve Dili:
OFFICE 2007 PRO TR - Win7 X64
Varsayılan

Selamlar,

Dosyayı inceleyin.
Eklenmiş Dosyalar
Dosya Türü: rar excelweb.rar (19.4 KB, 10 Görüntülenme)
__________________
حَسْبُنَا اللهُ وَنِعْمَ الْوَكِيلُ
Allah bize yeter, O ne güzel vekildir.

Forum Kuralları
Vedat Özer Çevrimdışı   Alıntı Yaparak Cevapla
Eski 14-11-2017, 08:32   #3
halit3
Uzman
 
halit3 kullanıcısının avatarı
 
Giriş: 18/01/2008
Mesaj: 10,482
Excel Vers. ve Dili:
2003 excel türkçe
Varsayılan

Alternatif kod
not birleştirilmiş hücreleri çözünüz.

kod:

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
Sub Gruplandir()

Application.ScreenUpdating = False
Application.Calculation = xlManual

Set s1 = Sheets("DATAA") ' veri sayfası
Set s2 = Sheets("LİSTE") 'aktarılan sayfa


son1 = s1.Cells(Rows.Count, "A").End(3).Row
son2 = s2.Cells(Rows.Count, "A").End(3).Row


s2.Range("D2:D" & son2).ClearContents

ReDim ara1(son1): ReDim ara2(son1):

For j = 3 To son1
ara1(j) = WorksheetFunction.Trim(s1.Cells(j, "A")) & WorksheetFunction.Trim(s1.Cells(j, "B"))
ara2(j) = 1
Next j


For r = 3 To son1
If ara2(r) = 1 Then
For i = r - 1 To son2
bulunan1 = WorksheetFunction.Trim(s2.Cells(i, "A")) & WorksheetFunction.Trim(s2.Cells(i, "B"))

If bulunan1 = ara1(r) Then
s2.Cells(i, "d").Value = s1.Cells(r, "d").Value
ara2(i) = 0
Exit For
End If
Next i

End If
Next r

Application.Calculation = xlAutomatic
Application.ScreenUpdating = True

MsgBox "İşleminiz tamamlanmıştır.", vbInformation, " Sonuç Penceresi"

End Sub
__________________





Forum Kuralları
halit3 Çevrimdışı   Alıntı Yaparak Cevapla
Eski 14-11-2017, 08:45   #4
anemis
Altın Üye
 
Giriş: 10/10/2013
Şehir: Ankara
Mesaj: 121
Excel Vers. ve Dili:
Excel 2016
Varsayılan

VBA kullanmadan, formülle yapmanın bir yolu var mıdır acaba?
anemis Çevrimdışı   Alıntı Yaparak Cevapla
Eski 14-11-2017, 09:03   #5
enesyildiz
Altın Üye
 
Giriş: 26/02/2014
Mesaj: 19
Excel Vers. ve Dili:
2016
Varsayılan

arkadaşlar emeğinize sağlık gerçekten güzel çalışma.

ama makro kullanmadan bunu yapma imkanımız varsa daha güzel olacak benim için.
enesyildiz Çevrimdışı   Alıntı Yaparak Cevapla
Eski 14-11-2017, 09:18   #6
Vedat Özer
Uzman
 
Vedat Özer kullanıcısının avatarı
 
Giriş: 04/01/2010
Şehir: Antalya
Mesaj: 2,038
Excel Vers. ve Dili:
OFFICE 2007 PRO TR - Win7 X64
Varsayılan

Selamlar,

Formüller dizi'dir

CTRL+STHİFT+ ENTER ile çalıştırın

C2 Hücresine ;

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=İNDİS(DATAA!$C$2:$C$65536;TOPLA.ÇARPIM((KAÇINCI(A2&"@"&B2;DATAA!$A$2:$A$65536&"@"&DATAA!$B$2:$B$65536;0))))

D2 Hücresine ;
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=İNDİS(DATAA!$D$2:$D$65536;TOPLA.ÇARPIM((KAÇINCI(A2&"@"&B2;DATAA!$A$2:$A$65536&"@"&DATAA!$B$2:$B$65536;0))))
Eklenmiş Dosyalar
Dosya Türü: xlsx formül.xlsx (10.4 KB, 2 Görüntülenme)
__________________
حَسْبُنَا اللهُ وَنِعْمَ الْوَكِيلُ
Allah bize yeter, O ne güzel vekildir.

Forum Kuralları
Vedat Özer Çevrimdışı   Alıntı Yaparak Cevapla
Eski 14-11-2017, 17:26   #7
enesyildiz
Altın Üye
 
Giriş: 26/02/2014
Mesaj: 19
Excel Vers. ve Dili:
2016
Varsayılan

çok teşekkürler vedat bey. sayenizde hallettim.
enesyildiz Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 02:41


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım - Tarot Falı - invest in turkey - Lingerie - Dyeing Machine - Karton Bardak- Çorlu Özel Eğitim- Site Yönetimi- Led Aydınlatma- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Kırklareli- Pronet Çerkezköy- Pronet Çorlu- Pronet Lüleburgaz- Pronet Keşan- Çorlu Araç Takip- Çorlu Su Arıtma- Boru Profil- Gebze Emlak- Beylikdüzü Temizlik- İstanbul Burun Estetiği- Bakır Sülfat- Rampa- Rotary- Çorlu İnternet Sitesi- youngblood- Çorlu Palet- Çerkezköy Palet- Çorlu Prefabrik- Çorlu Sürücü Kursu- Çorlu Sandviç Panel- Şişli Avukat- Korona Test Kalemi- Çorlu Vinç- Çorlu Pimapen Tamiri-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden