Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Makro-VBA
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Makro-VBA Makro veya VBA ile ilgili sorularınızı buraya gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 15-05-2018, 14:14   #1
bebar
Altın Üye
 
Giriş: 12/11/2014
Şehir: istanbul
Mesaj: 105
Excel Vers. ve Dili:
2013
Varsayılan Tek veri için çoklu düşeyara

Merhaba,

Daha öncede benzer konular açılmış fakat uygun örneği bulamadım, örneğim ektedir açıklamamı orada yaptım yardımcı olursanız çok memnun olurum
Eklenmiş Dosyalar
Dosya Türü: xlsx çoklu düşeyara örnek.xlsx (9.4 KB, 14 Görüntülenme)

Bu mesaj en son " 15-05-2018 " tarihinde saat 14:32 itibariyle bebar tarafından düzenlenmiştir....
bebar Çevrimdışı   Alıntı Yaparak Cevapla
Eski 15-05-2018, 15:46   #2
Ömer BARAN
Uzman
 
Giriş: 08/03/2011
Şehir: ANKARA / İSTANBUL
Mesaj: 10,448
Excel Vers. ve Dili:
Office 2013 TÜRKÇE
Varsayılan

Merhaba.

Aşağıdaki formüllerden birini dizi formülü olarak F3 hücresine uygulayın ve BOŞ sonuç elde edinceye kadar aşağı doğru kopyalayın.
.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(EĞERSAY($A$3:$A$16;$E$3)<SATIR()-2;"";KAYDIR($B$2;KÜÇÜK(EĞER($A$3:$A$16=$E$3;SATIR($A$3:$A$16)-2);SATIR(A1));0))
=EĞER(EĞERSAY($A$3:$A$16;$E$3)<SATIR()-2;"";İNDİS($B$3:$B$16;KÜÇÜK(EĞER($A$3:$A$16=$E$3;SATIR($A$3:$A$16)-2);SATIR(A1));0))
__________________
.
☾✭ İnadına TÜRKÇE ✭☽

-- Sorunuzu, gerçek belgenizle aynı yapıda ve olması gereken sonuçların elle yazıldığı örnek belge ile destekleyiniz.
-- ALTIN ÜYELİK öneriyorum. / FORUM KURALLARInı mutlaka okuyunuz.
-- ALTIN ÜYE olmayanlar, örnek belgeyi dosya.tc, dosyaupload.com gibi bir siteye yükleyip, belgeye erişim adresini verebilir.
-- Özel mesaj ile soru sormayınız. / Geri bildirimde bulunulmayan cevaplarımı siliyorum.
Ömer BARAN Çevrimdışı   Alıntı Yaparak Cevapla
Eski 15-05-2018, 15:51   #3
bebar
Altın Üye
 
Giriş: 12/11/2014
Şehir: istanbul
Mesaj: 105
Excel Vers. ve Dili:
2013
Varsayılan

hocam teşekkür ederim fakat verileri aldığım bazı yerlerde satır boşlukları var, dizi formulü tam olarak işimi görmüyor.
bebar Çevrimdışı   Alıntı Yaparak Cevapla
Eski 15-05-2018, 15:55   #4
Ömer BARAN
Uzman
 
Giriş: 08/03/2011
Şehir: ANKARA / İSTANBUL
Mesaj: 10,448
Excel Vers. ve Dili:
Office 2013 TÜRKÇE
Varsayılan

Siz formüldeki veri alanını ($A$3:$A$16) ilk veri hücresinden son veri hücresine kadarki alanı kapsayacak şekilde değiştirin.
Veri listeniz boşluklu da olsa, verdiğim dizi formülü istenilen sonucu verecektir.
__________________
.
☾✭ İnadına TÜRKÇE ✭☽

-- Sorunuzu, gerçek belgenizle aynı yapıda ve olması gereken sonuçların elle yazıldığı örnek belge ile destekleyiniz.
-- ALTIN ÜYELİK öneriyorum. / FORUM KURALLARInı mutlaka okuyunuz.
-- ALTIN ÜYE olmayanlar, örnek belgeyi dosya.tc, dosyaupload.com gibi bir siteye yükleyip, belgeye erişim adresini verebilir.
-- Özel mesaj ile soru sormayınız. / Geri bildirimde bulunulmayan cevaplarımı siliyorum.
Ömer BARAN Çevrimdışı   Alıntı Yaparak Cevapla
Eski 15-05-2018, 15:58   #5
bebar
Altın Üye
 
Giriş: 12/11/2014
Şehir: istanbul
Mesaj: 105
Excel Vers. ve Dili:
2013
Varsayılan

Çok teşekkür ederim hocam
bebar Çevrimdışı   Alıntı Yaparak Cevapla
Eski 16-05-2018, 00:20   #6
Ömer BARAN
Uzman
 
Giriş: 08/03/2011
Şehir: ANKARA / İSTANBUL
Mesaj: 10,448
Excel Vers. ve Dili:
Office 2013 TÜRKÇE
Varsayılan

Estağfurullah, kolay gelsin.
.
__________________
.
☾✭ İnadına TÜRKÇE ✭☽

-- Sorunuzu, gerçek belgenizle aynı yapıda ve olması gereken sonuçların elle yazıldığı örnek belge ile destekleyiniz.
-- ALTIN ÜYELİK öneriyorum. / FORUM KURALLARInı mutlaka okuyunuz.
-- ALTIN ÜYE olmayanlar, örnek belgeyi dosya.tc, dosyaupload.com gibi bir siteye yükleyip, belgeye erişim adresini verebilir.
-- Özel mesaj ile soru sormayınız. / Geri bildirimde bulunulmayan cevaplarımı siliyorum.
Ömer BARAN Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 11:36


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Karton Bardak- Çorlu Dil Konuşma Terapisti- Çorlu Dil Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Çorlu- Çorlu Araç Takip- Rampa- Çorlu İnternet Sitesi- Çorlu Sürücü Kursu- Şişli Avukat- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta- Kağıt Bardak- Kağıt Bardak- Çorlu Havuz- Çorlu Havuz- Çorlu Perde Yıkama- Okul Danışmanlık- ADR'li taşıma kabı imalatı- Mekanik Tesisat- Çorlu Grafik Tasarım- Çorlu Sondaj- Çorlu Etüt- Futbol Cafe- Beylikdüzü Temizlik- Çorlu Kurs- Çorlu Ders- İzmit Mimar- Hurda Bakır Kablo- Hurda Bakır Kablo- Çorlu Pronet- Çorlu Yönetim- Çorlu Apartman Yönetimi- Çorlu Marangoz- Çorlu Avukat- Çorlu Su Arıtma- Çorlu Kompresör- İstanbul İnşaat-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden