Yalnız Mesajı Göster
Eski 09-02-2018, 15:33  
yselimyilmaz
Altın Üye
 
Giriş: 29/12/2007
Şehir: edirne
Mesaj: 38
Excel Vers. ve Dili:
2010-türkçe
Varsayılan Formülleri Makro ile oluşturmak

Selam Arkadaşlar;

Çalışma Sayfamda aşağıda yazılı formüller bulunmaktadır. Sayfamdaki veriler çoğaldıkça formüller yüzünden işlemler yavaşlamaktadır. Formulleri sayfadan silip Userform'da oluşturacağım CommandButton içeriğine yazmak istiyorum.Bu formüllerin makro karşılıkları nelerdir veya nasıl kodlama yapmam gerekir ki, formül sonuçları istenilen hücrelere yazılsın?

1.formül
DATA1 Sayfası G2 Hücresinde ve G3,G4,G5.... Diye gidiyor.

=EĞER(A2<>"";TOPLA.ÇARPIM((SAYIM!$A$2:$A$65536=DAT A1!A2)*(SAYIM!$E$2:$E$65536));"")

2.formül
DATA1 Sayfası H2 Hücresinde ve H3,H4,H5.... Diye gidiyor.

=EĞER(A2<>"";(EĞER(G2>E2;G2-E2;E2-G2));"")

3.formül
DATA1 Sayfası I2 Hücresinde ve I3,I4,I5.... Diye gidiyor.

=EĞER(A2<>"";EĞER(G2>E2;"FAZLA";EĞER(E2>G2;"EKSİK" ;EĞER(G2=E2;"TAM")));"")

4.formül
DATA1 Sayfası J2 Hücresinde ve J3,J4,J5.... Diye gidiyor.
=EĞER(A2<>"";"TÜM LİSTE";"")
yselimyilmaz Çevrimdışı   Alıntı Yaparak Cevapla