Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Makro-VBA
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Makro-VBA Makro veya VBA ile ilgili sorularınızı buraya gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 03-01-2018, 22:08   #1
ersingur
 
Giriş: 27/01/2011
Şehir: urfa
Mesaj: 6
Excel Vers. ve Dili:
exel 2010 türkçe
Smile Formülde hücre değerlerini otomatik arttırma

Merhabalar,
sabit bir formülde alınan referans numaraları 25 er artmaktadır bu hücre değerlerini otomatik olarak 25 er arttırmamız mümkün mü acaba ? Şimdiden teşekkür ederim.Aşağıdaki e hücre değerini 25 er arttırmak istiyorum.

=TOPLA('02 br 04 veri'!E1632:E1656)
ersingur Çevrimdışı   Alıntı Yaparak Cevapla
Eski 03-01-2018, 22:38   #2
Haluk
Özel Üye
 
Giriş: 07/07/2004
Şehir: Türkiye
Mesaj: 5,254
Excel Vers. ve Dili:
Office 2010 - İngilizce
Varsayılan

Merhaba;

Aşağıdaki formül; 02 br 04 veri sayfasında E2:E1800 aralığında, E2 hücresinden başlayarak 25'erlik artışlarla hücrelerin içindeki verileri toplar.

Yani; E2 + E27 + E52 + E77 ......

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=SUMPRODUCT((MOD(ROW('02 br 04 veri'!$E$2:$E$1800);25)=0)*('02 br 04 veri'!$E$2:$E$1800))
Excel'iniz Türkçe ise, formülde Türkçe karşılıkları kullanmanız gerekir.

Forum üyelerinden İdris Beyin sitesinden indirebileceğiniz dosya ile karşılıklarını bulabilirsiniz;

http://www.excelgurusu.com/excel-isl...-alphabetical/


.
__________________
Kod anlatılmaz,yazılır ! 🇹🇷

Bu mesaj en son " 03-01-2018 " tarihinde saat 22:45 itibariyle Haluk tarafından düzenlenmiştir....
Haluk Çevrimiçi   Alıntı Yaparak Cevapla
Eski 03-01-2018, 23:01   #3
Ömer BARAN
Uzman
 
Giriş: 08/03/2011
Şehir: ANKARA / İSTANBUL
Mesaj: 9,477
Excel Vers. ve Dili:
Office 2013 TÜRKÇE
Varsayılan

Merhaba.

Konuyu Makro VBA bölümüne açmışsınız ancak formül ile çözüme ilişkin fikrimi söylemek istedim.

Gördüğüm kadarıyla; satır numaraları arasında (... * 25+7 ve ... * 25+6) şeklinde bir ilişki var
ama gereksiz mesajlaşmalara neden olmamak bakımından,
formülün uygulandığı ilk birkaç hücrenin olduğu bir örnek belge yüklemenizde yarar var.

Örnek belgenizin gerçek belgeyle aynı yapıda olmasını ve anlamlı veriler içermesini sağlayınız.
Örnek belge özellikleri ve örnek belge yükleme yöntemine ilişkin kısa açıklama cevabımın atındaki İMZA bölümünde var.

-- İsterseniz aşağıdaki formülü işlem yapılacak ilk hücreye uygulayın ve aşağı doğru yeterince satıra kopyalayın.
-- Verdiğim formüle göre; ilk formül hücresinde toplanacak alan E7:E31 iken bir sonrakinde E32:E56...... formülün uygulandığı 66'ncı satırda ise sorunuzda belirttiğiniz E1632:E1656 olur.
.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=TOPLA(DOLAYLI("'02 br 04 veri'!"&ADRES((SATIR(A1)-1)*25+7;5;4)&":"&ADRES((SATIR(A1))*25+6;5;4)))
__________________
.
☾✭ İnadına TÜRKÇE ✭☽

-- Sorunuzu, gerçek belgenizle aynı yapıda ve olması gereken sonuçların elle yazıldığı örnek belge ile destekleyiniz.
-- ALTIN ÜYELİK öneriyorum. / FORUM KURALLARInı mutlaka okuyunuz.
-- ALTIN ÜYE olmayanlar, örnek belgeyi dosya.tc, dosya.co gibi bir siteye yükleyip, belgeye erişim adresini verebilir.
-- Özel mesaj ile soru sormayınız. / Geri bildirimde bulunulmayan cevaplarımı siliyorum.
Ömer BARAN Çevrimdışı   Alıntı Yaparak Cevapla
Eski 04-01-2018, 18:09   #4
ersingur
 
Giriş: 27/01/2011
Şehir: urfa
Mesaj: 6
Excel Vers. ve Dili:
exel 2010 türkçe
Varsayılan

cevabınız için teşekkür ederim toplam için formülünüzü uygulayabildim linkteki excelde max ve ortalama içinde formül yazmıştım acaba bunlarada sizin formülünüzü uyarlayabilir miyiz ?
Teşekkürler.

http://dosya.co/kruh38fo4tvv/MERSİN_..._(1).xlsx.html
ersingur Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 22:04


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Çorlu Dil Konuşma Terapisti- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Çorlu- Çorlu Araç Takip- Çorlu Su Arıtma- Gebze Emlak- Rampa- Rotary- Çorlu İnternet Sitesi- Çorlu Sürücü Kursu- Çorlu Sürücü Kursu- Şişli Avukat- Edirne Serbest Muhasebeci- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta- Kağıt Bardak- Kaplan Tekstil- Çorlu Perde- Çorlu Havuz- Makina- Danışmazlar-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden