Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Makro-VBA
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Makro-VBA Makro veya VBA ile ilgili sorularınızı buraya gönderebilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 19-01-2018, 14:22   #1
policeman
Altın Üye
 
Giriş: 01/09/2007
Şehir: İstanbul
Mesaj: 324
Excel Vers. ve Dili:
2002 Türkçe
Varsayılan Formül karşılığı

Merhaba...
=EĞER(AK3=”VAR”;1;0) formülü,
.Formula = "=IF(AK3=""VAR"",1,0)" olarak kod içerisinde yazılı...

Bu kodu aşağıdaki formülün karşılığı ile değiştirmek istiyorum;
=EĞER(VE(G3=”EVET”;AK3=”VAR”);1;0)

Mümkünse yardım bekliyorum..
Saygılarımla..
policeman Çevrimdışı   Alıntı Yaparak Cevapla
Eski 19-01-2018, 14:29   #2
askm
Altın Üye
 
Giriş: 04/06/2005
Şehir: k.maraş
Mesaj: 1,967
Excel Vers. ve Dili:
2010-2016
Varsayılan

Formula = "=IF(And(AK3=""VAR"";G3="”EVET”"),1,0)"
şeklinde deneyin. Yalnız dosyanız olsa idi bunu komple kod halinde yazabilirdik.
__________________
excel 2010- türkçe
askm Çevrimiçi   Alıntı Yaparak Cevapla
Eski 19-01-2018, 14:49   #3
policeman
Altın Üye
 
Giriş: 01/09/2007
Şehir: İstanbul
Mesaj: 324
Excel Vers. ve Dili:
2002 Türkçe
Varsayılan

Sayın askm denedim olmadı, kod bütünü şöyle;

Sub TpHesapla()
With Application
.ScreenUpdating = False
.Calculation = xlCalculationManual
.EnableEvents = False
End With

Satir = Cells(Rows.Count, "AK").End(3).Row
If Satir >= 2 Then
Range("CE3:CE" & Rows.Count).ClearContents
With Range("CE3:CE" & Satir)
.Formula = "=IF(AK3=""VAR"",1,0)"
.Value = .Value
End With
End If

With Application
.ScreenUpdating = True
.Calculation = xlCalculationAutomatic
.EnableEvents = True
End With
End Sub
policeman Çevrimdışı   Alıntı Yaparak Cevapla
Eski 19-01-2018, 14:49   #4
Haluk
Özel Üye
 
Giriş: 07/07/2004
Şehir: Türkiye
Mesaj: 5,364
Excel Vers. ve Dili:
Office 2010 - İngilizce
Varsayılan

Sayın askm sorunuzu cevaplamış, bir sıkıntı olmaması lazım.

Bununla birlikte, ben de bir alternatif önereyim. Eğer sonucun 1 veya 0 olarak A1 hücresine yazılmasını istiyorsanız;

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
[A1] = ([G3] = "EVET") * ([AK3] = "VAR")
.
__________________
Kod anlatılmaz,yazılır ! 🇹🇷
Haluk Çevrimdışı   Alıntı Yaparak Cevapla
Eski 19-01-2018, 15:04   #5
Haluk
Özel Üye
 
Giriş: 07/07/2004
Şehir: Türkiye
Mesaj: 5,364
Excel Vers. ve Dili:
Office 2010 - İngilizce
Varsayılan

Kodunuzdan anladığım kadarıyla Array Formula (Dizi Formülü) girmeye çalışıyorsunuz.

Bir de şöyle deneyin;

En son mesajınızda yer alan aşağıdaki satırı;

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
.Formula = "=IF(AK3=""VAR"",1,0)"
bununla değiştirin;

Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
.FormulaArray = "=((G3:G" & Satir & "= ""EVET"") * (AK3:AK" & Satir & "= ""VAR""))"
.
__________________
Kod anlatılmaz,yazılır ! 🇹🇷

Bu mesaj en son " 19-01-2018 " tarihinde saat 15:10 itibariyle Haluk tarafından düzenlenmiştir....
Haluk Çevrimdışı   Alıntı Yaparak Cevapla
Eski 19-01-2018, 15:17   #6
policeman
Altın Üye
 
Giriş: 01/09/2007
Şehir: İstanbul
Mesaj: 324
Excel Vers. ve Dili:
2002 Türkçe
Varsayılan

Tamamdır sonuç verdi her ikinize de ilginiz için teşekkür ederim,sağolun..
policeman Çevrimdışı   Alıntı Yaparak Cevapla
Eski 19-01-2018, 15:23   #7
Haluk
Özel Üye
 
Giriş: 07/07/2004
Şehir: Türkiye
Mesaj: 5,364
Excel Vers. ve Dili:
Office 2010 - İngilizce
Varsayılan

Kolay gelsin ...

.
__________________
Kod anlatılmaz,yazılır ! 🇹🇷
Haluk Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 07:00


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Karton Bardak- Çorlu Dil Konuşma Terapisti- Çorlu Dil Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Konuşma Terapisti- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Çorlu- Çorlu Araç Takip- Çorlu Su Arıtma- Gebze Emlak- Rampa- Rotary- Çorlu İnternet Sitesi- Çorlu Sürücü Kursu- Çorlu Sürücü Kursu- Şişli Avukat- Edirne Serbest Muhasebeci- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta- Kağıt Bardak- Kağıt Bardak- Kaplan Tekstil- Çorlu Perde- Çorlu Perde- Çorlu Havuz- Çorlu Havuz- Makina- Danışmazlar- Çorlu Perde Yıkama- Çorlu Perde Yıkama- Okul Danışmanlık- Çorlu Ayakkabı- İzmit Sigorta- ADR'li taşıma kabı imalatı- Mekanik Tesisat- Çorlu Grafik Tasarım-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden