Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Fonksiyonlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Fonksiyonlar Bir fonksiyonun, nasıl işlediğini veya aradığınız bir işleme uygun olup olmadığını bu başlık altında sorabilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Kapalı Konu
 
Paylaş Konu Araçları Görünüm Modları
Eski 25-12-2017, 12:43   #1
SadiSerdari
 
Giriş: 03/10/2011
Şehir: Sivas
Mesaj: 63
Excel Vers. ve Dili:
2010
Varsayılan Yuvarlama Kaynaklı işlev hatası

Arkadaşlar aşağıdaki fonksiyon ile rakamın ilk değerinin sıfır yada büyük olması durumuna bakarak işlem yaptırmaya çalışıyorum.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(SOLDAN(YUVARLA(E33;2);1)="0";SAĞDAN(YUVARLA(E33;2);1);EĞER(SOLDAN(YUVARLA(E33;2);2)>"0";SAĞDAN(YUVARLA(E33;2);2);YANLIŞ))
virgülden sonraki değer 0,01-0,09 ise sorun yok 1-9 arasında yazdırabiliyorum. Ancak örneğin 0,11-0,99 arasında ise sadece en sağdaki değeri alıyor yani 1-9 arasında hangi değer gelmişse onu yazıyor. Yardımlarınız için teşekkürler.
SadiSerdari Çevrimdışı  
Eski 25-12-2017, 13:25   #2
çıtır
Altın Üye
 
Giriş: 06/03/2005
Şehir: KDZ.EREĞLİ
Mesaj: 1,197
Excel Vers. ve Dili:
Excel Vers. ve Dili: Office 2016 TR 64 Bit
Varsayılan

Sayın SadiSerdari " " (tırnak) içinde yazdığınız ifadeler metin olarak algılanır ve > işaretinin metinde bir anlamı olmaz.Tam olarak nasıl bir problem çözmeye çalıştığınız anlamadım .Örnekle açıklarsanız daha kolay yardım alabilirsiniz.Kolay gelsin.
çıtır Çevrimiçi  
Eski 25-12-2017, 13:34   #3
SadiSerdari
 
Giriş: 03/10/2011
Şehir: Sivas
Mesaj: 63
Excel Vers. ve Dili:
2010
Varsayılan

Kardeş farketmiyor. Tırnağı iptal etsem de aynı sorun devam ediyor. Örneğin sadece şunu yaptım.
A1=210,50 yazdım.
sonra =SAĞDAN(A1;2) yadığımda ,5 şeklinde değeri alıyor. oysaki 50 olarak alması lazım.
acaba bende mi bir yanlışlık var diye düşünüp değeri 210,51 olarak yazdım. sonuç 51 olarak dönüyor. excel kaynaklı bir durum. Sonuca ulaşamıyorum.
SadiSerdari Çevrimdışı  
Eski 25-12-2017, 13:52   #4
çıtır
Altın Üye
 
Giriş: 06/03/2005
Şehir: KDZ.EREĞLİ
Mesaj: 1,197
Excel Vers. ve Dili:
Excel Vers. ve Dili: Office 2016 TR 64 Bit
Varsayılan

Sayın SadiSerdari virgülden sonraki 0,5 ve 0,50 aynı değeri ifade ettiğinden sondaki 0 atıyor.Aşağıdaki şekilde deneyiniz.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=MOD(A1;İŞARET(A1))*100
çıtır Çevrimiçi  
Eski 25-12-2017, 14:43   #5
SadiSerdari
 
Giriş: 03/10/2011
Şehir: Sivas
Mesaj: 63
Excel Vers. ve Dili:
2010
Varsayılan

Formülümü şu şekilde düzenledim;
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(EĞERHATA(MOD(E33;İŞARET(E33))*100;0)=0;SAĞDAN(YUVARLA(E33;2);1);MOD(E33;İŞARET(E33))*100)
virgülden sonraki değerin sıfır olma ihtimaline karşı EĞERHATA kullandım.
yol gösterdiğiniz için teşekkürler.

Bu mesaj en son " 25-12-2017 " tarihinde saat 14:58 itibariyle SadiSerdari tarafından düzenlenmiştir....
SadiSerdari Çevrimdışı  
Kapalı Konu


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 21:47


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Çorlu Dil Konuşma Terapisti- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Çorlu- Çorlu Araç Takip- Çorlu Su Arıtma- Gebze Emlak- Rampa- Rotary- Çorlu İnternet Sitesi- Çorlu Sürücü Kursu- Çorlu Sürücü Kursu- Şişli Avukat- Edirne Serbest Muhasebeci- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta- Kağıt Bardak- Kaplan Tekstil- Çorlu Perde- Çorlu Havuz- Makina- Danışmazlar-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden