Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Fonksiyonlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Fonksiyonlar Bir fonksiyonun, nasıl işlediğini veya aradığınız bir işleme uygun olup olmadığını bu başlık altında sorabilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 06-11-2017, 09:21   #1
kaya_vural
Altın Üye
 
Giriş: 02/11/2007
Şehir: kırıkkale
Mesaj: 39
Excel Vers. ve Dili:
Türkçe office 2003
Varsayılan Verileri tarihe göre sıralamak.

Merhaba, bir sayfadaki verileri istenilen şarta bağlı olarak başka bir sayfada göstermek istiyorum. Örnek dosya ektedir. Yardım edecek arkadaşlara şimdiden teşekkür ederim.
Eklenmiş Dosyalar
Dosya Türü: xlsx Parça Hareketi.xlsx (17.2 KB, 21 Görüntülenme)
kaya_vural Çevrimdışı   Alıntı Yaparak Cevapla
Eski 07-11-2017, 03:53   #2
Ömer BARAN
Uzman
 
Giriş: 08/03/2011
Şehir: ANKARA / İSTANBUL
Mesaj: 9,243
Excel Vers. ve Dili:
Office 2013 TÜRKÇE
Varsayılan

Merhaba, umarım yanlış anlamadım.

Öncelikle formül kolaylığı bakımından her iki sayfadaki ilgili başlıkların birebir aynı olmasını sağlayın.

► Yardımcı sütun kulanarak çözüm:
-- Veritabanı safası P5 hücresine aşağıdaki formülü uygulayın ve aşağı doğru liste boyunca kopyalayın.
.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(K5='Parça Hareketi'!$A$1;MAK($P$4:P4)+1;"")
-- Parça Hareketi sayfası A3 hücresine aşağıdaki formülü uygulayın ve BOŞ sonuç elde edinceye kadar sağa ve aşağı doğru kopyalayın.
Biçimlendirme ayarlarını (TARİH, SAYI gibi) düzeltin.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(SATIR(A1)>MAK(Veritabanı!$P:$P);"";İNDİS(Veritabanı!$I:$O;KAÇINCI(SATIR(A1);Veritabanı!$P:$P;0);KAÇINCI(A$2;Veritabanı!$I$4:$O$4;0)))
► Dizi formülü kulanarak çözüm:
-- Parça Hareketi sayfası A3 hücresine aşağıdaki formülü uygulayın ve dizi formülüne dönüştürün,
sonra da BOŞ sonuç elde edinceye kadar sağa ve aşağı kopyalayıp, biçimlendirme ayarlarını düzeltin.

Formülün dizi formülüne dönüştürülmesi:
-- Formülü hücreye yapıştırın,
-- Formülün yapıştırıldığı hücre seçiliyken F2 tuşuna basarak hücre içerisine girin,
-- CTRL ve SHIFT tuşları basılıyken ENTER tuşuna basın.
-- İşlem doğru yapılmışsa formül kendiliğinden {...} gibi köşeli parantez arasına alınır.


NOT: Veritabanındaki veri alanının satır sayısı belli ise aşağıdaki formülde $K:$K gibi tüm sütun yerine
$K$1:$K$1000 gibi alan sınırlaması yaparak formülün daha hızlı çalışması sağlanabilir.
.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(EĞERSAY(Veritabanı!$K:$K;$A$1)<SATIR(A1);"";KAYDIR(Veritabanı!$H$1;KÜÇÜK(EĞER(Veritabanı!$K:$K=$A$1;SATIR(Veritabanı!$K:$K));SATIR(A1))-1;KAÇINCI(A$2;Veritabanı!$I$4:$O$4;0)))
__________________
.
☾✭ İnadına TÜRKÇE ✭☽

-- Sorunuzu, gerçek belgenizle aynı yapıda ve olması gereken sonuçların elle yazıldığı örnek belge ile destekleyiniz.
-- ALTIN ÜYELİK öneriyorum. / FORUM KURALLARInı mutlaka okuyunuz.
-- ALTIN ÜYE olmayanlar, örnek belgeyi dosya.tc, dosya.co gibi bir siteye yükleyip, belgeye erişim adresini verebilir.
-- Özel mesaj ile soru sormayınız. / Geri bildirimde bulunulmayan cevaplarımı siliyorum.
Ömer BARAN Çevrimdışı   Alıntı Yaparak Cevapla
Eski 07-11-2017, 10:00   #3
kaya_vural
Altın Üye
 
Giriş: 02/11/2007
Şehir: kırıkkale
Mesaj: 39
Excel Vers. ve Dili:
Türkçe office 2003
Varsayılan

Alıntı:
Ömer BARAN tarafından gönderildi Mesajı Görüntüle
Merhaba, umarım yanlış anlamadım.

Öncelikle formül kolaylığı bakımından her iki sayfadaki ilgili başlıkların birebir aynı olmasını sağlayın.

► Yardımcı sütun kulanarak çözüm:
-- Veritabanı safası P5 hücresine aşağıdaki formülü uygulayın ve aşağı doğru liste boyunca kopyalayın.
.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(K5='Parça Hareketi'!$A$1;MAK($P$4:P4)+1;"")
-- Parça Hareketi sayfası A3 hücresine aşağıdaki formülü uygulayın ve BOŞ sonuç elde edinceye kadar sağa ve aşağı doğru kopyalayın.
Biçimlendirme ayarlarını (TARİH, SAYI gibi) düzeltin.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(SATIR(A1)>MAK(Veritabanı!$P:$P);"";İNDİS(Veritabanı!$I:$O;KAÇINCI(SATIR(A1);Veritabanı!$P:$P;0);KAÇINCI(A$2;Veritabanı!$I$4:$O$4;0)))
► Dizi formülü kulanarak çözüm:
-- Parça Hareketi sayfası A3 hücresine aşağıdaki formülü uygulayın ve dizi formülüne dönüştürün,
sonra da BOŞ sonuç elde edinceye kadar sağa ve aşağı kopyalayıp, biçimlendirme ayarlarını düzeltin.

Formülün dizi formülüne dönüştürülmesi:
-- Formülü hücreye yapıştırın,
-- Formülün yapıştırıldığı hücre seçiliyken F2 tuşuna basarak hücre içerisine girin,
-- CTRL ve SHIFT tuşları basılıyken ENTER tuşuna basın.
-- İşlem doğru yapılmışsa formül kendiliğinden {...} gibi köşeli parantez arasına alınır.


NOT: Veritabanındaki veri alanının satır sayısı belli ise aşağıdaki formülde $K:$K gibi tüm sütun yerine
$K$1:$K$1000 gibi alan sınırlaması yaparak formülün daha hızlı çalışması sağlanabilir.
.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞER(EĞERSAY(Veritabanı!$K:$K;$A$1)<SATIR(A1);"";KAYDIR(Veritabanı!$H$1;KÜÇÜK(EĞER(Veritabanı!$K:$K=$A$1;SATIR(Veritabanı!$K:$K));SATIR(A1))-1;KAÇINCI(A$2;Veritabanı!$I$4:$O$4;0)))
Çok teşekkür ederim Ömer Bey, emeğinize sağlık.
kaya_vural Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 06:03


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım - Tarot Falı - invest in turkey - Lingerie - Dyeing Machine - Karton Bardak- Çorlu Özel Eğitim- Site Yönetimi- Led Aydınlatma- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Kırklareli- Pronet Çerkezköy- Pronet Çorlu- Pronet Lüleburgaz- Pronet Keşan- Çorlu Araç Takip- Çorlu Su Arıtma- Boru Profil- Gebze Emlak- Beylikdüzü Temizlik- İstanbul Burun Estetiği- Bakır Sülfat- Rampa- Rotary- Çorlu İnternet Sitesi- youngblood- Çorlu Palet- Çerkezköy Palet- Çorlu Prefabrik- Çorlu Sürücü Kursu- Çorlu Sandviç Panel- Şişli Avukat- Korona Test Kalemi- Çorlu Vinç- Çorlu Pimapen Tamiri- Çorlu Çelik Konstruksiyon-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2017, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden