Excel Forum
ALTIN ÜYELİK Hakkında Bilgi


Geri Git   Excel Forum > EXCEL-Soruları > Fonksiyonlar
Atatürk
Şifremi Unuttum

DUYURU SİSTEMİ / REKLAM PANOSU

Fonksiyonlar Bir fonksiyonun, nasıl işlediğini veya aradığınız bir işleme uygun olup olmadığını bu başlık altında sorabilirsiniz.
Dosya ekleyebilirsiniz

Özel Arama


Yanıtla
 
Paylaş Konu Araçları Görünüm Modları
Eski 17-10-2017, 16:16   #1
aydgur
Altın Üye
 
Giriş: 31/10/2005
Şehir: İstanbul
Mesaj: 328
Excel Vers. ve Dili:
Excel 2007 Türkçe
Varsayılan İsimleri sadece bir kere yazdırabilmek

c sütününda malzeme adları var . benim yapmak istediğim
her biri ayrı ayrı tarihlerde satılan malzemelerin adlarını
h sütününa her malzeme cinsini sadece bir kere yazdırmak.
Bunu formül yada makro ile nasıl yapabilirim ?
Eklenmiş Dosyalar
Dosya Türü: xlsx Kitap11.xlsx (202.3 KB, 10 Görüntülenme)
__________________
Excel 2002
aydgur Çevrimdışı   Alıntı Yaparak Cevapla
Eski 17-10-2017, 17:00   #2
çıtır
Altın Üye
 
Giriş: 06/03/2005
Şehir: KDZ.EREĞLİ
Mesaj: 1,221
Excel Vers. ve Dili:
Excel Vers. ve Dili: Office 2016 TR 64 Bit
Varsayılan

Formülle; İsimler C2 başladığı varsayılmıştır.H2 Kopyalayınız.Formül cubuğuna tıklayıp ctrl ve shift tuşlarına basılı iken enter tuşlayınız.Başta { sonda } işareti oluşmalı sonra ihtiyaç kadar aşağı çekiniz.Dizi formülü.1 kez alır.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
=EĞERHATA(İNDİS(C$2:C$100;KAÇINCI(;EĞERSAY($H$1:H1;C$2:C$100);0);1);"")
çıtır Çevrimdışı   Alıntı Yaparak Cevapla
Eski 17-10-2017, 21:20   #3
antonio
Destek Ekibi
 
antonio kullanıcısının avatarı
 
Giriş: 13/02/2011
Mesaj: 1,112
Excel Vers. ve Dili:
Excel 2013
Varsayılan

Merhaba,
Benzersiz veriler listesi ile bu verilere ait toplam tl ve euro değerlerini de getirecek şekilde kod oluşturdum. Kodlarınız aşağıda, dosyanız ektedir.
Kod: (Rahat kopyalayabilmeniz için tüm kodu seçmenizi sağlar)
Sub verileri_benzersiz_yazdir()
Dim sh As Worksheet, ss As Long, z As Object, a, b(), i As Long, n As Long
Dim aranan As String

Set sh = Sheets("Sayfa3")
ss = sh.Range("C" & Rows.Count).End(3).Row
Set z = CreateObject("Scripting.Dictionary")
    z.comparemode = vbTextCompare
    ReDim b(1 To 3, 1 To 1)
    n = 0
    a = sh.Range("C2:E" & ss).Value
    For i = 1 To UBound(a, 1)
        If a(i, 1) <> "" Then
            aranan = a(i, 1)
            If Not z.exists(aranan) Then
                n = n + 1
                z.Add aranan, n
                ReDim Preserve b(1 To 3, 1 To n)
                b(1, n) = a(i, 1)
                b(2, n) = a(i, 2) * 1
                b(3, n) = a(i, 3) * 1
            Else
                b(2, z.Item(aranan)) = b(2, z.Item(aranan)) * 1 + a(i, 2) * 1
                b(3, z.Item(aranan)) = b(3, z.Item(aranan)) * 1 + a(i, 3) * 1
            End If
        End If
    Next i
    sh.Range("H1").Value = "Benzersiz Malzeme Adı"
    sh.Range("I1").Value = "Toplam TL"
    sh.Range("J1").Value = "Toplam EUR"
    
    sh.Range("H2:J" & Rows.Count).ClearContents
    sh.Range("H2:J" & Rows.Count).Borders.LineStyle = xlNone
    sh.Range("H2").Resize(z.Count, 3).Value = Application.Transpose(b)
    With sh.Range("H2:J" & z.Count)
            .Borders.LineStyle = 1
            .Font.Name = "Calibri"
            .Font.Size = 10
    End With
    MsgBox "İşlem tamamlandı.", vbInformation, "antonio"
End Sub
Eklenmiş Dosyalar
Dosya Türü: rar aydgur-fonk-verileri benzersiz yazdir.rar (108.9 KB, 8 Görüntülenme)
__________________
Özel mesaj sistemini devre dışı bıraktım.
Yardım istemeden önce Forum Kurallarını okuyunuz.
Aynı konuyu farklı bölümlerde açanların sorularını yanıtlamıyorum, bu durumu fark etmeden yanıtlamışsam, mesajımı siliyorum.
antonio Çevrimdışı   Alıntı Yaparak Cevapla
Eski 18-10-2017, 18:14   #4
aydgur
Altın Üye
 
Giriş: 31/10/2005
Şehir: İstanbul
Mesaj: 328
Excel Vers. ve Dili:
Excel 2007 Türkçe
Varsayılan

İyi akşamlar , çok teşekkür ederim.
=EĞER(K3="TL";J3);EĞER(K3="EUR";J3*G3;EĞER(K3="USD ";K3*G4)) Bu formül DEĞER hatası veriyor , nasıl engelleyebilirim ?
__________________
Excel 2002
aydgur Çevrimdışı   Alıntı Yaparak Cevapla
Yanıtla


Konu Araçları
Görünüm Modları

Gönderme Kuralları
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is Açık
SimgelerAçık
[IMG] kodu Açık
HTML kodu Kapalı


Saat 04:27


Bu forum Elit NET - www.elitnet.com.tr tarafından sunulmaktadır.

Excel Eğitimi - Mobil Uygulama - Çorlu - Çorlu Web Tasarım -- Beylikdüzü mali müşavir - Lingerie - Dyeing Machine - Karton Bardak- Karton Bardak- Çorlu Dil ve Konuşma Terapisti- Çorlu Dil ve Konuşma Terapisti- Çorlu Özel Eğitim- Site Yönetimi- Pronet Tekirdağ- Çorlu Kamera- Pronet Edirne- Pronet Çorlu- Çorlu Araç Takip- Çorlu Su Arıtma- Gebze Emlak- Rampa- Rotary- Çorlu İnternet Sitesi- Çorlu Sürücü Kursu- Çorlu Sürücü Kursu- Şişli Avukat- Edirne Serbest Muhasebeci- Çorlu Etüt- İstanbul Botanik- Çorlu Sigorta- Kağıt Bardak- Kaplan Tekstil- Çorlu Perde- Çorlu Havuz- Makina- Danışmazlar-
Powered by vBulletin Version 3.7.2
Copyright ©2000 - 2018, Jelsoft Enterprises Ltd.
Advertisement System V2.6 By   Branden